Support » Plugin: Jetpack by WordPress.com » Jetpack server could not communicate with your site’s XML-RPC URL

  • Resolved passegua

    (@passegua)


    The Jetpack server could not communicate with your site’s XML-RPC URL

    I activate Jetpack plugin but when I click on “configure it” I get this error:

    “The Jetpack server could not communicate with your site’s XML-RPC URL. If you have the W3 Total Cache plugin installed, deactivate W3 Total Cache, try to Connect to WordPress.com again, reactivate W3 Total Cache, then clear W3 Total Cache’s cache.”

    But I do not have any W3 Total Cache plugin installed.

    So how could I use Jetpack?

    Thanks.

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Support darnelldibbles

    (@darnelldibbles)

    Hi there,

    Did you have the W3 Total Cache plugin installed at any point? And if so, did you completely delete the plugin?

    https://www.webnots.com/how-to-completely-delete-w3-total-cache-plugin/

    You may have uninstalled or deactivated the plugin, but I would make sure that all files created were removed from the backend.

    Thanks,

    passegua

    (@passegua)

    I never had that W3 Total Cache plugin.
    Never.

    passegua

    (@passegua)

    Eventually I understood where is the problem:

    https://infinityfree.net/support/javascript-error-using-api-or-mobile-android-app/

    My free web host blocks xmlrpc access.

    Too bad.

    Plugin Support darnelldibbles

    (@darnelldibbles)

    Hi there,

    You can you ask your hosting provider if they have a block in place to stop access to the XMLRPC file, or to API Calls and ask them to disable this security measure temporarily? This is a common occurrence with hosts and they would be familiar with the request to unblock/disable as well.

    Thanks,

    passegua

    (@passegua)

    Unfortunately no.

    They wrote this in their FAQ:

    Can I disable this security system?

    No, this security system is mandatory on all websites and cannot be disabled.

    If this security system means your website or application does not work as expected on InfinityFree, please consider to moving your website to premium hosting. On premium hosting, this security system is not present (your website will be protected in less obtrusive ways), so you can access your website through other clients which are not browsers (like mobile apps, automated verification tools, etc.).

    Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

    Well, that’s pretty definitive then.

    Unfortunately, blocking XML-RPC is not a great solution for fighting security risks. It’s akin to selling your car because you don’t want it to be stolen.

    Your site’s XML-RPC file is kind of like a communication gateway to your site. Jetpack, the WordPress Mobile Apps, and other plugins and services will use this file to communicate to your site. If this is blocked, you will have other issues pop-up down the road for the same reasons.

    The most popular hosting providers out there have managed to find other ways to protect their servers without having to hinder your site and your ability to use services with WordPress.

    You don’t have to move to their Premium product though. We have some recommended hosting providers at https://jetpack.com/hosting/ and WordPress has some recommended hosting providers at https://wordpress.org/hosting/

    Neither of them block XML-RPC.

    If you do move to a new hosting provider, you can find the documentation for this at https://wordpress.org/support/article/moving-wordpress/#moving-to-a-new-server

    I am having the same problem here and the same message on a new WP site, when I try to setup Jetpack. Never installed W3 Total Cache, but the error message is:

    The Jetpack server could not communicate with your site\’s XML-RPC URL. If you have the W3 Total Cache plugin installed, deactivate W3 Total Cache, try to Connect to WordPress.com again, reactivate W3 Total Cache, then clear W3 Total Cache\’s cache.

    I am running WordPress on a virtual box in Upcloud and there is no blocking for my xmlrpc API. Strangely enough, other WP sites on the same box have Jetpack installed and are working fine. I disabled all plugins in the new WP site, but no success. Can’t figure out what could be the problem.

    Any thoughts?
    Thanks.

    Plugin Support KokkieH

    (@kokkieh)

    @@sorinsfirlogea, please don’t post into old, resolved threads created by other people. It’s also impossible to troubleshoot this without being able to look at your site.

    Please open your own thread, or submit a support ticket at https://jetpack.com/contact-support/?rel=support, and include a link to your site, and we can take a look.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.