Support » Fixing WordPress » Jetpack ruined my site

  • Yesterday I upgraded to the latest version of Jetpack. Today I visited my page and everything but the header and my navigation bar at the top had disappeared. I deleted all of the plugins I wasn’t using and also deactivated active plugins. I found that the issue was Jetpack.

    My content returns when I deactivate Jetpack, but my site is still not functioning fully, no matter what I try. For example, the copyright that used to be in the bottom right corner of my page does not show up. The social bookmarking links that I had at the end of my posts also don’t show up. In my sidebar, my most recent posts and my most popular posts don’t show up. I understand that the most popular posts may be tied to stats which wouldn’t work if I have deactivated Jetpack. But the rest, I don’t understand, and I’ve even tried to install another social bookmarking plugin to see if that would work, and it still didn’t.

    Please help!

    My site is:

Viewing 14 replies - 1 through 14 (of 14 total)
  • Anybody out there? My site is still not fully working the way it should. Does anyone know if going back to an old version of Jetpack will fix this issues? Everything was fine before the upgrade. If that is possible, how to I do it?

    Hi girlunstoppable

    I’ve never heard of Jetpack causing this. Of course anything is possible when it comes to programming.

    I have a hunch but you probably won’t like it. (and I hope I’m wrong) If you’re around here right now could you activate the plugin then let me know so I can have a look?

    Thanks for looking at this. I reactivated jetpack just now and my content’s gone again. Don’t want to leave it like this for too long. I’ve subscribed to this thread, so please let me know when you’re done checking it out so I can deactivate jetpack again.

    Are all modules active?

    Sorry, not sure what means :/

    I don’t use Jetpack but doesn’t it have several features or modules or something that can be individually activated?

    Oh… Out of 11 modules, there are three that have a prompt to activate them. I guess that means the rest must be activated, even though I really only use Jetpack for Stats.

    Oh, I just figured out how to deactivate the individual elements of Jetpack and one of them was causing the content to disappear. Not sure which one yet. Some of the plugins and sidebar widgets are still gone though! Any ideas?

    Hmmm, I could have sworn I saw a suspect iframe in your source code. Make sure all elements of Jetpack are active. For that matter make sure all plugins are active.

    Okay, I reactivated all of the Jetpack elements and activated all my other plugins with the exception of the Stats I used before it stopped working and Jetpack took over. They cannot be activated simultaneously. Should I delete the Stats plugin? I just want to make sure it won’t have an effect on my stats history before I do that.

    By the way – I think the Jetpack element that was causing my content to disappear is “Shortcode Embeds”

    Okay, you may as well as deactivate it. I’m going to give you some reading. Have a look at Esmi’s response in this thread.

    I’m going down the path that you may have been hacked because earlier I saw this in your source code (although it hasn’t yet returned) …

    <iframe src='' width='1' height='1' frameborder='0'>

    I have no idea what that is but I don’t like the look of it.

    Okay. Thanks for your help. I don’t have time to look into this right now – is this something that could get worse? And is there anything I should do in the meantime before I get a chance to address it?

    I suppose for the immediate time being you could change ALL passwords but that’s not necessarily how they got in to begin with.

    I haven’t found any info via Google on that weird URL but as I say I really don’t like it.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Jetpack ruined my site’ is closed to new replies.