Jetpack by WordPress.com
[resolved] Jetpack Publicize stopped working (7 posts)

  1. Estrella
    Posted 1 year ago #

    Hi. I've been using the Publicize function from Jetpack to publish my posts to Twitter and Facebook for a long time, and recently I noticed it stopped working. I didn't install any new plug-ins. In fact, I hadn't been active in my WordPress admin for a while at all. I only updated some plug-ins, also Jetpack.

    So the publicize function stopped working for both Twitter and Facebook. Deactivated the Twitter and Facebook connections and added them again, but no difference. Even added a Google+ connection. This one published a post the first time after it was added, but after that no more.

    I really don't know how I could solve this problem. Hope you could help me.
    My website is http://www.estrellaweb.nl. Using all latest versions of the plug-ins I use.


  2. quickim
    Posted 1 year ago #

    I'm experiencing the same problem for the past 3 days - publicize has stopped publishing to fb & twitter

  3. Estrella
    Posted 1 year ago #

    JetPack just released an update few days ago. It statet that it solved the Publicize problem. At first there was no difference, ben when I unlinked my social media accounts and relinked them again, I did 2 test posts (one of them was a planned one) and they both were publiced by Jetpack. Noting that I tried to remove and add my accounts before, the update finally fixed the problem for me. Hope it works for you as well!

  4. quickim
    Posted 1 year ago #

    Tnx for the update RebelStar, however I suspect the problem still exist especially when I schedule deferred publishing - have you tried to schedule any of these post by any chance?

    Never the less, I will try to relink my FB account (although I'm pretty sure I've tried that after the last update) and update again.

    Anyone else still experiencing any problem this?


  5. Estrella
    Posted 1 year ago #

    Hi, I tried two test post, one of them was scheduled. I specifically did thid, because 90% of my posts are scheduled and it worked.

    But I have to say, this morning when a post was scheduled for 8am, it did publish in Twitter, but not on Facebook, while that did work while I was testing.

    I think we can say Jetpack is having some strange behaviour in context to Facebook publishing...

  6. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Hi Estrella!

    I've taken a look at your site, and everything look good:


    No errors here:


    Do you still have issues with Publicize?

    quickim: Could you please start your own thread, as per the Forum Welcome? Make sure to include your site's URL.


    Thank you!

  7. Estrella
    Posted 1 year ago #

    It started working again normally, fortunately.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Jetpack by WordPress.com
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic