WordPress.org

Forums

[resolved] Jetpack publicize Error code: -32301 (7 posts)

  1. therfive
    Member
    Posted 1 year ago #

    Brand new domain on bluehost, did a wordpress install that came with jetpack plugin (2.9.2) installed. Tried to connect to social accounts in publicize settings and am getting the Error code: -32301.

    I've seen several other posts on here on the topic and have tried a few things but so far no luck.

    I deactivated / reactivated jetpack, uninstalled jetpack and reinstalled manually by downloading the zip, deactivated basically all other plugins... still no luck.

    Domain is rfivemainline.com

    Went to: rfivemainline.com/xmlrpc.php?for=jetpack

    and it returns: XML-RPC server accepts POST requests only.

    I installed jetpack compatibility plugin and the results all say Code: 200 Message: OK

    I'm running the Twenty Eleven theme.

  2. therfive
    Member
    Posted 1 year ago #

    Just submitted a jetpack support request through the jetpack -> help menu.

  3. therfive
    Member
    Posted 1 year ago #

    No reply yet from the Jetpack support team (they probably don't work on the weekends). I did speak with my hosting provider and they don't see anything that would be blocking the connection on their end. They confirmed they're running an apache web server.

    I also tried issuing the curl command:

    curl -i -H 'Content-Type: text/xml' --data '<?xml version="1.0&"?><methodCall><methodName>demo.sayHello</methodName><params></params></methodCall>' 'http://rfivemainline.com/xmlrpc.php'

    And I got back: Hello!

    So it seems to be connecting, but still no luck on the publicize options.

  4. therfive
    Member
    Posted 1 year ago #

    I'm running out of ideas to try. Any help would be appreciated :)

  5. therfive
    Member
    Posted 1 year ago #

    It looks like it miraculously started working this morning... I didn't really change anything, just tried again. Not sure if the jetpack support did anything or it just decided to behave better.

  6. Pattie Reaves
    Member
    Posted 11 months ago #

    I have the same issue ... but it hasn't mysteriously started working. We're on a WordPress MU installation. That CURL request works for me, too.

    Any ideas?

  7. TKList
    Member
    Posted 1 week ago #

    Disabling CloudFlare plugin in WordPress and pausing CloudFlare on their site worked for me.

Topic Closed

This topic has been closed to new replies.

About this Topic