Jetpack by WordPress.com
Jetpack: Publicize (10 posts)

  1. boscardin
    Posted 2 years ago #

    I upgraded to 3.7 today and tried to make a post. The post did not show up on Facebook and I tried a couple of test posts as well. I have very few active plugins:
    * Jetpack, 2.5
    * Akismet, 2.5.9
    * User Role Editor, 4.6

    Currently using the Koi theme: http://themify.me/themes/koi

    I deactivated, reactivated the Jetpack plugin. Re-connected my Facebook account, but nada. This plugin was working as of October 24 (the last post), prior to my upgrading to 3.7.


  2. W-P-Zar
    Posted 2 years ago #

    Same problem on my site.

  3. Jeremy Herve
    Jetpack Mechanic
    Plugin Author

    Posted 2 years ago #

    Could you post your site URL here, so I can have a look?

    If you want it to remain private, you can also contact us via this contact form:

  4. boscardin
    Posted 2 years ago #


  5. Jeremy Herve
    Jetpack Mechanic
    Plugin Author

    Posted 2 years ago #


    I checked your Jetpack settings, and noticed an error related to your domain name servers. You seem to be using the following name servers:

    1. antares.starcon.com.
    2. ns1.blackboxhq.ca.

    The first name server does seem to return an error, and create connection issues between your site and WordPress.com.

    If your site is hosted with blackboxmedia, you might not need this name server at all. Could you contact your hosting provider and ask them to have a look?


  6. boscardin
    Posted 2 years ago #

    The server does not use those nameservers to perform lookups. Are there logs somewhere to see if there's a failure?

  7. Jeremy Herve
    Jetpack Mechanic
    Plugin Author

    Posted 2 years ago #

    The problem actually happens on WordPress.com servers, when we attempt to communicate with your site. Every time you publish a new post, your site has to let WordPress.com know about the post before the WordPress.com pushes it to Facebook. That's where things seem to fail right now, because WordPress.com cannot communicate back with your site because of the problematic name server associated to your domain.

    Removing it, and replacing it with a valid name server should help.

  8. boscardin
    Posted 2 years ago #

    My host said he looked into it, "fixed" it (I forgot what he said exactly in what that meant). I don't know if I was explicit in the first post, but this plugin was working prior to my upgrade to 3.7.

  9. boscardin
    Posted 2 years ago #

    New information:
    Tried these different tests:

    Test #1:
    Unlinked FB account: removed wordpress.com from FB and removed FB from wordpress.org blog. Re-linked FB accounts.
    No posts to FB

    Test #2:
    Unlinked WP.com, unlinked FB account. Deleted plugin from W.org blog. Reinstalled plugin on W.org blog. Relinked wp.com and FB account.
    No posts to FB.

    Test #3:
    Installed Jetpack on another W.org. Linked it to the same FB account and same WP.com account. Created test post.
    *This W.org blog is actually the main domain hosted. The blog that is experiencing issues is an add-on domain.

    What puzzles me most is that it was working and then one day, it wasn't, without my having changed any settings on any piece of the blog, domain, hosting, settings, etc.

  10. Jeremy Herve
    Jetpack Mechanic
    Plugin Author

    Posted 2 years ago #

    I had another look at your site: the name server error is now gone, that's good news.

    However, your site doesn't seem to be connected to WordPress.com anymore. Could you go to the Jetpack menu in your dashboard, and reconnect to WordPress.com there?

    If you still experience issues, can you please use Jetpack's Debugger module to send us some more information about your site?

    1) Go to the Jetpack page in your dashboard.
    2) Click on the Debug link appearing at the bottom of the page.
    3) Click the link that says "click here to contact Jetpack support."
    4) Fill in the description box and your name and email address.
    5) Click the "Contact Support" button.


Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Jetpack by WordPress.com
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic