Support » Plugins » Jetpack publicise, wrong image, Facebook and Google Plus

  • Resolved DustyGhost

    (@dustyghost)


    For the last couple of weeks I have been frustrated that the post just added is showing the featured image of the post before.

    EG
    1) Post 1 created with Featured image.
    2) Publicise sends to FB and G+
    3) Next post 2 is created with featured image.
    4) Post 2 publicised to FB and G+
    5) Post 2 on FB and G+ now shows the wrong image!!

    dustyghost.com is my site
    I have had to fix the FB and G+ site pages (as these are so public)
    However I have left my own G+ page with the problem so you can see it. HERE

    If you look at the post that says “Digger and Snuff: Talking” you will see this is using the image from the post before.

Viewing 15 replies - 1 through 15 (of 23 total)
  • anyone?

    Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    When you share a post on Facebook and G+, or when Jetpack Publicize publishes a post to your Facebook page or G+ Profile, Facebook and Google+ crawl the page and look for Open Graph meta tags in the head to build a complete post preview (with an image, title, description, …).

    Jetpack automatically creates these Open Graph Meta tags for you unless you already use another Open Graph plugin, in which case we let the other plugin handle things. Looking at your site, you seem to be using the WordPress SEO plugin to handle Open Graph meta tags, but you haven’t configured the plugin yet. You’ll want to go to SEO > Social to configure your Open Graph meta tags.

    I hope this helps.

    P.S.: In the future, if you have more questions about Jetpack, it’s best to post in the Jetpack support forums here:
    http://wordpress.org/support/plugin/jetpack

    noted on the Jetpack forums. Thanks for the heads up. 🙂

    In the SEO -> Social settings I have turned off the “Add Open Graph meta data” for now, as this is a big grey area with me and I obviously have not set it correctly. Will see if I can find an article on how to use the settings properly.

    I turned this off just before my last post went live, and it seems to be the correct images are showing. At least for now.

    Again when I get a chance I’ll read up on Open Graph tags and how to use them properly.

    Thanks Jeremy, as ever you’re a great help! 🙂

    Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    As long as you leave the Open Graph meta tags off, the results will be quite random: if Google and Facebook can’t find meta tags when crawling your posts, they take a random image from the page. It could be an image from your sidebar or your site logo though, so using Open Graph meta tags usually gives much better results.

    If you don’t want to use WordPress SEO’ Open Graph tags, you could leave the checkbox unchecked under SEO > Social, and force Jetpack to inject its own meta tags even if the WordPress SEO plugin is active. This way you won’t have to bother with this and Jetpack will take care of everything for you.

    To do so, activate this plugin:
    https://wordpress.org/plugins/always-use-jetpack-open-graph/

    Great! will try that out over the next few days and let you know if I get further issues.

    Mark

    This has gone wrong today again. I turned off the SEO setting to include Open Graph tags, and installed the always-use-jetpack-graph plug-in.

    If you go here:
    https://www.facebook.com/DustyGhostDotCom

    You will see a link post: Latest “Digger and Snuff comic: Snowboarding “
    It is supposed to show the featured image from this post (comic post type):
    http://dustyghost.com/comic/digger-and-snuff/digger-snuff-snowboarding/

    This is showing an image from another post.
    I think this image may have been picked up from the “Related posts” section at the bottom of the page.

    looks like Google+ has the correct image though.

    Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    The problem comes from your theme, Comic Easel: it includes its own Open Graph image tag, as defined here:
    https://plugins.trac.wordpress.org/browser/comic-easel/trunk/functions/injections.php#L354

    Jetpack also includes a set of Open Graph meta tags, thanks to the always-use-jetpack-graph plugin.

    Since Comic Easel includes that image tag before the tags that are added by Jetpack, Facebook tries to use that image in the post preview.
    Unfortunately, and as you can see in the code, Comic Easel uses thumbnail images to build its image tag. That’s a problem because Facebook requires images to be larger than 200x200px to be used in post previews. Since your thumbnails are 150x150px, Facebook ignored the image tag added by Comic Easel and picked a random image on the page.

    To solve this issue, I would suggest that you remove the tags added by the Comic Easel theme. Since Jetpack also takes care of adding Twitter meta tags to your site you don’t need any of the tags added by Comic Easel. You should be able to remove the tags with this code:

    remove_action('wp_head', 'ceo_social_meta');

    I’ve also let the Comic Easel author know about the problem, so he can take a look.

    Frumph (the author) is pretty good, so he’ll no doubt solve this for the next release.

    I’ll add this to the functions.php in my child theme.

    Thanks again Jeremy.
    As ever you are helpful and patient.

    Mark

    Alternatively you could just go to settings -> media and change your thumbnail size and width to that of which is greater then 200x200px or equal to.

    Then use a thumbnail rebuild plugin to redo your thumbs and you’re golden.

    Just so you know, it looks like Comic Easel caused the issue from the start.

    I added the remove_action('wp_head', 'ceo_social_meta'); code to my functions.php file. And the og:image tag now shows the correct image, not a thumbnail.

    I also experimented:

    I just turned the setting back on in WordPress SEO -> Social
    and I disabled the always-use-jetpack-graph pluggin.

    The Open Graph tag now shows as this:`
    <meta property=”og:image” content=”http://dustyghost.com/wp-content/uploads/2014/07/Snow_upload_asd.jpg&#8221; />`

    So as you can see, it would appear SEO is not to blame for this.
    However I have not included a default image for posts with no images at all. So will set that now.

    Thanks Frumph! I’ll give that a go too.

    So not an issue with Comic Easel, but an issue with my settings. 🙂

    It’s good to have you guys around. Thanks both of you!

    Starting to get a bit frustrated now.

    Since the new Jetpack upgrade I now have the wrong image being picked up again!!

    https://www.facebook.com/DustyGhostDotCom
    Look at teh post sent on the 7th August.
    Wrong image!!!

    I see that you have changed the way the OG tags work in this update.
    However I can only see OG tags added my Comic Easel.

    So I don’t get why this was working and is now not working. 🙁

    SEO open graph are off.
    And my images have all got thumbs resized to 200 x 200

    So on this page:
    http://dustyghost.com/comic/digger-and-snuff/digger-snuff-console/

    This is my image tag:

    <meta property="og:image" content="http://i2.wp.com/dustyghost.com/wp-content/uploads/2014/07/Games_upload_edf.jpg?resize=200%2C200" />

    Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Since you use the WordPress SEO plugin, Jetpack’s Open Graph meta tags are automatically deactivated. Jetpack currently doesn’t have any control over the tags used on your site.

    You should be able to solve this issue by either activating WP SEO’s tags, or changing the image being used by Comic Easel.

    Jeremy,

    I don’t mean to sound ungrateful for your hard work to help out with the Open Graph tags, but I have turned off the WordPress SEO option to include their tags.
    So before the last update, when Jetpack was putting in the open graph tags (even with Comic easel adding some too) this was all working for me.

    Now you have taken your tags out, this is not working for me.

    It would have been nice to have a flag that would let me chose if Jetpack should add them in or not, rather than taking that decision out of my hands.

    I am very confused now. Comic easel is posting the correct image to the og tag, it’s 200 px at least.

    I have just run the Facebook debugger on the page I last had issues with and that is not showing a problem?

    https://developers.facebook.com/tools/debug/og/object?q=http%3A%2F%2Fdustyghost.com%2Fcomic%2Ff-d-m-idget%2Ff-d-m-idget-problem%2F

    So how is it that using publicise I seem to get the wrong image on my FB page?

    Yet when I use the share button on the site directly or the FB debugger this all seems to work correctly?

    Sorry, but I am getting a little confused.

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘Jetpack publicise, wrong image, Facebook and Google Plus’ is closed to new replies.