Support » Theme: Sela » Jetpack Problems – Header Image Won’t Show Up

  • Resolved jessi.webb

    (@jessiwebb)


    Jetpack had some kind of critical error that killed my website yesterday. Bluehost helped me to login and disable Jetpack, but now my header image/logo won’t show up. The image is still in the media library. I tried uploading the image again, but it still doesn’t display. I’m assuming not having Jetpack is the problem, but when I reinstall Jetpack my site crashes again. Any suggestions? Thank you.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • darnelldibbles

    (@darnelldibbles)

    Hi there,

    Was the Jetpack issue in reference to the critical error that has been affecting many Jetpack sites on Bluehost?

    If so, we are looking into the issue here:

    https://wordpress.org/support/topic/e_compile_error-was-caused-in-line-41/page/4/

    Please take a look and let me know if the error you have is related. If so, it is affecting quite a few people and we are looking into a fix ASAP.

    Thanks,

    Thank you, but I don’t think it’s quite the same as the link provided. I have my site working now and Jetpack reinstalled, but the header still won’t show up. I deleted and uploaded it again under ‘Themes-Customize’ and I looked through my Custom CSS and Child Theme files to try to find a problem, but I don’t see anything that would be causing it not to show up. Any help would be much appreciated. Thanks.

    Hi there!

    I can see an error with the Jetpack connection on your site. It would be best to try and fix this first as it may cause many issues on your site.

    The problem I mentioned seems to be with the XML RPC endpoint on your site.
    Problems accessing XML RPC could be due to another plugin, a security module, or a block on your server. As a first step to fixing this, I’d recommend contacting your host to see whether they block XML RPC and if so, to unblock it for Jetpack (they can find our IP range here https://jetpack.com/support/hosting-faq/).
    If you’re still having issues after that, please post to https://wordpress.org/support/plugin/jetpack/ so we can have a closer look.

    Thank you. I checked with Bluehost and they said that XML RPC was not blocked on their end. Still checking into how to fix it with Bluehost tech support. I’ll post an update if I get anywhere. Other suggestions welcome. 🙂

    Hi there,

    The problem is caused by CSS in the child theme.

    It sets the background for the header to white, which overrides the theme’s CSS to add the image as a background.

    Here’s the CSS rule in the child theme that’s causing the problem:

    /* Site Header */
    .site-branding {
    	background: #fff;
    	background-position: center;
    	background-repeat: no-repeat;
    	text-align: center;
    	height: 100%;
    	min-height: 160px;
    	padding: 1.5em 0 18px;
    	text-align: center;
    	-webkit-background-size: cover;
    	-moz-background-size: cover;
    	-o-background-size: cover;
    	background-size: cover;
    }

    If background: #fff; is deleted from that rule, the background header image will appear.

    If you’d then like more of the image to appear so that it’s not cut off, I’d recommend also changing the CSS to use contain for the background size instead of cover.

    I hope this helps 🙂

    @gary-barrett – You’re amazing! THANK YOU! Problem solved.

    You’re welcome, glad I could help 🙂

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.