WordPress.org

Support

Support » How-To and Troubleshooting » Jetpack problem: "invalid_signature: The timestamp is too old."

Jetpack problem: "invalid_signature: The timestamp is too old."

  • Tatiane Pires
    Participant

    @tatianeps

    I was trying to fix the “Your WordPress.com account is not authorized to view the stats of this blog” issue. Since many people are saying that installing Jetpack (jetpack.me) would fix it, I tried this new plugin.

    First I deactivated WordPress.com Stats, then I installed Jetpack and authorized the Stats module with my wordpress.com account. Everything should be fixed and stats should be up and running again (as far as I’ve read in the forums).

    Now the issue is when I access /wp-admin/admin.php?page=stats on my blog it only shows the following message:

    invalid_signature: The timestamp is too old.

    How can I fix it?

Viewing 15 replies - 1 through 15 (of 15 total)
  • Your server’s clock is probably not set correctly. A future version of Jetpack will probably work around this problem. In the meantime, setting your server’s clock to the correct time should fix the issue.

    What’s the URL of your site?

    Tatiane Pires
    Participant

    @tatianeps

    @ mdawaffe

    My blog is http://tatianeps.net

    @tatiane: confirmed. Your server thinks the current time is
    Fri, 18 Mar 2011 16:55:25 GMT
    when it is actually
    Fri, 18 Mar 2011 18:13:50 GMT

    If you don’t know how to update your server’s time, I suggest contacting your host.

    Tatiane Pires
    Participant

    @tatianeps

    @ mdawaffe

    I seem to be on a dead end now, because support on my host is taking way to long to answer requests. =(

    Is it something I can change on my own? Or do I depend on the host to change some server configuration?

    There is probably nothing you can do on your own. We hope to release a new version of the Jetpack plugin next week that will address this issue.

    Tatiane Pires
    Participant

    @tatianeps

    @ mdawaffe

    In the meantime, I’ll rely only on Google Analytics. Hopefully Stats will be up and running here soon.

    Thanks!

    Tatiane Pires
    Participant

    @tatianeps

    I’ve just updated Jetpack to version 1.1.1, but the problem persists. Message: “invalid_signature: The timestamp is too old.”

    Same issue here. My web host is not very supportive to set the server clock correctly. They keep telling that their servers clock are correct, but it is ~14 minutes older than the official time.

    Tatiane Pires
    Participant

    @tatianeps

    I was still without site stats from Jetpack because this issue with server timestamp. So I deactivated Jectpack and installed again WordPress.com Stats.

    I decided to try it out just to take the chance, my surprise is that WordPress.com Stats is working just fine now and I can see the visits of Friday (March 18, when the plugin stopped to display info on my dashboard) and of the weekend.

    I’ll stay with WordPress.com Stats until the timestamp issue is solved. It seems that Jetpack is aimed for self-hosted WP blogs.

    Nah, that is just a very interesting coincidence…

    Tatiane Pires
    Participant

    @tatianeps

    @ lealcy

    I know. I just posted it here because it may help more people to know that the WP.com Stats is back. I believe people at WP.com are working on that.

    Digital Soup
    Member

    @peterjeshua

    Same error here. invalid_signature: The timestamp is too old.

    Daniel
    Participant

    @dnlb2

    Same error, How can i know the know my server’s time?

    freepresscoop.net

    @daniel, just create a php script with the code below:

    <?php echo date(‘r’);

    When you run it, it will show you the current server time.

    Daniel
    Participant

    @dnlb2

    @lealcy, Thanks I’ll try before write to the hosting company.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Jetpack problem: "invalid_signature: The timestamp is too old."’ is closed to new replies.