Support » Plugin: Jetpack by WordPress.com » Jetpack Post By Email

  • Resolved jamiers

    (@jamiers)


    This is driving me crazy. I really want to use the Post By Email feature within Jetpack and I have generated by private email address through WordPress.com. I have sent mail to the address from a couple different accounts, and it never comes into my private WordPress web site (either in pending or actually posted).

    What could I be doing wrong? Anyone have any ideas on where to start?

    I see some other Post by Email posts, but they aren’t related (I think).

    Jamie

    http://wordpress.org/extend/plugins/jetpack/

Viewing 15 replies - 1 through 15 (of 27 total)
  • I have the exact same problem. If I find a solution I’ll post what I find.

    Plugin Contributor Jeremy Herve

    (@jeherve)

    Could you post your site URL here, so I can have a look?

    If you want it to remain private, you can also contact us via this contact form:
    Contact

    http://www.windchilde.com/bluedepth

    I also had a previous issue with Jetpack connecting to WordPress.com, but it looks as though iPage fixed it because Jetpack works as it always has… Just mention it since you might have seen my site before in that other ticket… 🙂

    Thanks

    Plugin Contributor Jeremy Herve

    (@jeherve)

    Could you try to use Post By Email again, now that your connection issue is fixed?

    Same problem here as well. I have used different email accounts but no luck with the post via email option.
    My account seems to be successfully connected to my wordpress.com.

    Any suggestions?

    Thank you

    Plugin Contributor Jeremy Herve

    (@jeherve)

    @mlazopoulou I replied to your email.

    Has anyone managed to make this work? I’ve tried all the troubleshooting suggestions from here

    I’ve connected and disconnected from wordpress.com and also I have regenerated the email address but no luck at all!

    Any other suggestions?

    Thank you!

    I’ve tried since I got my Jetpack working with WordPress.com (thanks to iPage, gah) from my wmich.edu account, my gmail.com account and my windchilde.com account and not a single test post has appeared on my blog. :/

    all the other jetpack features are working on my blog (such as subscribe via email to this blog etc) so this means that I am connected to the service! However the most wanted feature (post via email) is dead for some reason…. 🙁

    i’ve tried everything…
    Even a vanilla installation of wordpress! I am connected to wordpress.com as I’m able to use the sharing buttons (publisize) and the stats.
    My wordpress installation is public.

    No luck though with the post by email. I think it is the only thing that is not working on jetpack!

    Help please!

    Feels like I’m talking to my self but maybe I will help somebody else as well!

    Solution found!

    on my server I have changed the default PHP version from 5.2 to 5.3

    It works!

    I can confirm that changing the default PHP version from 5.2 to 5.3 has worked for me also. The system does not send me a confirmation email that it was posted, but the post does arrive properly on my blog.

    Any chance that this little bit could be included as a requirement on the Post By Email instructions?

    Thanks!

    Plugin Contributor Jeremy Herve

    (@jeherve)

    Any chance that this little bit could be included as a requirement on the Post By Email instructions?

    WordPress requires PHP version 5.2.4 or greater, so you shouldn’t run into issues if your server uses a greater version. Is it possible that your server used PHP 5.2.3 or an earlier version?

    @jeremy I am running at least 8 installations of wordpress on the server and they were running absolutely fine with the previous settings… so it wasn’t something obvious for me.
    Also in your email you mentioned
    – that I wasn’t connected ( I was because all the other features were working)
    -that it didn’t work because the blog was private (on one of the blogs that I was trying to make it work) Im using private wordpress plugin, but it worked as soon as I’ve made this change to the server.

    On this page it says

    A web host that uses PHP 5. Jetpack follows the WordPress host requirements.

    So because wordpress was running fine I didn’t check the link.

    Hope this helps
    M

    iPage just says 5.2, it doesn’t break it down any further than that. Much like miazopoulou, everything else worked just fine on all the WP.org blogs I run so I didn’t even give it any thought. But going to 5.3 did the trick and eliminated the guesswork for which sub-version of 5.2 was actually in play. If I were a user, I’d prefer a little fibbing and read “Only works with PHP 5.3” that way I knew I didn’t have to email my host back and forth asking picky questions. *shrug*

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘Jetpack Post By Email’ is closed to new replies.