Support » Plugin: Jetpack by WordPress.com » Jetpack plugin not connecting after migration

  • Resolved sunilwilliams

    (@sunilwilliams)


    I’m trying to connect jetpack.

    I’ve migrated the site from one server to another.
    After the migration, jetpack was in development mode.
    When I took it out of dev mode, jetpack asked me if if the current site was a new home for the same domain. I confirmed.

    Next I tried to connect jetpack normally:

    From the “Welcome to Jetpack” screen, I can see the invitation to connect jetpack.

    ie, there is text saying “Please connect to or create a WordPress.com account to start using Jetpack. This will enable powerful security, traffic, and customization services.”. Beneath this text is a big blue button with that has the text “Connect Jetpack”.

    I click on the this text. The following screen authorizes the connection and then shows a button with the text “return to your site”.

    I click on that button. I’m not returned to the site, but I’m shown a screen that shows a table of plans. I’m invited to select one. I select one.

    After I select a plan I am returned to my site. I’m taken immediately to the jetpack admin.

    The screen I’m shown is the “Welcome to Jetpack” screen. It shows me the button inviting me to connect.

    I’ve gone through this loop a few times now.

    What could be preventing the connection from taking place?

    I set up the server myself, so I’ve got a suspicion that I’m missing a library that jetpack needs. However, when I’ve skipped a library in the past I’ve seen jetpack throw loud notifications about the missing library.

    The loop happens when I disable all plugins and drop the box’s firewall.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hey sunilwilliams.

    I had the same problem today. My hosting provider is Digital Ocean and they had maintenance few days ago, so I assume that something was changed.
    However, I fixed the issue, by simply (disconnect the site from wordpress.com) and then connect it again.

    Cheers

    Plugin Contributor Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    If this keeps happening, can you please use Jetpack’s Debugger module to send us some more information about your site?

    1. Go to the Jetpack page in your dashboard.
    2. Click on the Debug link appearing at the bottom of the page.
    3. Click the link that says “click here to contact Jetpack support.”
    4. Fill in the description box and your name and email address.
    5. Click the “Contact Support” button to send us the debug results privately. It’s best not to post this information on public forums, as it contains private details about your site.

    Thanks!

    sunilwilliams

    (@sunilwilliams)

    Hi all.

    This might be resolved. For reasons unrelated to this post, I restarted php-fpm and apache.

    After that, the jetpack admin page showed me a warning: an xml extension for php wasn’t available.

    I installed the php-xml module. After that Jetpack connected.

    Thanks.

    Hi Stanimir (@sstoqnov),

    Thank you for that tip. It solved my problem! 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Jetpack plugin not connecting after migration’ is closed to new replies.