Support » Plugins » Jetpack Plugin and Broken Page Navigation

  • I’m using WordPress 3.2.1, the Jetpack plugin 1.1.2 and the WP-PageNavi plugin 2.74. All are currently the latest versions.

    I use custom permalinks /%category%/%postname%/. When I’m logged-in to my WP install as admin and navigate pages on my site, the URLs appear as expected: http://domain/page/2/, http://domain/page/3/.

    However, if I log-out and try to navigate pages the URLs appear to be malformed: http://domain/2/, http://domain/3/ and consequently I’m getting 404 errors.

    I thought it may be an issue with the WP-PageNavi plugin, but I tried another page navigation plugin, WP Page Numbers, and the problem persists.

    However, if I disconnect Jetpack from or deactivate the plugin all together the problem disappears.

    I only noticed the problem recently, but as far as I can tell it was an issue as far back as WordPress 3.1.0.

    Any ideas on what may be causing this are greatly appreciated.

    Regards, Steve.

Viewing 15 replies - 1 through 15 (of 20 total)
  • I have the same problem on my site and it doesn’t appear to be related to any of these plugins. I think it’s an unrecognised fault with the release.

    Are you using WordPress Multisite?

    Thread Starter tech-otaku


    No, I’m not using WP Multisite and I can’t be certain the problem’s being caused by the Jetpack plugin.

    However, I’ve since deleted Jetpack and re-installed the old Stats plugin that’s still available for download and page navigation now functions perfectly whether I’m logged in as admin or not. Weird.

    Regards, Steve.

    I am also using WordPress 3.2.1 and when it suggested I install Jetpack all my links stopped working. Even after deactivating and going as far as removing from my hosting file manager still no longer works. I can see my posts but when I click as a link nothing happens.

    Luckily I did not try Jetpack with my other site – that still works fine.

    I also tried re-installing WP after removing Jetpack and also tried Stats – still no luck. Might have to delete site completely and start again.

    Sorry meant to say also 404 error not “nothing happens”.

    Ive had problems with admin pages loading since the latest upgrade but they seem to have resolved as soon as I deactivated. Its a shame as I loved some of its features.

    I am using the wordpress 3.2.1 with jetpack 1.2.1 on sites I am having hosted. Also I am using multisite, so one of my problems was that I couldn’t set a custom permalink without crashing the site, I was getting server 500 errors. So I disabled all of my plugins, added the /%postname%/ to the custom field in the Site Admin screen and added /%postname%/ to the path in the Network Admin screen. Then corrected the SiteURL and Home paths under settings, also in the Network Admin screen.

    Afterwards, through FTP, I replaced my .htaccess file with:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress

    The old file had this in it:

    RewriteEngine On
    RewriteBase /wordpress/
    RewriteRule ^index\.php$ – [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ – [L]
    RewriteRule ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    So doing the above worked. My site was up and running with the custom permalinks.

    So after this I began to add my plugins (which are only two). One is Share and Follow and the other is JetPack. Activated Share and Follow first and the site was fine, activated JetPack and the was still ok. The next thing I did was connect JetPack to and it crashed the site again (this time is is like an endless loop, no 500 error).

    Next step was to deactivate both, and only activate JetPack, the result was that the site was still crashed with the endless loop. Deactivate JetPack and the site is back up with the custom permalinks. Any fix on this yet?

    Just had the same problem with a client’s site. She swore she hadn’t touched a thing in ages but the pagination had just started acting odd whether logged in as admin or not. Lots of 404 errors and same URL issues as mentioned by original poster. One interesting thing was when clicking on the Next button, instead of going to http://domain/page/2 or attempting to go to http://domain/2 it was going to http://domain/category/242424 (a category she was using) and retrieving posts. All other pages got 404 errors. When questioned further she admitted to upgrading jetpack yesterday. We disabled it and all is fine.

    Having the same problem, any solution to this.

    Hi Folks,

    Can someone who’s still experiencing this problem please confirm the following details so that I can try to reproduce it?

    – What version of WordPress are you using?
    – What version of Jetpack are you using?
    – What is your web host? (DreamHost, Media Temple, etc?)
    – What do you have selected for your Permalink Structure?

    Also — can someone please describe (or confirm) exactly how you’re seeing this problem. Right now I am doing this:

    – Log into wp-admin
    – Set theme to 2011
    – Install/activate Jetpack
    – Connect to
    – Use an Incognito window (or log out of WP) and go to the homepage of the site
    – Scroll to the bottom of the page and click the “<– Older posts” link

    From my understanding of the above, this should lead me to a 404 page if the bug is presenting itself.

    Thanks in advance for helping us get this tracked down and fixed!

    Here is how this problem occurs.

    Using latest version of WordPress and Jetpack.

    I am using Canvas theme from Woothemes.

    It was working fine on default layout.

    After I switched to Custom Template page as the Frontpage the problem appeared.

    Problem doesn’t occur for Admin only for readers.

    http://domain/page/2 is redirected to which leads to either 404 or an image file instead of page 2.

    Thread Starter tech-otaku


    @beau Lebens

    Although I’m no longer using Jetpack, the issues described by loyalpk are the same as I outlined in my original post back in July.

    Some additional information that may help; my web host is GoDaddy and I use the inFocus WP theme.


    I am new to webhosting and having the same page navi problem.

    is there any solution ???

    @beau Lebens,

    I am having the same issue with jetpack and pagination.

    – WordPress 3.3.1
    – Jetpack 1.2.2
    – NearlyFreeSpeech.Net
    – Permalinks are Month and Name

    I have a child theme based on twenty eleven, and I am using a custom page template set to a static home page. I am attempting to paginate recent posts from this template.

    The pagination works (clicking “Older Posts” takes me to when I am logged in as an admin)

    When an anonymous user tries to click the link they are taken to a 404 URL like this:

    It works only when the stats module of Jetpack is deactivated. When stats are turned on, then I get the 404s.

    @jjeaton, can you please try changing your “WordPress Address (URL)” and “Site Address (URL)” (Under Settings > General in your wp-admin) to use all lower-case letters and see if that helps?

    @beau, the URLs are already lower-case. I was able to fix my problem by using front-page.php instead of a static page template. It seems the problem is caused by a static page template in conjunction with Jetpack Stats. Thanks.

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘Jetpack Plugin and Broken Page Navigation’ is closed to new replies.