Support » Plugin: Jetpack by WordPress.com » Jetpack not synced properly after reset

  • Resolved Kalidor

    (@kalidor)


    Recently, I needed to disable and re-enable my plugins, including Jetpack. When I re-enabled it I was asked to connect again, and I did so. Upon doing so it created a new instance of my site’s connection and reset all site stats as well as unconnected all my blog subscribers.

    I subscribed again with my email to test and saw that it said I was subscribed to my original site and the new one.

    I tried various ways of disconnecting, re-connecting, turning Jetpack on and off but it only interacts with the “new” connection. So my years of stats and subscribers are not displaying at all.

    How can I make my website see the original connection, as well as merge the new stats into the old stats? (If the stats from the past few days are lost, that’s a price I’ll pay to get the stats of the past several years back.)

    Thanks

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hi –

    Now that vacation is over I’m hoping someone can help me connect my site to the original site stats and user blog subscribers.

    The page link didn’t come through – it’s allspark.com

    Thanks

    Plugin Contributor Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Sorry about the delay in writing back to you.

    With Jetpack, your stats information is connected to a unique blog ID. Sometimes, if a site owner was using a development site or a different address when they set up Jetpack, disconnecting may create a new blog ID. When this happens, it may appear that your stats were lost.

    That’s what happened on your site; it previously used a different site URL.

    I have fixed the issue, and you should be able to get your Stats and Subscribers back by going to the Jetpack menu in your dashboard, and disconnecting / reconnecting to WordPress.com. You can disconnect from WordPress.com thanks to the link at the bottom of the page.

    Thank you.

    Thank you. This is now working and all the data is present.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.