Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » Jetpack not sending email to subscribers or posting social media

  • Resolved jeannius88

    (@jeannius88)


    I noticed my latest blog posts were not being sent to email subscribers or publicising on social media. I have reconnected Jetpack, uninstalled and reinstalled, and also copied the post into a new post and tried posting again. The issue is still persisting regardless of this.

    I have also contacted my host just in case they may be able to assist.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Contributor csonnek

    (@csonnek)

    Happiness Rocketeer πŸš€

    @jeannius88 Thanks for getting in touch! I pulled a random sampling of your subscribers and every single one received the email notification of your most recent post linked above based on our logs.

    Since we’ll need to get a list of emails from you of those subscribers that didn’t receive the email notification (because you don’t want to share those publicly) – could you contact us via this contact form and mention this thread? Also give us that list of email addresses that didn’t get the notice and we’ll be able to take a closer look.

    Let us know if you have any questions. Otherwise, we’ll wait to hear back from you via email. Thanks!

    Thread Starter jeannius88

    (@jeannius88)

    Hello, it looks like the emails and publicise content did eventually go out, however it was a 2-3 hour delay from when the post was scheduled. I’ve noticed this happening with my previous posts as well, is there any reason why?

    Plugin Contributor csonnek

    (@csonnek)

    Happiness Rocketeer πŸš€

    Scheduling posts is a tricky one. It’s possible with your site install and configuration that new post data isn’t synced to our servers immediately upon publication – which is what triggers your email and Publicize actions.

    We don’t really have any way to troubleshoot a delay in these going out – we can only see if it works or if it doesn’t and in your case they are going out as expected.

    If you have a post that does not go out to your subscribers or via Publicize, get in touch with us using the Contact Form link above with the information I requested and we’ll be happy to take a closer look.

    Since things are working, we’ll mark this resolved for now.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.