Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » Jetpack non sync with social profiles

  • Resolved acicciu


    Respectable. support,
    I have a problem with the Jetpack plugin. For about 2 weeks, I can not sync the content of my website with the accounts I set up on Jetpack (Google+, Linkedin, Twitter, Facebook). Within my profile under “blog articles” I can see posts posted on the website ( with WordPress 4.8 and Jetpack 5.0) but on social profiles nothing is published anymore. I tried to:
    – disconnect and reconnect the site;
    – disconnect and reconnect profiles;
    – remove and reinstall the jetpack plugin.
    Unfortunately I can not solve the problem.
    Please help me to understand and solve the problem.
    Thank you.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Jetpack’s Publicize feature won’t work for plugins/scripts that don’t the default post method by WordPress as it skips some checks set by Jetpack to run those Publicize jobs.

    Could you try manually publishing one post on your site and see if that works?

    Thread Starter acicciu


    Thank you for the reply! I manually published an article and is actually shared on all 4 platforms. Is there a way to solve the problem? Until two weeks ago this did not happen and everything worked perfectly!
    Thank you

    Hi there, the only thing I can suggest in this case is to roll back to an older version of your posting plugin – I am assuming that an update would have changed its behavior.

    Unfortunately Jetpack will only Publicize posts if the post is published using the default WordPress flow.

    Thread Starter acicciu


    Thank you for the reply.
    How do I download the previous version (5.0)?
    Thank you

    You can find a list of our previous versions on this page here:

    Please select version 5.0 and click download

    Thread Starter acicciu


    Hi Lamday,
    I installed the old versions (5.0, 4.9, 4.8) but the problem is not resolved. On another platform, I changed the communication protocol from https to http to line 17 in the jetpack.php file and seems to work all over again.
    This may be the problem (maybe an incompatibility with WordPress version 4.8) or is it just a case?
    Hosting the two platforms is the same.

    /*defined( ‘JETPACK__API_BASE’ ) or define( ‘JETPACK__API_BASE’, ‘’ );*/

    /*defined( ‘JETPACK__API_BASE’ ) or define( ‘JETPACK__API_BASE’, ‘’ );*/

    Thank you

    Hi @acicciu

    Sorry about the delay in writing back to you!

    That’s interesting. Changing that line will force the outgoing requests to HTTP – Which suggests that your host could be blocking outgoing HTTPS requests.

    Are you running the same plugins on your other site? ie. Cybersin?

    Also, if you you need to change that setting for Jetpack to work, you’re better off using a filter:

    define( ‘JETPACK_CLIENT__HTTPS’, ‘NEVER’ );

    Add this into your theme’s function.php file or a code snippet plugin, this will ensure that no future updates will overwrite the change you made to the core files.


Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Jetpack non sync with social profiles’ is closed to new replies.