Support » Plugin: Jetpack by » Jetpack Markdown Not Working

  • Resolved Susan Warren


    I’ve installed Jetpack v2.9.3 specifically so I could markdown in my pages and posts. I’ve activated the markdown module and I can find a new setting for activating markdown on the “discussion” settings page, but no settings at all on the “writing” settings page. And on individual pages and posts there’s no option to use markdown or not.

    I thought perhaps markdown was automatically activated, but when I enter markdown formatted text in a page or post and then preview it, the preview just shows the raw markdown code: there’s no conversion.

    As an experiment I installed the “Markdown on Save Improved” plugin and it works perfectly, even with the Jetpack markdown module enabled. But the Markdown on Save Improved is deprecated and the author recommends using the Jetpack markdown module.

    I tried deactivating the Jetpack plugin and reactivating, but that didn’t fix anything.

    Any ideas why the Jetpack markup isn’t showing up or working?

Viewing 11 replies - 1 through 11 (of 11 total)
  • Posted 5 days ago and still no replies. Anyone? Or do I just give up on this?

    Forgot to say that in my first post I said that “Markdown on Save Improved” worked perfectly. I spoke too soon. It escaped all single and double smart quotes so that every smart-quote apostrophe wound up like \’s and every quote wound up like \”, in both text and inline code, in every page on my site. It could be a magic-quotes problem, or it could be the plugin. I voted for the plugin, uninstalled it, imported my most recent backup database and got the site back to normal. It’s stayed normal for close to a week now, so no magic-quotes black magic- -it was the plugin.

    I am having the same issue with jetpack not rendering markdown, it just displays as normal text, I’m using wordpress 3.9 and the latest version of jetpack

    Hi, Susan Warren and JonnieDarko

    I’ve read the Jetpack Markdown instructions ( but there isn’t any mention of a Markdown setting under Settings -> Writing, only under Settings -> Discussion (to activate the feature for comments).

    Here’s what I did to get it working on my site. Basically, you activate the Markdown feature within Jetpack, go to a page or post, and then start typing in text with your Markdown syntax.

    By any chance, are you trying to use Markdown in the Visual Editor?

    “For best results, use the Text tab in the Editor. The Visual Editor can produce unexpected results.”

    Hi Andrew,

    Thanks for your reply.

    I thought there might be some kind of setting on pages and posts to choose to use markdown because I couldn’t get markdown to work properly.

    With the Jetpack markdown activated I can see the settings for comments so I know that the plugin is active. However, when I enter markdown text in the editor the markdown code isn’t being translated properly when I either preview a page or save it and then check it (I thought perhaps a page needs to be saved before the translation occurs, but that makes no difference). I NEVER use the visual editor, always the text editor because I prefer to code for myself, so I always use the text editor for my markdown tests as well.

    I know how to use markdown– it’s not a matter of my mis-coding. I’ve tried both markdown and multimarkdown coding syntax, and I’ve tried copying and pasting markdown text from a dedicated markdown editor (Markdown Pad) and I always get the same results: the code in the output page.

    This morning I tried a different approach: I uninstalled and deleted Jetpack, cleared the cache, logged out of WP and shut down my browser to kill the session and any remnants. I then went back into WP and reinstalled Jetpack. Then I activated the markdown option and made sure the comments/discussion markdown option was present (to verify that things had installed). When I opened up a new page and pasted in some markdown text, the text showed up properly in the page preview! I have no idea what uninstalling, deleting, and reinstalling did, but it worked.

    Okay, that’s progress. Glad to hear you’ve got it working, Susan.

    Jonnie, how about you? Any luck?

    Plugin Contributor Brandon Kraft


    Happiness Engineer

    Thanks for sharing. That’s odd that it wasn’t parsing correctly without all of that. I apologize for the delay in responding as well. We answer tickets, generally, from oldest to newest and the forums sorts it by the time-since-latest-post.

    Bumping a thread, thus, actually buries it 🙁

    Hi Brandon,

    I’m guessing (hoping) that for whatever reason it was just a bad install the first time around. Works fine now!

    I know this is marked as resolved, but I’m having exactly the same problem with Jetpack Markdown and I really don’t fancy deleting and reinstalling Jetpack!

    Annoyingly I’ve just written a large article in markdown as I figured then my github and wordpress entry could be the same! 🙁

    I’m using WordPress 3.9.2 and Jetpack 3.1.1

    Plugin Contributor Brandon Kraft


    Happiness Engineer

    Brian, could you please start your own thread, as per the Forum Welcome?

    In the thread, please include your site’s URL and what all you have tried? With the Markdown module active, your site should parse Markdown for new posts.

    Thank you!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Jetpack Markdown Not Working’ is closed to new replies.