Support » Plugin: Jetpack by WordPress.com » JetPack locked me out of my dashboard

  • Resolved hehafner

    (@hehafner)


    I just updated JetPack to the current version, 7.7. After the update I was given the following message:

    This page isn’t working chefeliana.com is currently unable to handle this request.
    HTTP ERROR 500

    After trying other means to get in, I realized it was JetPack. I disabled it and am now able to log in. Why is this happening? I don’t want to update JetPack on any of my other sites until I know the reason for being locked out.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic πŸš€

    I’m sorry to hear you’ve run into issues!

    Could you try to log in to your site via FTP or CPanel, delete the existing Jetpack plugin folder, and reinstall the plugin manually as explained here:

    Managing Plugins

    You’ll find the Jetpack plugin folder here:

    
    wp-content
       plugins
         jetpack - DELETE THIS FOLDER
    

    If you’re not sure how to do this, you can ask your hosting company for help. They should also have documentation explaining how to edit or remove files from your site using FTP or a File Manager in your admin panel.

    If you get another 500 error after reinstalling Jetpack from scratch, could you try to enable debugging on your site so we can find out more about the error? You can follow the instructions here to do so:
    https://gist.github.com/jeherve/e6acfc973c07cb500836804e1044d12a

    Let us know how that goes!

    hehafner

    (@hehafner)

    I deleted the plugin and then reinstalled. After reinstalling I was locked out. The diagnostic says:

    Debug
    XML-RPC is not responding correctly ( 404 )
    It looks like XML-RPC is not responding correctly. Please make sure XML-RPC is turned on for your site and is set up to respond to all content types. You can test this yourself by running the following command from the command line:

    curl -A ‘Jetpack by WordPress.com’ -d ‘<methodCall><methodName>demo.sayHello</methodName></methodCall>’ https://chefeliana.com/xmlrpc.php
    The answer should be:

    <?xml version=”1.0″ encoding=”UTF-8″?>
    <methodResponse>
    <params>
    <param>
    <value>
    <string>Hello!</string>
    </value>
    </param>
    </params>
    </methodResponse>

    I haven’t done anything to the XML-RPC file.

    hehafner

    (@hehafner)

    I checked my .htaccess and it has:

    	# Disable XML-RPC - Security > Settings > WordPress Tweaks > XML-RPC
    	<files xmlrpc.php>
    		<IfModule mod_authz_core.c>
    			Require all denied
    		</IfModule>
    		<IfModule !mod_authz_core.c>
    			Order allow,deny
    			Deny from all
    		</IfModule>
    	</files>
    

    Not sure how it became disabled.

    hehafner

    (@hehafner)

    Upon further testing, I found there is a conflict between iThemes Security and Jetpack. If I turn off iThemes, Jetpack works. Any idea what the problem is between the two?

    hehafner

    (@hehafner)

    I tried enabling XML-PRC but Jetpack still does not work. I’ll have to leave it off for right now. Awaiting further instructions.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic πŸš€

    I found there is a conflict between iThemes Security and Jetpack. If I turn off iThemes, Jetpack works. Any idea what the problem is between the two?

    In your iThemes Security settings, you’ll find an option to keep XML-RPC available; this will allow both plugins to work well together.

    I would recommend that you check that this option is set correctly, and then try the following:

    1. Go to the Jetpack menu in your dashboard
    2. Scroll down to find the Connections area.
    3. Click the “Manage site connection” link where your site is listed.
    4. Click the red Disconnect button.
    5. Click on the “Set Up Jetpack” button to connect your site to WordPress.com again.

    Let us know how that goes.

    hehafner

    (@hehafner)

    Hi @jeherve, I did try that but to no avail.

    Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

    In that case, I’d recommend following up with https://wordpress.org/support/plugin/better-wp-security/

    It sounds like perhaps either that option is no longer working, or there’s a new option we aren’t aware of yet.

    hehafner

    (@hehafner)

    Ok, I will do that. Thanks

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.