Support » Plugin: Jetpack by WordPress.com » Jetpack Like button not working

Viewing 15 replies - 1 through 15 (of 37 total)
  • I am having the same issue with the likes button. It is grayed out and show “loading”, but never changes.

    So any help would be appreciated.

    http://www.quailrunphoto.com

    Plugin Contributor Richard Archambault

    (@richardmtl)

    Happiness Engineer

    Hi slash83;

    I looked at your site, and it’s not clear what the issue. is. Normally this is caused by a javascript error but I don’t see any on your site. Can you try turning off all your other plugins and switching to the TwentyEleven theme to see if it’s a plugin or them econflict? You can turn on your plugins one by one until you find the culprit. Once you find it, let me know and I’ll see if it’s something we can fix on our end.

    quailrunphotos:

    Your case is a bit easier. I had a look at your site, and your theme or one of your plugins seems to be loading an old version of jQuery instead of using the version that comes bundled with WordPress.

    It can create multiple conflicts with WordPress and with other plugins like Jetpack. You can read more about it here:
    http://wordpress.org/support/topic/troubleshooting-wordpress-35-master-list?replies=4#post-3547424

    Try switching to a different theme for a few minutes, and check if that solves the issue; if it does, you’ll want to look for the function loading jQuery in your theme’s header.php file, or in the functions.php file. Once you find that function, you can remove it and enqueue the proper version of jQuery as explained here:
    http://codex.wordpress.org/Function_Reference/wp_enqueue_script

    If the issue is not related to your theme, please try to disable all your plugins, one at a time, until you find the one that causes the conflict. You can then enqueue jQuery using the method I linked to above.

    If you do not feel comfortable editing PHP files, you can also contact the theme or plugin author and ask them to solve the issue.

    Thank you. I disabled my theme and selected one of the wordpress default themes. The button works, I switched back to my original theme and the button stopped working.

    I have contacted the theme developer. Thanks for the help.

    David

    Thanks a lot for your reply Richard. Really appreciate your efforts!

    Unfortunately the button still doesn’t work if I disable all my plug-ins. It comes to live, if I switch to TwentyEleven theme but when I activate my current theme again the button stops working.

    It seems like it is an issue with my current theme then (a customised/modified WP Shower Portfolium theme).

    Marcel

    Plugin Contributor Richard Archambault

    (@richardmtl)

    Happiness Engineer

    Hi Slash,

    It seems you removed the Jetpack Like button, so I can’t troubleshoot for you at the moment. I suspect that the issue is likely a javascript issue, however; it usually is with the Likes button.

    Hey Richard,

    Thanks for staying tuned on this. Actually I have not removed the Jetpack Like button. I activated the plug-in again. When I visit my page it still shows the greyed-out button.

    Unfortunately I can only do front-end editing. What I know from customising the page is that I do load a few jquery scripts and a columnizer writter in javascript. I could hand over the original template files if that might help you.

    However I do understand if that might be too much effort for an individual problem.

    Thanks for your help anyway!

    Marcel

    Plugin Contributor Richard Archambault

    (@richardmtl)

    Happiness Engineer

    Hi Slash,

    Ok, I see the like button now, it wasn’t there when I looked yesterday.

    So, I don’t actually see any javascript errors, so I’m not quite sure what the issue is. Everything looks ok on the connection side of things, as well. Can you try steps 1 and 2 on this page:

    http://jetpack.me/troubleshooting/troubleshooting-tips/

    and let me know if you find the culprit, if any?

    I’m having the same problem and inadvertently posted to a “resolved” post. I don’t know how to remove replies.

    Since I posted there (post copied below), I have deactivated all of my plugins one at a time until they were all deactivated and I still had the problems. I went to your Troubleshooting page and Known Issues and didn’t see a list of themes that conflict.

    I’m looking forward to finding out when you have a fix. I also tried activating Twenty Eleven and that didn’t help, so I reactived Mantra.

    The Like button appears to not be working on any page, though the proper ending tags appear.

    My 404 Monitor tells me that people have tried to use the button. The site is not linked yet, but Google has indexed it. It’s a work in progress, but we’d like it to be operating correctly when it is finally linked and official. It’s at daviesuu.org currently.

    Thanks for maintaining this plugin, which is overall very useful.

    Moderator Jan Dembowski

    (@jdembowski)

    Brute Squad and Volunteer Moderator

    JoyceD6? You’ll get a more targeted response to your specific problem if you post your own topic instead.

    http://wordpress.org/support/plugin/jetpack#postform

    Adding your problem to someone else problem doesn’t help then or you. You do want personalized support right? 😉

    Thanks! I had seen it done on other posts – people posting when they had the same problem. Sorry if this was improper. Wish I knew how to delete previous replies.

    Richard,

    Thanks again. I did have a look at the troubleshooting.

    The like button works when I switch to other themes. I still can not get it to work with my current theme.

    I thought I might have messed up the code when I optimised the theme. However, I now also checked back with the original theme. I downloaded a fresh copy and activated it. It seems as it is a problem with the theme. You can have a look at the original theme here: http://wpshower.com/themes/portfolium/

    I think the theme is quite a bit different because of its portfolio structure. Which means it offers a portfolio page for photography, and a blog separately. This is resembled in the admin dashboard. If I like to create a new post I simply add a new post. However, if I like to create a new photo set, I will have to do this via a tab called “portfolio”, which seems to be a separate functional element of the theme.

    My guess is that this unique structure could be a problem for the jetpack plug-in. Most other functions (apart from the wordpress likes) seem to be working though.

    In the theme’s support forums I couldn’t find a discussion related to Jetpack. Any thoughts, Richard?

    Thanks!

    Marcel

    Plugin Contributor Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    @marcel Could you please start your own thread, as per the Forum Welcome?
    http://wordpress.org/support/plugin/jetpack#postform

    It could also help if you could let us know your site URL, so we can have a look at the problem? If you want your site URL to remain private, you can also contact us via this contact form:
    http://jetpack.me/contact-support/

    Thank you!

    Sorry Jeremy, if you scroll to the first post you will see, that I started this post and that an example of my page can be found at: http://www.marcelmuench.de/2013/04/responsible-business-week/ (as stated in my very first post).

    Plugin Contributor Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    My bad. Sorry about that.

    Could you go to Posts > All Posts in your dashboard, open that post in the post editor, and just click the “Update” button? Does this change anything?

    Thanks!

    No worries. Appreciate your help!

    Unfortunately that doesn’t help either. As I mentioned it works if I switch to another theme. It does not work with the original WPShower Portfolium theme as well as with my customised Portfolium theme.

    Have you got any thoughts on the assumptions in my post today (6 hours ago). Thanks

Viewing 15 replies - 1 through 15 (of 37 total)
  • The topic ‘Jetpack Like button not working’ is closed to new replies.