Support » Plugins » [JetPack] Jetpack has a glitch, "no_state"

  • I’ve been trying to get Jetpack 1.5 to work on a WP 3.4.1 site. I have it working on other sites.

    I get this error (almost) every time I try to authorize it:

    Your Jetpack has a glitch. Something went wrong that’s never supposed to happen. Guess you’re just lucky: no_state
    Try connecting again.

    After deactivating it for a day, and then reactivating it, it came up with a new error:

    Wrong size. Hm… it seems your Jetpack doesn’t quite fit. Have you lost weight? Click “Connect to” again to get your Jetpack adjusted.
    Error Details: Invalid authorization_code.

    But I only saw that error the one time.

    For what it’s worth, the URL that was being generated on my side before it parses through to Jetpack was:

    I then tried again to authorize, and it now reverts back to the original error, which it has been doing for a couple of days (since I installed it two days ago).

    Please advise.

    Thank you.

Viewing 1 replies (of 1 total)
  • I had both of the same Jetpack errors as inspired888 come up on my WordPress 3.4.1 installation.

    However, the issue has now been resolved.

    The first thing that happened was that I must have entered into Jetpack my credentials incorrectly the first time (using the username/password combo provided to me during signup)… because it responded with an “authorization code” error.

    Then I opened a new browser tab and went into and changed my username (not the display name but rather the username used to log in) and then changed the password to something easier to remember.

    Then I tried connecting Jetpack To again and it gave me the no_state error.

    I deactivated Jetpack, and then activated it again.

    The next time I pressed the button to connect Jetpack to, because I was already logged in to in that browser, it instantly recognized me by my new username and simply asked for confirmation rather than asking me to re-enter my password.

    Ta-da! I was able to successfully connect my accounts.

Viewing 1 replies (of 1 total)
  • The topic ‘[JetPack] Jetpack has a glitch, "no_state"’ is closed to new replies.