WordPress.org

Forums

Pinbin
[resolved] Jetpack infinite scroll support (9 posts)

  1. juanpdelat
    Member
    Posted 1 year ago #

    Hi,
    I've been playing with the amazing theme to add support to infinite scroll but I'm still not able to do it.

    I was using Infinite-Scroll but I am having a problem with the posts overlapping each other when the scroll happens and wanted to try another infinite-scroll plugin.

  2. theroad_running
    Member
    Posted 1 year ago #

    Hi Juan.

    Well, forget about the jetpack infinite scroll plugin.

    find paul irish' infinte scroll plugin:

    http://www.infinite-scroll.com

    you can find it through the plugin search in your wp backend as well.

    you'll have to change the css selector for "#content" by "#post-area". the rest is already a-ok!

    you can see a working version on my modified pinbin version at http://www.theroad.be

  3. Silkalns
    Member
    Theme Author

    Posted 1 year ago #

    @theroad_running

    Thanks for suggestion!

    I can confirm that this plugin actually works with Pinbin theme.

  4. theroad_running
    Member
    Posted 1 year ago #

    you're welcome. maybe you can change the post-area id to content for out of the box integration with the theme. although this is quite straight forward. i guess adding a small howto to the documentation should do as well :-).

    paul irish' code is really nice as well. I read you were thinking about adding infinte scroll to the theme? might want to look into his implementation.

  5. Muk9
    Member
    Posted 1 year ago #

    I was trying to apply the infinite-scroll plugin to my website but the posts stack. I changed the content selector to #post-area but still no luck. I even tried to re install pinbin and disabled all other plugins running on my website. Do I need to change some other settings or is this a problem specific to my website?

    Thanks!

  6. nahtee
    Member
    Posted 1 year ago #

    When you use the infinite scroll plugin, on the infinite scroll settings page. Scroll down to the Behaviors setting and change it from Default to Masonry/Isotope. Doing that fixed my "stacking" problem.

  7. Muk9
    Member
    Posted 1 year ago #

    That fixed the issue, thanks for the help.

  8. coldcedar
    Member
    Posted 1 year ago #

    Hi! How do you change the "Behaviors" setting from Default to Masonry/Isotope?

    Do you mean to change it here and if so, how?:

    public $behaviors = array( //array of behaviors as key => array( label => js file ) (without extension)
    'twitter' => array( 'label' => 'Manual Trigger', 'src' => 'manual-trigger' ),
    'local' => array( 'label' => 'Local', 'src' => 'local' ),
    'cufon' => array( 'label' => 'Cufon', 'src' => 'cufon' ),
    'masonry' => array( 'label' => 'Masonry/Isotope', 'src' => 'masonry-isotope')

  9. coldcedar
    Member
    Posted 1 year ago #

    Please help! Need a how-to!

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic