Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » Jetpack image caching still working after turning off

  • Resolved PhilipPeake

    (@philippeake)


    Turning off acceleration does not work. Links still point to wordpress systems.
    The big problem is that the image caching on those system is not working (400 error) so most of the images are not working.

    If I could just serve them from my own system things would work…

    So two things to fix: The jetpack plugin so that it does not use wordpress servers for images when acceleration is turned off, and the wordpress servers themselves that are not caching correctly.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Contributor Jen H.

    (@jenhooks)

    Hi again, @philippeake. A few things are going on here.

    Are you using the Bluehost (formerly Mojo Marketplace) plugin? That plugin will re-activate Site Accelerator even after you’ve disabled it. Also note that if you’re using Jetpack’s tiled galleries, that feature will use Site Accelerator (the Photon engine) even if you have it disabled.

    If you previously had Site Accelerator on and no longer want the images cached (even after disabling), we need to purge them manually. You’d need to send us a list of cached image URLs that you’d like to have removed. These URLs will start with “i0.wp.com”, or similar. If you have a long list, you can reach out to us here

    Regarding this:

    The big problem is that the image caching on those system is not working (400 error) so most of the images are not working.

    I suspect that the culprit is the size of your images. Site Accelerator will time out if it can’t cache an image within 10 seconds. Images should be around 250 MB for optimal loading speeds on shared hosting.

    A final note: your Jetpack connection is broken right now. You can see the error in our connection debugger here:

    https://jptools.wordpress.com/debug/?url=https://photo.vogon.net

    You can see the problem here: https://d.pr/i/ckvI8l

    For Jetpack to be able to connect properly, https://photo.vogon.net/xmlrpc.php?for=jetpack should simply say, “XML-RPC server accepts POST requests only.” on a completely white screen, with the text left-justified in the top corner of the screen. You can see a working example here: https://jetpack.com/xmlrpc.php

    Please ask your host’s customer support team to allow Jetpack to access XML-RPC (or, modify your security plugin settings.) Then, reconnect Jetpack:

    https://jetpack.com/support/reconnecting-reinstalling-jetpack

    Let us know how it goes!

    • This reply was modified 1 month ago by Jen H..
    • This reply was modified 1 month ago by Jen H.. Reason: typos ;)
    Thread Starter PhilipPeake

    (@philippeake)

    Thanks for the reply.
    No Bluehost plugin.
    Running on my own server, so no hosting service to worry about.

    The tiled galleries (silently) requiring Site Accelerator is probably the answer to why the images are cached on WordPress systems.

    None of the images are anything approaching 250M (I have a 15M upload limit set).

    The XML_RPC URL does respond as you say – to me.
    Externally it is blocked – too many probes trying to break stuff.

    I can try unblocking it for a while, and see what happens.

    Plugin Contributor Jen H.

    (@jenhooks)

    Hey @philippeake,

    Thanks for the followup. For me, your site is not loading right now in Firefox or Chrome, and I noticed it was very, very slow when I checked it yesterday. Here’s a brief screencast of what I’m seeing today.

    I have a feeling the issues you’re seeing with Jetpack (aside from the block you’ve imposed to XML-RPC) are related to how slowly your site is loading. This free online tool might help shed some light on things?

    Plugin Contributor Jen H.

    (@jenhooks)

    Hey @philippeake,

    Since it’s been more than a week since we’ve heard from you, I’m going to go ahead and mark this thread as Resolved. If you still need a hand, please feel free to reach back out here and mark the thread as not resolved.

    Thanks!

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.