Support » Plugins » Jetpack Gravatar Hovercards: Self Hosting

  • I’ve just installed Jetpack – great way to cut down on the number of plugins.

    I had hovercards running and then disabled them by clicking on the button on my own hovercard – not the jetpack menu. Now I can’t get them to work again. I’ve tried enabling and disabling a number of times but they don’t come back. Any ideas anyone?

Viewing 12 replies - 1 through 12 (of 12 total)
  • I am experiencing same problem, though I didn’t disable my hovercard. It was working for the first 5 to 10 minutes, but now it doesn’t. Nor does the site stats part of jetpack. I think it only worked long enough for the bad code to work itself into my cache. Everything was fine with the site stats but I, like you, switched to jetpack to limit the total number of plugins in use. I’m still researching.

    Everything now seems to be running fine for my Twenty-Ten child theme. It just took time for the kinks to get worked out.

    mine is working but it only shows hover cards at the admin panel! 🙁

    on my post’s comment’s area, not at all… maybe it’s because of my blog theme?? any suggestions?


    Same with me, the hovercards work in the admin, but not anywhere else.

    would anyone please let us know how to do this??? thanks.

    They started working on mine, I’m not exactly sure why though. I did uninstall a Twitter widget (not the jetpack one) but I can’t think of anything else I did, or how that would keep hovercards from working.

    It wasn’t just the Jetpack hovercards either, I did install just the regular Hovercard plugin, and even tried Ottos code which adds it to the functions.php and neither would work.

    I can only suggest disabling addons and see if it starts to work.

    The rating settings in the gravatar may have some effect on this, I’ve got mine set to G in blog discussion settings. It seems to work with any authors or commentors that are set-up with gravatars. Twenty-Ten Child seems to be AOK. Sorry I can’t help more.

    Jetpack Hovercards are not working for my self-hosted wordpress either….

    I’m on a self-hosted wordpress install via Dreamhost
    WordPress 3.2.1
    default theme “Twenty Eleven 1.2”
    no modifications, etc…

    URL in question is:
    Debugging on Chrome shows:
    Resource interpreted as Script but transferred with MIME type application/json.
    Resource interpreted as Image but transferred with MIME type text/plain.




    @kouya, you probably disabled hovercards and you can re-enable them by deleting the appropriate cookie. Or, clearing all cookies should also do the trick if you don’t mind clearing them.

    If the hovercards are working in the admin pages but not on the site itself, it could be caused by a plugin conflict and it’s less likely but still possible that something in the theme is conflicting. Try disabling all other plugins and then check to see if it works. If it does, re-enable your plugins one at a time until you find the one that conflicts.

    My experience has been that the most likely culprit is that you’ve made a custom theme and forgot to add <?php wp_footer(); ?> to footer.php.

    I think that’s especially likely for the ones who have this working in their Dashboard, but not on the site.

    It’s something I’ve done a few times now :). I hope it helps some of you.

    Hi Guys,
    I just installed jetpack. I have one question my hover card does work but it only shows name and bio, it doesnt show connected services, personal links or extra pics as shown in the demo, anyone would know why?

    I’m having this same problem (hovercards show in admin panels, but not in site comments with viewing the site as a normal user would). It isn’t that line in footer.php indicated above, as I do have that in my footer.php file.

    However, out of 3 sites I manage, 2 are working fine… which leads me to believe it does have something to do with the theme. I just don’t know where to start looking.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Jetpack Gravatar Hovercards: Self Hosting’ is closed to new replies.