Support » Plugin: Jetpack by » Jetpack giving me white screen of death on edit post

  • Resolved trudslev


    Jetpack 7.5.2
    PHP 7.3
    Wordpress 5.2.2

    When I click edit on any of my posts I get a white screen of death. If I disable Jetpack, it works again.

    How can I help debug this issue?

Viewing 13 replies - 1 through 13 (of 13 total)
  • CloudedDottedMind


    Hi, I have same issue today –
    WSOD on add pages and posts.

    Jetpack 7.5.2
    PHP 7.2
    Wordpress 5.2.2

    Plugin Support KokkieH


    Hi there,

    I assume this is when editing in WP-Admin, rather than in the interface via Jetpack, correct? Using the block editor, or the classic editor plugin?

    First thing to check is whether it might be a conflict with another plugin or the theme on your site – the recent update in Jetpack could have introduced a conflict with another plugin that didn’t exist before, or an update to a plugin could have introduced a conflict with Jetpack.

    Please attempt to disable all plugins except Jetpack, and switch to the default Twenty Nineteen theme. If the problem goes away, enable them one by one to identify the source of the problem.

    If you are able to install plugins, install Health Check. On the troubleshooting tab, you can click the button to disable all plugins and change the theme for you, while you’re still logged in, without affecting normal visitors to your site.

    It would also be helpful if you can share your site’s URL so we can check it from our end. If you’re not willing to share it publicly, please open a support ticket at so we can help you there instead.

    I am using the WP-admin interface with Gutenberg.

    I already turned off all plugins and enabled on by one. That’s how I found out the Jetpack was the culprit.

    I also checked Health Check and I upgraded to php 7.3 as per it’s suggestion and removed some inactive plugins. None of which helped the problem.

    My sites URL is

    Plugin Contributor James Huff


    Volunteer Moderator

    I see a connection error on your site, but no obvious blockers. Please contact us via about this.

    Same issue here with WSOD when I try to edit a post from wp-admin.

    Have followed the above advice and narrowed it down to not being able to have Gutenberg v.6.1.0 and Jetpack v7.5.2 active at the same time.

    Both allow me to edit when just one of them is active or with any of my other plugins but not together.

    Any help appreciated.

    I have the same problem
    Screen page with last version of jetpack
    When i stop jetpack, all is ok

    Last version of wordpress
    theme nineteen

    Thanks for your help

    Plugin Support KokkieH


    @techfortravel, thanks for that info. I’m not able to replicate on my site – the editor works fine with both Gutenberg 6.1.0 and Jetpack 7.5.2 active.

    But it does appear that the latest update of Gutenberg introduced a conflict with Jetpack. It’s already being worked on in, so you can subscribe to that issue directly for updates.

    @shautefe, @trudslev, are you also using the Gutenberg plugin on your sites? If so, it’s likely the same issue.

    Yes i use it.
    Version 6.1.0
    I see now the link you give me

    Plugin Support KokkieH


    Thanks for confirming.

    If it’s indeed the same issue, the pending fix to the Gutenberg plugin should resolve this.

    I remove the 6.1.0 and i reinstall the 6.0.0
    All is Ok

    I am using the latest Gutenberg too.

    Plugin Contributor James Huff


    Volunteer Moderator

    This will work under Gutenberg 6.0.0, until this fix lands in the next Gutenberg update:

    In case anyone here didn’t know, the Gutenberg plugin is no longer a requirement to use the block editor that has been built into WordPress since the release of WordPress 5.0.

    The Gutenberg plugin is now just a testing ground for new features, which is why it breaks periodically.

    James, I wasn’t aware that Gutenberg wasn’t required. I have just uninstalled it and everything works again 🙂

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.