Support » Plugin: Jetpack by WordPress.com » Jetpack: [failed_publicize_action] Invalid Publicize ID Error code: -32601

  • Resolved Justin Soo

    (@juzhax)


    Site:
    game-solver.com
    rumorscity.com
    rumorsmarket.com

    Same results.

    [ Moderator note: code fixed. Please wrap code in the backtick character or use the code button. ]

    SELF:
    	Array
    (
        [headers] => Array
            (
                [server] => nginx
                [date] => Fri, 08 Aug 2014 22:04:52 GMT
                [content-type] => text/plain;charset=utf-8
                [connection] => close
                [x-pingback] => https://jetpack.wordpress.com/xmlrpc.php
                [expires] => Wed, 11 Jan 1984 05:00:00 GMT
                [cache-control] => no-cache, must-revalidate, max-age=60
                [pragma] => no-cache
                [x-hacker] => Jetpack Test
            )
    
        [body] => {"error":"Communication error","error_description":"We were unable to make an XML-RPC request to your website. Please make sure that XML-RPC is turned on and that Jetpack is installed, activated and connected with your WordPress.com account. If the error persists, try disconnecting and connecting Jetpack again."}
        [response] => Array
            (
                [code] => 400
                [message] => Bad Request
            )
    
        [cookies] => Array
            (
            )
    
        [filename] =>
    )

    https://wordpress.org/plugins/jetpack/

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Contributor Brandon Kraft

    (@kraftbj)

    Happiness Engineer

    Hi,

    On one of the impacted sites, can you deactivate and reactivate Jetpack, then try again?

    Thanks!

    I’ve disabled all plugins and enabled again only Jetpack. It doesn’t success.
    I’m running vanish with port 80 and nginx with port 8080 in a server. It is jetpack not allow the nginx to run with port 8080 ? Because I run successful in other server that with vanish and nginx and lighttpd, apache.

    I’ve traced the request using tcpdump.

    ser-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_4) AppleWebKit/537.77.4 (KHTML, like Gecko) Version/7.0.5 Safari/537.77.4
    Referer: http://rumorsmarket.com/wp-admin/options-general.php?page=sharing&action=error&publicize_error=-32601
    Cookie: __cfduid=dae7e4134d5e4494ed4215f364f61076e1393811120148; _ga=GA1.2.594402786.1394505160; wordpress_11326ba0aae5393d1aa124a654ef817c=Admin%7C1407688059%7C47f092ee8da4d9510c71a68b807dc5c7; wordpress_7b7f4045b446c3acbd56eacc7f91c585=Admin%7C1408403223%7Cb38fbb35ce544367fbc236eb5b4c8245; __utma=1.594402786.1394505160.1394505421.1395015651.2; __utmz=1.1394505421.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none); NREUM=s=1407512700274&r=53208&p=28894; PHPSESSID=782menfrrfei112laffdoj2em3; wordpress_logged_in_11326ba0aae5393d1aa124a654ef817c=Admin%7C1407688059%7C27899b76d10aebe4a8b25ecab28036dd; wordpress_logged_in_7b7f4045b446c3acbd56eacc7f91c585=Admin%7C1408403223%7C6c0db92266f743c175fb8a81667cb9a1; wordpress_test_cookie=WP+Cookie+check; wp
    13:14:07.308948 IP wordpress.com.8092 > ns5001450.ip-192-95-32.net.http: Flags [P.], seq 2563778396:2563778695, ack 1527703330, win 29, options [nop,nop,TS val 393857619 ecr 2267645431], length 299
    E.._..@.:.%.B.	a._ i...P..'\[.."....*......
    .y.S.)..POST /xmlrpc.php HTTP/1.0
    User-Agent: WordPress/4.0-beta2-20140728; http://jetpack.me
    Host: rumorsmarket.com
    Accept: */*
    Content-Length: 102
    Content-Type: application/x-www-form-urlencoded
    
    <?xml version="1.0&"?><methodCall><methodName>demo.sayHello</methodName><params></params></methodCall>
    13:14:07.434988 IP wordpress.com.8119 > ns5001450.ip-192-95-32.net.http: Flags [P.], seq 4202853158:4202853457, ack 741608445, win 29, options [nop,nop,TS val 393857650 ecr 2267645463], length 299
    E.._.L@.:.Y.B.	a._ i...P..s&,4.............
    .y.r.)..POST /xmlrpc.php HTTP/1.0
    User-Agent: WordPress/4.0-beta2-20140728; http://jetpack.me
    Host: rumorsmarket.com
    Accept: */*
    Content-Length: 102
    Content-Type: application/x-www-form-urlencoded
    
    <?xml version="1.0&"?><methodCall><methodName>demo.sayHello</methodName><params></params></methodCall>
    13:14:07.548884 IP wordpress.com.paycash-wbp > ns5001450.ip-192-95-32.net.http: Flags [P.], seq 1530255339:1530255719, ack 3351134744, win 29, options [nop,nop,TS val 393857679 ecr 2267645491], length 380
    E....c@.:.. B.	a._ i...P[5....B......).....
    .y...).3POST /xmlrpc.php?for=jetpack&rand=202125213 HTTP/1.0
    User-Agent: The Incutio XML-RPC PHP Library
    Host: rumorsmarket.com
    Accept: */*
    Content-Length: 172
    Content-Type: application/x-www-form-urlencoded
    
    <?xml version="1.0"?>
    <methodCall>
    <methodName>jetpack.verifyRegistration</methodName>
    <params>
    <param><value><string>secret</string></value></param>
    </params></methodCall>
    13:14:07.916697 IP wordpress.com.8171 > ns5001450.ip-192-95-32.net.http: Flags [P.], seq 2603972733:2603973218, ack 559565334, win 29, options [nop,nop,TS val 393857771 ecr 2267645583], length 485
    E.....@.:._}B.	a._ i...P.5x}!ZJ.....D......
    .y...)..POST /xmlrpc.php?for=jetpack&token=%23Y5U7ktZza6TPyoYEW%29Hu%29l%2ADkeYB%235L%3A1%3A1&timestamp=1407517400&nonce=eeYQ1NtMeI&body-hash=pdst%2B%2B8gjpsEsdzTGdS19%2BYN3g4%3D&signature=eUM%2B2pqiwHLhIy9f5ZmffHrzL3o%3D HTTP/1.0
    User-Agent: Jetpack by WordPress.com
    Host: rumorsmarket.com
    Accept: */*
    Content-Length: 114
    Content-Type: application/x-www-form-urlencoded
    
    <?xml version="1.0"?>
    <methodCall>
    <methodName>jetpack.testConnection</methodName>
    <params>
    </params></methodCall>
    ^C
    6 packets captured
    21 packets received by filter
    0 packets dropped by kernel

    Here are the response

    [root@ns4007603 sites-enabled]# curl -d '<methodCall><methodName>demo.sayHello</methodName></methodCall>' http://rumorsmarket.com/xmlrpc.php
    <?xml version="1.0" encoding="UTF-8"?>
    <methodResponse>
      <params>
        <param>
          <value>
          <string>Hello!</string>
          </value>
        </param>
      </params>
    </methodResponse>
    [root@ns4007603 sites-enabled]# curl http://rumorsmarket.com/xmlrpc.php?rsd
    <?xml version="1.0" encoding="UTF-8"?><rsd version="1.0" xmlns="http://archipelago.phrasewise.com/rsd">
      <service>
        <engineName>WordPress</engineName>
        <engineLink>http://wordpress.org/</engineLink>
        <homePageLink>http://rumorsmarket.com</homePageLink>
        <apis>
          <api name="WordPress" blogID="1" preferred="true" apiLink="http://rumorsmarket.com/xmlrpc.php" />
          <api name="Movable Type" blogID="1" preferred="false" apiLink="http://rumorsmarket.com/xmlrpc.php" />
          <api name="MetaWeblog" blogID="1" preferred="false" apiLink="http://rumorsmarket.com/xmlrpc.php" />
          <api name="Blogger" blogID="1" preferred="false" apiLink="http://rumorsmarket.com/xmlrpc.php" />
              </apis>
      </service>
    </rsd>

    I’ve tried with the older version of

    Jetpack Compatibility Test
    Tests your site’s compatibily with Jetpack.
    Version 1.5 | By Automattic | Visit plugin site

    It does work.

    Site info
    
    SITE_URL: http://rumorsmarket.com
    HOME_URL: http://rumorsmarket.com
    TEST: HTTP Connection
    
    Array
    (
        [headers] => Array
            (
                [server] => nginx
                [date] => Sat, 09 Aug 2014 10:22:25 GMT
                [content-type] => text/plain;charset=utf-8
                [connection] => close
                [vary] => Cookie
                [x-pingback] => http://jetpack.wordpress.com/xmlrpc.php
                [expires] => Wed, 11 Jan 1984 05:00:00 GMT
                [cache-control] => no-cache, must-revalidate, max-age=60
                [pragma] => no-cache
                [x-hacker] => Jetpack Test
            )
    
        [body] => OK
        [response] => Array
            (
                [code] => 200
                [message] => OK
            )
    
        [cookies] => Array
            (
            )
    
        [filename] =>
    )
    TEST: HTTPS Connection
    
    Array
    (
        [headers] => Array
            (
                [server] => nginx
                [date] => Sat, 09 Aug 2014 10:22:26 GMT
                [content-type] => text/plain;charset=utf-8
                [connection] => close
                [vary] => Cookie
                [x-pingback] => https://jetpack.wordpress.com/xmlrpc.php
                [expires] => Wed, 11 Jan 1984 05:00:00 GMT
                [cache-control] => no-cache, must-revalidate, max-age=60
                [pragma] => no-cache
                [x-hacker] => Jetpack Test
            )
    
        [body] => OK
        [response] => Array
            (
                [code] => 200
                [message] => OK
            )
    
        [cookies] => Array
            (
            )
    
        [filename] =>
    )
    TEST: Self Connection
    
    Array
    (
        [headers] => Array
            (
                [server] => nginx
                [content-type] => text/plain;charset=UTF-8
                [vary] => Accept-Encoding
                [x-powered-by] => PHP/5.4.31
                [expires] => Sun, 10 Aug 2014 10:33:15 GMT
                [cache-control] => max-age=86400, max-age=86400, public, must-revalidate, proxy-revalidate
                [pragma] => public
                [content-length] => 42
                [accept-ranges] => bytes
                [date] => Sat, 09 Aug 2014 10:33:15 GMT
                [age] => 0
                [connection] => close
            )
    
        [body] => XML-RPC server accepts POST requests only.
        [response] => Array
            (
                [code] => 200
                [message] => OK
            )
    
        [cookies] => Array
            (
            )
    
        [filename] =>
    )

    But doesn’t work on the newest version of Jetpack debug

    SELF:
    	Array
    (
        [headers] => Array
            (
                [server] => nginx
                [date] => Sat, 09 Aug 2014 10:23:48 GMT
                [content-type] => text/plain;charset=utf-8
                [connection] => close
                [x-pingback] => http://jetpack.wordpress.com/xmlrpc.php
                [expires] => Wed, 11 Jan 1984 05:00:00 GMT
                [cache-control] => no-cache, must-revalidate, max-age=60
                [pragma] => no-cache
                [x-hacker] => Jetpack Test
            )
    
        [body] => {"error":"Communication error","error_description":"We were unable to make an XML-RPC request to your website. Please make sure that XML-RPC is turned on and that Jetpack is installed, activated and connected with your WordPress.com account. If the error persists, try disconnecting and connecting Jetpack again."}
        [response] => Array
            (
                [code] => 400
                [message] => Bad Request
            )
    
        [cookies] => Array
            (
            )
    
        [filename] =>
    )

    http://jetpack.me/support/debug/?url=rumorsmarket.com

    Communication error
    
    We were unable to make an XML-RPC request to your website. Please make sure that XML-RPC is turned on and that Jetpack is installed, activated and connected with your WordPress.com account. If the error persists, try disconnecting and connecting Jetpack again.
    
    If you continue to get this error, please check out our troubleshooting guide or contact support

    turnonnet

    (@turnonnet)

    hosting at ?

    My own server at OVH

    [root@ns5001450 ~]# uname -a
    Linux ns5001450.ip-192-95-32.net 3.10.9-xxxx-grs-ipv6-64 #1 SMP Wed Aug 21 11:51:59 CEST 2013 x86_64 x86_64 x86_64 GNU/Linux
    [root@ns5001450 ~]# varnishd -V
    varnishd (varnish-3.0.5 revision 1a89b1f)
    Copyright (c) 2006 Verdens Gang AS
    Copyright (c) 2006-2011 Varnish Software AS
    [root@ns5001450 ~]# nginx -v
    nginx version: nginx/1.0.15
    [root@ns5001450 ~]# php-fpm -v
    PHP 5.4.31 (fpm-fcgi) (built: Jul 24 2014 09:25:56)
    Copyright (c) 1997-2014 The PHP Group
    Zend Engine v2.4.0, Copyright (c) 1998-2014 Zend Technologies
        with XCache v3.1.0, Copyright (c) 2005-2013, by mOo
        with XCache Cacher v3.1.0, Copyright (c) 2005-2013, by mOo
    [root@ns5001450 ~]#

    Plugin Contributor Brandon Kraft

    (@kraftbj)

    Happiness Engineer

    Hi,

    I’m still looking into this. The debug test is failing at the authenticated_xmlrpc_request test, when we verify that we can communicate using our shared token and signature system.

    We include the URL and port number as part of the signature process, so my initial thought is we’re using port 80 during the signing process while your server is trying to use 8080 when verifying the signature, which happens in class.jetpack-signature.php.

    We use either 80 by default, the value of $_SERVER['SERVER_PORT'].

    Your kind of setup will work (hosting providers like WP Engine have something similar), though it is personally over my head on configuring it.

    Does that put you in the right direction?

    Dear Brandon,

    Thank you very much you solved my problem that wasting me almost half year.
    We can cheat the php by modify wp-config.php

    add this line

    $_SERVER['SERVER_PORT'] = 80;

    Then all working well.

    Thanks everyone! The solution works on my setup too! i can now upgrade our clients jetpack! ( last working jetpack was 2.7 ).

    Hey guys,

    Thanks everyone for your suggestions. I just resolved the same issue using the suggestion that Brandon suggested but I had to use port 443 based on 443 being the port used for https connections. Here is what I added to wp-config.php to resolve the issue:

    $_SERVER['SERVER_PORT'] = 443;

    If other solutions haven’t worked you might want to give this one a shot.

    Thanks @wpengine_mike! Your solutions works for me as my site is on HTTPS with Haproxy in front and Apache behind!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Jetpack: [failed_publicize_action] Invalid Publicize ID Error code: -32601’ is closed to new replies.