Support » Fixing WordPress » Jetpack errors on install with publicise

  • Hi, I have installed jetpack so i can use publicise. Upon installation I recieved this error:

    Warning: set_time_limit(): Cannot set max execution time limit due to system policy in /customers/2/a/5/parkwyddnjfc.uk/httpd.www/2018website/wp-content/plugins/jetpack/class.jetpack.php on line 5021 Warning: Cannot modify header information – headers already sent by (output started at /customers/2/a/5/parkwyddnjfc.uk/httpd.www/2018website/wp-content/plugins/jetpack/class.jetpack.php:5021) in /customers/2/a/5/parkwyddnjfc.uk/httpd.www/2018website/wp-includes/pluggable.php on line 1216

    I can press back and return to wordpress and then connect wordpress.

    I then activate publisize and tried it, it worked great. However, on my website with publicise activated I get this error:

    Warning: count(): Parameter must be an array or an object that implements Countable in /customers/2/a/5/parkwyddnjfc.uk/httpd.www/2018website/wp-includes/post-template.php on line 284

    Hopefully someone can help as publicise works exactly as I need.

    Thanks

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Sorry, not a WordPress issue. https://jetpack.com/support/publicize/

    Strange, Jetpack told me it wasn’t a jetpack issue and directed me here….

    Hi there,

    I am Dat, working on the Jetpack plugin.

    Next time, please create a topic here https://wordpress.org/support/plugin/jetpack
    You can also contact us http://jetpack.com/support/

    Warning: count(): Parameter must be an array or an object that implements Countable in /customers/2/a/5/parkwyddnjfc.uk/httpd.www/2018website/wp-includes/post-template.php on line 284

    Can I know which PHP version of your site?
    Does the issue persist when switching between PHP 5.6.x and PHP 7.0?

    It looks like this issue is being reported here also
    https://core.trac.wordpress.org/ticket/42814

    Cheers,

    Internal ref: 863780-zen

    • This reply was modified 1 year, 8 months ago by  Dat Hoang.

    I’m seeing the same issue on one of my WordPress sites. When I use any version of PHP up to 7.1, the page is fine. When I switch to 7.2, I get this error message:

    Warning: count(): Parameter must be an array or an object that implements Countable in /wp-includes/post-template.php on line 284

    So, I compared post-template.php from one of my sites that works fine under PHP 7.2 and the one giving me the error. Each is running version 4.9.2 WordPress. However, there are subtle differences between the two post-template.php files! None of the differences is anywhere near line 284, but I’m still baffled how two supposedly identical files can have different content.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Jetpack errors on install with publicise’ is closed to new replies.