WordPress.org

Support

Support » Plugins and Hacks » Jetpack error xml_rpc-32700

Jetpack error xml_rpc-32700

  • Your Jetpack has a glitch. Something went wrong that’s never supposed to happen. Guess you’re just lucky: xml_rpc-32700
    Try connecting again.

    The quote above is what happens when I

    1. shut down all plugins
    2. try to activate Jetpack with WP.com
    3. connect to wordpress (for API)

    Do any of you scholarly chaps have any advice on this?

    I’ll try with “blank” htaccess too, but with all plugins turned off, I would have expected this to work. I don’t even know what this error is.

Viewing 15 replies - 1 through 15 (of 18 total)
  • Hi Btard:

    Two suggestions:

    1) That error suggests your blog is having trouble actually making a connection to WordPress.com. Simply trying again can work.

    2) We’ve identified and fixed many host specific connection issues in Jetpack 1.1.1 which was released on Friday – You should install the latest version, either through upgrade or from http://jetpack.me

    Hi

    I have the same problem with the last version too. Do you have any solution¿¿?? I have several WP and this issue is just in one of them, in the others works properly.

    Best Regards

    Same problem here with one of my sites. Deactivating plugins seems to have no effect. Not sure what the source of the error is. Has anyone found a workaround?

    I’m using WP 3.1.1 and Jetpack 1.1.1.

    Hi

    I’m using WP 3.1.1 and Jetpack 1.1.1 too.

    Best Regards

    I have seen the same error several times. I have found that if I clear the caches (I use W3 Total Cache) as soon as I activate the plugin, then it will connect. If it fails the first time, just clear the cache again and try again. Works for me.

    Hmm. I’m using WordPress 3.1.2 and Jetpack 1.1.2. I’m moving a site from one server to another; while both use different virtualization techniques and certainly there are some different settings on Apache + PHP + MySQL, they seem to be pretty much the same, except that this second server has a far slower database connection (not that the first one had a quick one, but certainly faster).

    On the second server, I cannot activate Jetpack, whatever I try… I started with a “clean slate” with no plugins at all, and it failed. Then I started adding W3 Super Cache (it helps a lot with superslow database servers) and a few extra plugins, but Jetpack never managed a connection. This is a multisite WP install, so after activating multisite, I tried to activate Jetpack on the sub-sites (just two for now). No luck. And definitely the XML-RPC check works. Since, as said, the setup is pretty much the same, my only conclusion is that the superslow MySQL database access is somehow interfering, e.g. Jetpack requires a XML-RPC reply in less than a few nanoseconds 🙂 and since this server will take its time responding, Jetpack will silently fail. Is there some hack I can do on the Jetpack code to increase the timeouts or something? If this is really just timeout-related, maybe a good idea is to have the timeout as a user-configurable setting on Jetpack’s backoffice?

    Oops… I meant W3 Total Cache of course (I’m not using WP Super Cache any longer hehe; W3 Total Cache is far, far better)

    Gwyneth, in my case, the plugin is working on one site but not another even though both sites are installed on the same server (different directories and URLs). I also have caching enabled, and I suspect there is a conflict with it, but I haven’t yet turned everything off to see if it works. My sites that aren’t using caching have no problems with Jetpack; the one that is using caching has a problem.

    @djsparks you’re right!! With the latest Jetpack upgrade, the nice Automattic guys are now giving extra information, explicitly check for W3 Total Cache (and possibly other caching plugins, too), and on the error message they advise to turn caching off, connect to WordPress, and turn it on again.

    It certainly fixed things for me on one WP install.

    On the other site, as per your suggestion, I turned all plugins off, and tested it one by one. And now it works! I’m logged in! Hah! So simple 🙂

    Apparently, the culprit seems to be google-maps-embed; when re-installing it, WP complains about header files already been sent. Still, I can re-activate this plugin and Jetpack will continue to work.

    I had the same problem, had do specifically disable wpstats to get jetpack to connect. Later Jetpack automatically brought up stats which now looks different than it used to before.

    I had to deactivate all of my plugins (sans Akismet and Jetpack) before it would work!
    http://edwardianpromenade.com

    I tried to activate jetpack on my new standalone without success, I receive the error xml_rpc-32700 thoug the xmlrpc server works properly.
    Deactivating/reinstalling plugin does not help 🙁

    I am having the same problem.

    @gabblgob, did you find a solution?

    @lutetia
    Not at all. It looked like a problem of cloud hosting where my WP is located, now everything works OK. I have no idea what there was and/or what they did, after few days I just saw my WP is connected – that’s it. Mystery, but true.

    Thanks…I’ve just sent an email to my hosting provider to see what they say.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Jetpack error xml_rpc-32700’ is closed to new replies.
Skip to toolbar