Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » Jetpack error when connecting

  • Resolved acattabriga

    (@acattabriga)


    I’m trying to re-install Jetpack so I can use the Woocommerce Tax plugin and when I go to connect Jetpack I get this error

    ” Invalid request, please go back and try again.
    Error Code: invalid_request
    Error Message: The required “scope” parameter is malformed.”

    I’ve tried uninstalling the plugin and reinstalling it. I’ve tried loading my site from a backup. Nothing works and I can’t get jetpack to connect and setup.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support Michelle (a11n)

    (@deathlynotes)

    Hey @acattabriga

    Glad to help!

    Jetpack is not connected to your site because your xmlrpc.php file is locked by your hosting. That means we cannot access your site, which is needed for our connection:

    https://www.docbrowns.com/xmlrpc.php

    The link above must return the following message:

    XML-RPC server accepts POST requests only.

    You can see a working example here: http://jetpack.me/xmlrpc.php

    Since your site returns a 403 “Forbidden” error for this page, please check the following:

    * Can you see the /xmlrpc.php file at the root of your WordPress installation when accessing your site via FTP (if you’re not sure what this means, please ask your hosting customer support for a hand)? If you don’t, then please try re-installing WordPress. You can do this by going to the Dashboard → Upgrades page, then clicking the “Reinstall WordPress” button.

    * Do you use any security plugins that may block access to this file? If so, could you try to disable them? You might also want to check your site’s .htaccess file for any rules that might be blocking access to the xmlrpc.php file. Again, if you’re not sure what this means, your host customer support should be able to lend a hand.

    * Does your hosting provider block access to this file? If you don’t find any plugin that may block access to the file on your site, I would recommend that you get in touch with your hosting support and ask them to allow Jetpack to access xmlrpc.php.

    Let me know if you have any questions.

    My best regards,

    Michelle

    Anonymous User 18700194

    (@anonymized-18700194)

    Hi there,

    It has been more than one week since we have heard from you, so I’m marking this topic as resolved.

    But if you have any further questions or need some more help, you’re welcome to reply here or open another thread.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Jetpack error when connecting’ is closed to new replies.