Support » Plugins » Jetpack Error Code

  • Resolved sundijo


    I accidentally uninstalled Jetpack on a blog. When I went to reinstall it and connect to I got this error code:

    Your Jetpack has a glitch. Something went wrong that’s never supposed to happen. Guess you’re just lucky: xml_rpc-32700
    Try connecting again. Error Details: The Jetpack server could not communicate with your site’s XML-RPC URL. Please check to make sure is working properly. It should show ‘XML‑RPC server accepts POST requests only.’ on a line by itself when viewed in a browser and should not have any blank links or extra output anywhere.

    Any ideas what I need to do? That’s how I prefer to look at my daily stats.


Viewing 6 replies - 1 through 6 (of 6 total)
  • same problem here =/

    Thanks for sharing. I tried to deactivate but that didn’t fix it. Do you know how I clear the cache?

    @sundigo: If you look at, there are three blank lines before the text “XML‑RPC server accepts POST requests only.” is output. This usually indicates that another plugin or your theme is interfering with Jetpack’s ability to talk to our servers at Could you try disabling your other plugins and switching your theme temporarily to Twenty Ten or Twenty Eleven, then connect Jetpack again?




    My solutions was to look into the error log (/error_log) file, and I found out that one of the classes from the WordPress Ecommerce Data Feeder plugin had an error (just a simple typo – a missing comma: [28-Oct-2012 12:59:20] PHP Parse error: syntax error, unexpected T_RETURN in /public_html/wp-content/plugins/ecommerce-feeder/classes/WPSC_Ecommerce_Feeder_XML.class.php on line 164).

    I corrected it, and everything works now.

    So, as a general advice, try looking into your /error_log file before spending too much time on various forums for specific solutions.

    Hope it helps someone…


    I am getting this error when I tried to connect Facebook…none of the other sharing is working.

    Something which should never happen, happened. Sorry about that. If you try again, maybe it will work.
    Error code: -32301
    This is a very ambivalent error. Any directions will help. Thanks

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Jetpack Error Code’ is closed to new replies.