Support » Plugins and Hacks » Jetpack by WordPress.com » [Resolved] Jetpack email subscriptions sending in Spanish

[Resolved] Jetpack email subscriptions sending in Spanish

  • Hello everyone,

    I’ve recently noticed that my Jetpack email subscriptions are being sent to subscribers in Spanish, even though the default language of my blog is English.

    I should clarify that the actual blog content of the subscriber emails is in English, as expected, but the email subject line, the date, comment button and footer subscription information is all in Spanish.

    I subscribe to my own blog, just so I can see what is being sent out, which is how I caught this.

    Anyone else had this issue and how did you solve it? Thanks for any assistance.

    Billy Sheahan
    Chicago, IL USA


Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Jeremy Herve


    Could you post your site URL here, so I can have a look?

    If you want it to remain private, you can also contact us via this contact form:

    I have the same problem. Blog is in english but Google plus button appears with “Seguir” this is spanish. http://www.alinirimia.com

    You should be able to check at the end of a post.

    Thank you

    Alin Irimia

    Plugin Author Jeremy Herve


    @alinirimia Your problem seems different, since it doesn’t involve Jetpack Subscriptions, but a Google+ button.

    Could you check your Google+ settings and make sure that your language settings are set to English?

    If that doesn’t help, could you please start your own thread, as per the Forum Welcome?

    Thank you!

    Hello Jeremy,

    I’m getting the same problem as Billy: the email sent is mixed spanis/englilsh when it should be in catalan (I’ve translated the strings in jetpack-ca.po), but nothing… As the site is under construction, I hope you don’t mind if I send you a private message as you suggested to Billy.


    Plugin Author Jeremy Herve


    @asdevargas if you’ve sent us an email via the contact form, we’ll reply very soon!

    In the meantime, you could check for untranslated in the WordPress.com GlotPress project:

    Indeed, some Jetpack modules like Comments, email subscriptions or Likes, are hosted on WordPress.com. Thus, you will have to look in the WordPress.com GlotPress project to find the strings to translate.

    Hello Jeremy,

    Thanks for the suggestion, I went to the link and find some of my missing strings: “Confirm follow”, “Blog Name”, “If you want to see all of the blogs…” and suggested translations for them; unless one “Modify your subscription options” that doesn’t appear.

    Could you please tell me what I should do now? I have downloaded “All current” but I’m not quite sure to know what I should do with it, where it should go –and I see that that my suggested translations are not in the po (I guess until approved).

    Thank you in advance for your help…

    Plugin Author Jeremy Herve


    unless one “Modify your subscription options” that doesn’t appear.

    I would suggest that you try to search for Subscription options and modify separately.

    Could you please tell me what I should do now?

    Until your translations are approved by a validator, you won’t be able to see them in your subscription emails. As soon as they are approved, we’ll deploy them and you will start seeing them in all new subscription emails.

    Hello Jeremy,

    I finally found them. So I will wait for the validation, thank you very much for everything.


Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] Jetpack email subscriptions sending in Spanish’ is closed to new replies.
Skip to toolbar