Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » Jetpack Email-Only Subscribers Not Receiving E-Mail Updates Of New Posts

  • Resolved consumerista


    Hello, I have a premium Jetpack account for one blog and the free plan for another. Today, I’m having issue with the free one.

    I have about 500+ subscribers through Reader, and around 20 other ones that are “email only”. When I make a new post, the ones receive an e-mail (per their notification settings), but none of the e-mail-only accounts receive an update. It isn’t in the spam folder or anything.

    I suspect this change may have happened when I switched from to a few months. However, my e-mail only subscribers are still showing up in my control panel, and everything looks like it is working in there. I debugged Jetpack and there are no issues with Jetpack on my site.

    Subscriptions enabled in Jetpack–> Settings –> Discussion

    When I click “View Your Followers” in that same panel, I get redirected to, and I can see a list of my e-mail-only followers.

    My domain can be accessed using the following link:

    Thanks for your help

Viewing 7 replies - 1 through 7 (of 7 total)
  • Thread Starter consumerista


    I checked on my other blog and the e-mail-only subscribers are receiving new content. Same theme, same plugins, same server, etc., so the issue is unique to my current one.

    There also seems to be an error when users try to subscribe via e-mail using the contact form.

    Plugin Support Mehdi (a11n)


    Hi @consumerista

    You mentioned having issues with your email-only followers as they’re not receiving any emails when a new post is published.

    As a first step, can you confirm that you are publishing these posts through the admin account that connected Jetpack on your WP-Admin dashboard?

    It’s also worth noting that the subscription feature only works with newly-published posts, and not those that were previously published privately, and not those that were updated to a newer publish date. I’ve also found that you had the Duplicator plugin activated; posts that are generated through it would likely not send a notification. Could you confirm whether these are the cases of your posts?

    To troubleshoot this, I’d suggest reconnecting as explained in our guide:

    You can then temporarily disable the WP Fastest Cache and Heartbeat Control by WP Rocket plugins and try to resubscribe using the form.

    Let us know how this goes.

    Thread Starter consumerista


    Hello. I think when they set up my site they synced my main domain with the version. I just disconnected Jetpack, and when I go to reconnect, it keeps redirecting me to the, even when I manually change the URL from this to just

    I wonder if this arrangement affected e-mail somehow for e-mail-only subscribers?

    The stats have been syncing on my and The is also listed as my “primary site” on, because my domain is hosted elsewhere, even though it was purchased through Not sure if these things have any effect at all, just small differences between the site of mine that is working and the one that isn’t.

    To answer your question, yes I’m aware it only works on new posts, and none of the posts were made using duplicator. I was also publishing them through the dashboard on my main domain which was connected to Jetpack. The e-mails are getting sent on new posts for subscribers; the e-mail-only ones are what are giving me issues.

    I disconnected Jetpack and reconnected again to my WordPress email. Everything is as it was before. I sent out another test e-mail and it was e-mailed to the subscribers but not the e-mail only subscribers.

    FYI, this is the end of the URL it redirects me to when I try to “Subscribe” using the subscribe form: form

    Here is the live link of the subscribe form:

    Another piece of info. The “follow” form IS working on my That site is private, but some version of Jetpack is connected. It also doesn’t have the stats for e-mail subscribers synced, so the amount of subscribers is single digits, even though the “Site Views” is updated when I click on it in the control panel.

    Thread Starter consumerista


    FYI, I got SMTP set up per the recommendation of my host, but that did not solve the problem. (My host spent like an hour troubleshooting this one with no luck.) We disabled/deleted reinstalled, uninstalled other plugins, etc.

    I will add that I noticed Jetpack “contact form” wasn’t working on either of my sites a few weeks ago (no emails being sent), and I switched both of my sites to WPForms. I suppose the issue with E-Mail subscriptions may be related (?) but it’s only happening on one of my sites.

    I also notice that the “Blog Subscriptions (Jetpack)” widget and the Jetpack “Forms” are not working despite me having “Extra Sidebar Widgets” and “Contact Form” enabled. I have to use the shortcode to get the Subscription form to show up, which isn’t a problem I guess.

    Jetpack just seems really buggy rn for some reason.

    Plugin Contributor Stef (a11n)


    Hi there, @consumerista,

    I tried to subscribe as well and I got the same error. I then noticed that there are some pending invitations that have never been confirmed, some were very very old. I removed them to shorten the pending queue, but I was still unable to subscribe.

    I then noticed that you also have a MailPoet signup form on the same page: even if it’s unlikely, can you try temporarily deactivating it and then using a different email address to try subscribing again?

    Can you also confirm that email-only subscribers not getting any updates have not subscribed to the MailPoet form instead?

    Thread Starter consumerista


    I added the MailPoet yesterday because the Jetpack wasn’t working even after troubleshooting for hours. The MailPoet plugin isn’t the issue.


    Hi @consumerista

    I made some tests on your site and there is something installed on the site that’s causing problems.

    The best way to find out if something is interfering is to test for a theme or plugin conflict. You can do that by following these steps:

    * **Temporarily deactivate all plugins except Jetpack, and [clear your browser’s cache](**

    Then try to subscribe on your site again using another email. If your Subscription works, then you know another plugin is conflicting here.

    You can reactivate plugins one by one, subscribing with different emails after each one to discover which plugin is causing the problem. You can leave that plugin deactivated and/or contact whoever makes that plugin for help resolving the issue it’s causing.

    * If deactivating plugins doesn’t help, it may be your theme. **Temporarily activate a default WordPress theme like [Twenty Twenty-One](**

    Then try to subscribe on your site again using another email.If it works, then you know it’s a problem with the theme. You can contact whoever makes the theme for help resolving the issue it’s causing.

    Let me know if you have any questions.

    My best regards,


Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Jetpack Email-Only Subscribers Not Receiving E-Mail Updates Of New Posts’ is closed to new replies.