Support » Plugin: Jetpack by » Jetpack 'Edit CSS' box not loading

  • I’ve just noticed this evening that the ‘Edit CSS’ box won’t load. I just get a never ending pinwheel in the middle of the box, as if it’s loading the file, but the code never shows up.

    I’ve tried Safari and Firefox, switching themes, deactivating all plugins (though I haven’t activated or updated any new plugins in the past few days), and deleting and reinstalling the Jetpack plugin.

    My many CSS revisions were still intact, so I’ve been able to save that at least.

    I just can’t edit the CSS any more.

    What else can I try to get this working again?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Contributor designsimply


    I just tested the Edit CSS page on a blog running WordPress 3.4.2 and Jetpack 2.0, and adding, editing, and saving custom CSS worked in my tests. I’m using the Twenty Twelve theme, and I tested from Firefox 16.0.2 on MacOS 10.7.5.

    Do you have anything like the Firebug add-on installed in Firefox that you could use to try to check for errors when you load the Edit CSS page? I found one error on my test site, but I’m not sure if it’s related to the issue you reported since I can see the error and my CSS Editor still works fine.

    Script file not found: /wp-content/plugins/jetpack/modules/custom-css/safecss/js/ace/worker-css.js.js

    Thanks for the response, and for the instructions to check for errors!

    I have Firebug installed in Firefox, but I’m not familiar with how to use it. There is a similar functionality in Safari though, and I was able to track the problem down to a conflict with a plugin, “All In One Event Calendar by Timely”. According to Timely’s website this is a known issue.

    Just FYI, I’ve tested and found the error happening in Safari, Firefox, and Opera, but the page loads just fine on my iPhone and iPad.

    So again, thanks for the tip. I only wish there was something I could do to fix the conflict. I’ll either have to find another calendar plugin or just not use Jetpack’s CSS editor anymore 🙁

    Plugin Contributor designsimply


    Good find. Sounds like Timely sees it as a known issue, and hopefully they will address it.

    Also, it seems like the file not found error is not related to the Timely plugin issue you found, but I wanted to note that we will fix the file not found error I found in Jetpack on our side.

    Jive Dig


    Ugh. Same issue here. . . took me a while to find it, but it’s Timely related here too.

    Whoever here’s about a Timely fix first please post so we call know!

    Plugin Contributor designsimply


    I was able to track the problem down to a conflict with a plugin, “All In One Event Calendar by Timely”. According to Timely’s website this is a known issue.

    @texasellis, it would be helpful to link back to where you saw that Timely posted about the issue.



    Here’s a link to their support page:

    There are a couple of responses from Timely folks which state something to the effect of, “We’ll put that on our list of issues to address.” They’ve also said a major 2.0 update is on the horizon, and was to be released around the end of November, but that has apparently been delayed.

    In the meantime I’ve stopped using Jetpack’s CSS editor, as the Timely plugin really does seem to be the best, most user-friendly calendar plugin **that can import Google calendar ics feeds** available. Believe me, I’ve looked for alternatives.

    For those interested, as a workaround I’ve placed a call to my external CSS file in my theme’s header.php file, in the form of

    <link rel="stylesheet" href="" type="text/css" />

    I simply edit this CSS file in a text editor (Text Wrangler) which downloads and uploads the file directly to and from the server via FTP. It’s not as elegant as the Jetpack solution, but it works for now.

    I look forward to the day when these two plugins can play nicely together 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Jetpack 'Edit CSS' box not loading’ is closed to new replies.