Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » Jetpack Dashboard was unable to properly communicate with your website.

  • Resolved hellocorey

    (@hellocorey)


    I have set up a fresh instance of WordPress on my subdomain with the intention of setting up a store with Woo Commerce, but Jetpack and Woo Commerce are having issues connecting:

    Jetpack: Jetpack Dashboard was unable to properly communicate with your website. Please check your website’s error logs to see what’s wrong.

    Woo Commerce: There was an error getting your inbox. Please try again.

    I have actioned all the troubleshooting guides I can find.

    • Configured for Cloudflare
    • Jetpack debug says everything is fine
    • Site health is currently fine, but it occasionally changes to have a Critical Error stating Jetpack cannot connect to wpcom: “shop.hellocorey.com is not connected. 200”
    • xmlrpc.php test displays correctly as: “XML-RPC server accepts POST requests only.” However fails validation test at https://xmlrpc.eritreo.it/#

    cURL error 35: error:1409442E:SSL routines:ssl3_read_bytes:tlsv1 alert protocol version

    I have checked with GoDaddy to make sure the xmlrpc.php isn’t blocked.

    This is well outside my knowledge, so I am well and truly stuck. Any help would be appreciated. Thanks.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support Animesh Gaurav

    (@bizanimesh)

    Hi @hellocorey

    It seems that you’re using Cloudflare but enable TLS 1.3 only. Can you please enable TLS 1.2 as well? Our system has not supported TLS 1.3 yet.

    Cloudflare has good documentation here:

    After that, please try disconnecting and reconnecting Jetpack on your site.

    You can follow these instructions to do that:

    1. Go to the Jetpack menu in your WP Admin dashboard
    2. Scroll down to find the Connections area.
    3. Click Manage site connection.
    4. Click Disconnect and follow the prompts to complete the disconnection process.
    5. Click the Set Up Jetpack button to connect your site to WordPress.com again.

    This handy guide explains the full process in more detail: https://jetpack.com/support/reconnecting-reinstalling-jetpack

    Let us know if the issue is still there?

    Thread Starter hellocorey

    (@hellocorey)

    Thanks for the quick response @bizanimesh

    I have lowered the minimum TLS to 1.2 and cleared the Cloudflare caches for good measure, but the issue is still persisting.

    I’m still seeing this banner in the Jetpack daskboard:

    “Jetpack Dashboard was unable to properly communicate with your website. Please check your website’s error logs to see what’s wrong.”

    Though, site health is now showing a new critical issue:

    The REST API encountered an error
    The REST API is one way WordPress, and other applications, communicate with the server. One example is the block editor screen, which relies on this to display, and save, your posts and pages.

    The REST API request failed due to an error.
    Error: [] cURL error 28: Operation timed out after 10001 milliseconds with 0 bytes received

    Appreciate the help.

    Thread Starter hellocorey

    (@hellocorey)

    I did some further reading on the REST API issue and noticed that plugins are often the cause.

    I disabled everything apart from Jetpack, and reactivated them one-by-one and re-tested site health. Somehow, the REST API issue has resolved itself.

    Though connection issues with Jetpack and Woo Commerce are still persisting.

    Plugin Contributor Stef

    (@erania-pinnera)

    Hey @hellocorey,

    I did some further reading on the REST API issue and noticed that plugins are often the cause.

    I disabled everything apart from Jetpack, and reactivated them one-by-one and re-tested site health. Somehow, the REST API issue has resolved itself.

    That was amazing troubleshooting, well done! Glad you have solved this glitch. Now onto your connection issue!

    When I run a diagnostic test on your Jetpack connection, I get the following error:
    cURL error 28: Operation timed out after 30001 milliseconds with 0 bytes received.

    This usually means that your web host is blocking some connections Jetpack needs in order to work correctly. In fact, I can also see a 524 Origin Time-out error thrown by Cloudflare when trying to load your xmlrpc.php page.

    Could you please contact your web host and ask them to make sure that the connections to and from *.wordpress.com are whitelisted? In terms of IP ranges, the following ranges need to be fully whitelisted:

    https://jetpack.com/support/hosting-faq/

    To stay on the safe side, I’d also circle back to Cloudflare to make sure it’s setup okay as far as Jetpack is concerned – we have some info for this here and here.

    Let me know what you find out and we’ll take it from there. Thanks again for helping us sort this out!

    Plugin Support Animesh Gaurav

    (@bizanimesh)

    Hi @hellocorey

    One more update, I want to provide:

    I verified with the team, and now we support TLS 1.3, so you can enable TLS 1.3 and follow the steps that Stef has provided.

    Thread Starter hellocorey

    (@hellocorey)

    Thanks for the help so far everyone.

    @bizanimesh Got it, thanks.

    @erania-pinnera I have spoke to GoDadddy and referenced your notes, but unfortunately they were pretty unhelpful. They said they couldn’t help because the WP install was made directly in CPanel and not through their dashboard.

    With that in mind, I set up a temporary unsecured testing site at http://coreysilva.com and from what tell, communication between wordpress.com servers aren’t hindered.

    If I’m correct, does this point to Cloudflare as the issue? I have posted this issue in the community forum, but I’m yet to receive any replies.

    I double check the config settings for Cloudflare you linked to. I have set this up already, but I’m a designer by trade, so this stuff is well outside my area of expertise — I just try and work it out as I go.

    Thanks again!

    Thread Starter hellocorey

    (@hellocorey)

    If I’m correct, does this point to Cloudflare as the issue? I have posted this issue in the community forum, but I’m yet to receive any replies.

    I meant the ‘Cloudflare community forum’, thread here.

    Plugin Support Animesh Gaurav

    (@bizanimesh)

    Hi @hellocorey

    Could you please temporarily completely disable the Cloudflare for your site and then check the Jetpack connection? I’m somewhere confirm Cloudflare is not affecting this, but I might be wrong also, so it’s always better to check.

    If the Jetpack connection is looking good after disabling Cloudflare, then we know the source of the problem, and as a next step, make sure WP0002 – Block WordPress XML-RPC is disabled in Cloudflare. However, this should be disabled by default, but worth double-check this part. Here are more details. If you need help checking this, you will need to contact Cloudflare.

    Let me know what you find after disabling Cloudflare!

    Thread Starter hellocorey

    (@hellocorey)

    Thanks @bizanimesh

    Okay, so I have done a lot of testing and research and I’m 99% sure Cloudflare is the issue.

    First I tried disabling CF on shop.hellocorey.com but it just makes the primary and sub-domains inaccessible entirely. I’m sure I could fix this to test, but it’s not worth the trouble. Instead however, I just added CF dns to the test instance and coreysilva.com and the same exact problems occurred.

    There are 2 areas which I think are causing the issues:

    1. WP0002 rule
    This is apparently disabled by default, but there’s no way to know without at least a Pro plan.

    2. Caching Static HTML with WordPress/WooCommerce
    Which requires the ‘Bypass Cache on Cookie rule’ is only available in Business/Enterprise level plans

    So, I’ve concluded that it’s not possible for me to set up WordPress with WooCommerce/JetPack with a Cloudflare free plan — with my current set up at least.

    The store is an experiment anyway, so if I need to spend money to get it up and running, there are better ways to invest that capital. It’s a good time to look at my hosting when it renews in a few months.

    Anyway, thanks to you and @erania-pinnera for the help. Even though it wasn’t resolved, I’ve leant a lot. Hopefully this will help someone else with the same issue.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.