Support » Plugin: Jetpack by WordPress.com » Jetpack cron issue

  • Kevin

    (@kevinsandlingmailcom)


    I’ve had a bunch of cron issues that I just managed to clear up with some simple fixes to wp-config.php; however, when I view all the crons in my WP installation, JetPack stands out for 2 reasons:

    1. Next Run shows “2015-08-11 11:34:18 (now)” meaning it’s basically stuck. Two other crons show this same thing: wpseo_ping_search_engines and do_pings

    2. the “arguments” field shows the following junk:

    [“jetpack_activated”,”jetpack_active_modules”,”jetpack_available_modules”,”jetpack_do_activate”,”jetpack_log”,”jetpack_publicize”,”jetpack_slideshow_background_color”,”jetpack_widget_twitter”,”jetpack_wpcc_options”,”jetpack_relatedposts”,”jetpack_file_data”,”jetpack_security_report”,”jetpack_autoupdate_plugins”,”jetpack_autoupdate_themes”,”jetpack_autoupdate_core”,”jetpack_json_api_full_management”,”jetpack_sync_non_public_post_stati”,”jetpack_site_icon_url”,”jetpack_site_icon_id”,”jetpack_dismissed_manage_banner”,”jetpack_updates”,”jetpack_restapi_stats_cache”,”jetpack_unique_connection”,”jetpack_protect_whitelist”],”mock-option”:[“jetpack_is_main_network”,”jetpack_is_multi_site”,”jetpack_main_network_site”,”jetpack_single_user_site”],”stats”:[“stats_options”,”home”,”siteurl”,”blogname”,”blogdescription”,”gmt_offset”,”timezone_string”,”page_on_front”,”permalink_structure”,”category_base”,”tag_base”],”likes”:[“social_notifications_like”],”site-icon”:[“jetpack_site_icon_url”],”subscriptions”:[“home”,”blogname”,”siteurl”,”page_on_front”,”permalink_structure”,”category_base”,”rss_use_excerpt”,”subscription_options”,”stb_enabled”,”stc_enabled”,”tag_base”]}]

    I’ve deactivated / reactivated jetpack, cleared cash, hit /wp-cron.php but no change here.

    Suggestions?

    Thanks in advance.

    https://wordpress.org/plugins/jetpack/

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Could you let me know the changes you’ve made to fix cron on your site?

    Thanks!

    Kevin

    (@kevinsandlingmailcom)

    Thanks for the quick reply.

    Makers of the plugin I use to aggregate content recommended adding the following lines to wp-config.php:

    define(‘DISABLE_WP_CRON’, true);
    define( ‘WP_CRON_LOCK_TIMEOUT’, 1 );
    define( ‘ALTERNATE_WP_CRON’, true );

    the alternate cron was to come from easycron.com (one of several providers), but all that did was hit mydomain.com/wp-cron.php at certain intervals.

    After I made these changes, ALL crons went to “(now)” as the next run, and no crons ran unless manually forced.

    Today, I removed all those lines from wp-config.php, and voila, all crons but a handful no longer show (now) as next run. Jetpack still does (along with wpseo_ping_search_engines and do_pings), as well as showing all that junk in the “Arguments” field.

    Kevin

    (@kevinsandlingmailcom)

    Update: all crons show (now) as next run, so my changes did not help. I am running a content aggregation site (http://techblo.gs) on Godaddy Managed WP hosting.

    Everything else about this hosting is perfect, except this cron issue.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    What happens when you force the execution of the stuck cron jobs with a plugin like WP Crontrol?

    Kevin

    (@kevinsandlingmailcom)

    Nothing. “Run now” appears to work, but the cron jobs still show (now), rather than changing to their specified interval, including Jetpack.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Here is how WP Crontrol’s main screen (Tools > Crontrol) looks on my end at the moment:
    http://i.wpne.ws/cCpU

    Could you post a screenshot of how things look like for you right now?

    Kevin

    (@kevinsandlingmailcom)

    HA! I wish. I can’t zoom out far enough to get it on one page! Here’s what you can see after I scroll down to the Jetpack line:

    https://drive.google.com/file/d/0B7u3VdRwESR5NTJuTXltYXV4VFk/view?usp=sharing

    Here’s the top line view:
    https://drive.google.com/file/d/0B7u3VdRwESR5MUNzY25DeE96WE0/view?usp=sharing

    Kevin

    (@kevinsandlingmailcom)

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    That’s interesting. It might be worth getting in touch with one of the WordPress customer reps over at GoDaddy, just to make sure that’s not a known issue with their managed WP environment.

    Let me know how it goes.

    Kevin

    (@kevinsandlingmailcom)

    OK, spoke to the folks at Godaddy. We edited the jetpack_sync_all_registered_options cron job to have “none” in the arguments field.

    So far, that and all other cron jobs seem to have corrected themselves and are showing a proper “next run” time instead of (now).

    What would cause this issue?

    Thanks for the help.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    To be honest I’m not sure. What happens if you now revert your jetpack_sync_all_registered_options changes?

    Kevin

    (@kevinsandlingmailcom)

    No idea. Nobody seems to know why those arguments would appear with that cron. do you recommend putting all those arguments (above) back into that cron job?

    The basic problem is, for some reason, the cron jobs get stuck, and revert to (now) as their next run time. Nobody can explain why that is happening, nor how to fix it.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Nobody seems to know why those arguments would appear with that cron.

    The arguments appear there because we pass them to the function scheduling the cron job, wp_schedule_event(). That function accepts arguments, as you can see here:
    https://codex.wordpress.org/Function_Reference/wp_schedule_event

    It allows us to synchronize your site options with WordPress.com, thus making sure we always have up to date information about your site. We then use these options in multiple Jetpack modules, like Stats, Publicize, or Subscriptions. If you remove the arguments, the synchronization won’t happen properly, and if you ever change one of your site settings, the change won’t be synchronized with WordPress.com and we will continue to use the old options with some of the Jetpack modules.

    That doesn’t explain why your cron jobs get stuck, though. When you deactivate Jetpack altogether, do you continue to experience issues with other cron jobs on the site?

    Kevin

    (@kevinsandlingmailcom)

    Sorry, I didn’t ask the question correctly: nobody seems to know why that text (of all the arguments) would randomly just appear on that display in WP Crontrol, when every other time it appears, that particular cron shows “none” as its arguments.

    I’ve deactivated Jetpack, and will report back here to see if that affects other cron jobs.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Jetpack cron issue’ is closed to new replies.