Support » Plugins » Jetpack crashed server

  • I recently installed on an IIS/Windows server and tried to install this plugin and its crashed the server. Once I removed it (via ftp), everything worked properly again. Is this plugin not compatible with IIS/windows based servers?

Viewing 11 replies - 1 through 11 (of 11 total)
  • If you haven’t, you should take a look at your server’s error logs to find out what is going on. Jetpack is compatible with IIS.

    What exactly happens when you install Jetpack on you server?

    Hi Tim, thanks so much for your response.

    Here is a description of steps that lead up to the incident:

    • I found the plugin through the wp-admin/plugin section
    • I installed the plugin successfully using the wp-admin/automated installer
    • The minute I hit “activate” the browser displayed:

      Server error
      The website encountered an error while retrieving http://our.url/wp-admin/. It may be down for maintenance or configured incorrectly.
      Reload this webpage later
      HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfill the request.

    The server error logs only displayed 500 error codes with no additional explanation. Our Event logs also displayed no relevant information.

    Upon activating the plugin, every call to wordpress was causing a HTTP 500 Server Error condition.

    Since I couldnt get back to my wp-admin section to disable the plugin, I had to delete the jetpack folder via ftp. Once I did, the site was immediately accessible again.

    Any ideas how we can get jetpack to work? I greatly appreciate any assistance

    A few questions for you:

    What version of PHP are you running?

    Is your XMLRPC file being blocked? We can check that if you go to http://our.url/xmlrpc.php and post the response you get.

    If you could post or send us the PHP error log from around the time you tried to activate Jetpack, that would be helpful.



    We are running PHP 5.3.9

    The message I received when I checked the XMLRPC status is “XML-RPC server accepts POST requests only.” Do you suspect that is causing the problem? Would we need to turn that on in the file permissions or is that the same thing as the remote Settings “Enable XML-RPC” in the writing section of the wp-admin?

    No, that is the normal response when visiting the URL.

    Are you running any caching plugins or a firewall on your server? Is there any proxying going on and/or ports being blocked?

    No, we are not running any caching plugins (to my knowledge) and we are not running a firewall or proxy on the server, either (we have an external firewall).

    And to give a better idea of PHP logs, a week before we installed wordpress we upgraded our PHP to 5.3.9. Prior to upgrading there are some errors:
    [22-Jan-2012 07:02:38] PHP Warning: PHP Startup: Unable to load dynamic library ‘C:\Program Files\PHP\ext\php_curl.dll’ – The specified module could not be found.
    in Unknown on line 0

    But that stops on the 22nd (when we updated to PHP 5.3.9, which now seems to have the proper curl dll), and there are no errors during the weekend of January 28/29 when we were having the problems with Jetpack.

    It would be very helpful to see the PHP error logs at the time you installed Jetpack and the 500 errors occurred. Without that, I’m really just guessing at this point.

    I’d also urge you to run through the install process for the PHP curl extension to make sure it is properly installed.

    There were no error messages recorded in the php-errors.log during the time when we were getting the 500 server errors running WordPress. If you can think of any other place that the errors might have been recorded, I’d by happy to provide additional data, but I don’t know where else to look.

    I’ll check the PHP curl extension to make sure it is properly installed.

    i had this exact same problem today on my WordPress site running on IXWebHosting. I used FTP to change the name of the folder from JetPack to xJetpack, and the site recovered, albiet with an error..

    The plugin jetpack/jetpack.php has been deactivated due to an error: Plugin file does not exist.

    I am uninstalling it now – it does show on the uninstall menu.

    Sounds like a great tool, if I can get it to run….


    I resolved the problem, although I am not certain which of the two actions was the relevent one.

    First, I de-activated WP-Statistics plugin (which was installed and running). I suspect this was NOT the problem, I re-activated it afterwards and it did not appear to create a conflict with JetPack.

    Second, when JetPack gave me the ‘Server Error’, I logged out of my site, and logged back in. It worked fine after that. It seems that the JetPack install did not recognize my login for some reason….

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Jetpack crashed server’ is closed to new replies.