Support » Plugin: Jetpack by WordPress.com » Jetpack connection lost on my https site

  • Resolved dambuster2385

    (@dambuster2385)



    Paypal security requiements meant I had to make my site https with a SSL certificate. Now Jetpack won’t connect. I get the following error message:

    “Error Details: The Jetpack server was unable to communicate with your site [HTTP 404]. Ask your web host if they allow connections from WordPress.com. If you need further assistance, contact Jetpack Support: http://jetpack.com/support/“.

    Google analytics data has disappeared and I’m missing publicize. Badly!

    I hunted for support and from this page (https://jetpack.com/support/getting-started-with-jetpack/known-issues/) tried adding the suggested below wp-config lines (alternately) to no avail:

    define( ‘JETPACK_SIGNATURE__HTTPS_PORT’, 80 );

    $_SERVER[‘SERVER_PORT’] = 443;

    Can you help please? I can see lots of people with publicize and other connection issues which I am sure are connected to https and Jetpack. If this cannot be resolved I would imagine many wordpress sites will not be able to use Jetpack which is a great shame given all the great work that has gone into it.

    Please help me and all the many like me. Your help will be greatly apreciated.

    Regards

    Nic

    • This topic was modified 1 year, 11 months ago by  dambuster2385.
Viewing 5 replies - 1 through 5 (of 5 total)
  • I have used Qualys SSL Labs to prepare a SSL report which doesn’t appear problematic from my amateurish knowledge

    i recently made a switch to use cloudflare’s ssl amd followed these instructions.
    Use Jetpack and CloudFlare on your WordPress site

    though im not sure if we have the same case but often than not a lot of tutorials in the web regarding ssl configuration for wordpress(for the most cases) in reference to the use of jetpack miss out Steps 5-7
    5. Enable Administration over SSL by adding the following to wp-config.php
    6. Set the port to 443 by adding the following to wp-config.php:
    7. Under Settings > General in your dashboard, change both your site address and WordPress address to use HTTPS
    you have dont steps 5 and 6 try doing step 7

    regarding to your analytics or any third party solution that asks for your site’s url… you now need to specify your new site protocol instead of http its now https.

    hope it helps

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    @faospark are indeed a good step to get started. If that doesn’t help, could you post your site URL here so I can have a look?

    If you want it to remain private, you can also contact us via this contact form:
    http://jetpack.com/contact-support/

    Thanks!

    im already good @jeherve
    I think it is @dambuster2385 that still needs help

    I’m now sorted. For some reason my hosting company started blocking Jetpack by default but there is a way to enable it by editing the .htaccess file. The hosting company made the edit and I;m back in business.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Jetpack connection lost on my https site’ is closed to new replies.