Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » Jetpack connection error

  • Resolved rcharbonxx

    (@rcharbonxx)


    I found the issue when I was putting up a new post. When I tried to publish I got an alert saying I needed to reconnect to LinkedIn, and when I clicked on the alert to try to reconnect, all I got was a blank screen. So I went to WordPress.com and saw “The site cannot be accessed”. Then I went to site health and saw that the Wpcom connection test failed with the message “X Error Gems of Wisdom Consulting Inc. | Dr. Sharon T. Freeman is not connected.: 200”

    I’ve disconnected and reconnected Jetpack and that seemingly went well, but the error persists and WordPress.com still says the site cannot be accessed.

    When I run Jetpack Debug, I get: “XML-RPC is not responding correctly ( 409 )”. However, when I go to https://www.gemsofwisdomconsulting.com/web/xmlrpc.php I get the expected response.

    I have run thorough all the troubleshooting steps (update all, disable plugins, use default theme, etc…) to no avail.

    Most of Jetpack (stats, etc…) seems functional, but the connection error is disconcerting, and Linking to LinkedIn still fails.

    Site into as per support page request:

    
    ### wp-core ###
    
    version: 5.7
    site_language: en_US
    user_language: en_US
    timezone: America/New_York
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: closed
    environment_type: production
    user_count: 5
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /hermes/bosnacweb01/bosnacweb01bd/b1593/apo.drosenthal/web
    wordpress_size: 48.54 MB (50893636 bytes)
    uploads_path: /hermes/bosnacweb01/bosnacweb01bd/b1593/apo.drosenthal/web/wp-content/uploads
    uploads_size: 82.87 MB (86892322 bytes)
    themes_path: /hermes/bosnacweb01/bosnacweb01bd/b1593/apo.drosenthal/web/wp-content/themes
    themes_size: 81.07 MB (85005642 bytes)
    plugins_path: /hermes/bosnacweb01/bosnacweb01bd/b1593/apo.drosenthal/web/wp-content/plugins
    plugins_size: 51.11 MB (53591749 bytes)
    database_size: 28.55 MB (29933568 bytes)
    total_size: 292.13 MB (306316917 bytes)
    
    ### wp-dropins (1) ###
    
    advanced-cache.php: true
    
    ### wp-active-theme ###
    
    name: Enfold Child (enfold-child)
    version: 1.0
    author: Kriesi
    author_website: http://www.kriesi.at
    parent_theme: Enfold (enfold)
    theme_features: core-block-patterns, avia_exclude_bbPress, deactivate_tribe_events_calendar, avia_exclude_GFForms, avia_exclude_menu_exchange, avia_exclude_relevanssi, avia_exclude_WooCommerce, avia_exclude_wpSEO, avia_exclude_wpml, avia_exclude_instagram_feed, avia_mega_menu, avia_improved_backend_style, avia_option_pages_toggles, avia_sidebar_manager, automatic-feed-links, nav_menus, menus, widgets, post-formats, avia-disable-default-shortcodes, avia_post_meta_compat, force-post-thumbnails-in-widget, post-thumbnails, title-tag, editor-styles, editor-style, customize-selective-refresh-widgets, responsive-embeds, editor-color-palette, editor-font-sizes, avia_no_session_support
    theme_path: /hermes/bosnacweb01/bosnacweb01bd/b1593/apo.drosenthal/web/wp-content/themes/enfold-child
    auto_update: Disabled
    
    ### wp-parent-theme ###
    
    name: Enfold (enfold)
    version: 4.8.1
    author: Kriesi
    author_website: https://kriesi.at
    theme_path: /hermes/bosnacweb01/bosnacweb01bd/b1593/apo.drosenthal/web/wp-content/themes/enfold
    auto_update: Disabled
    
    ### wp-themes-inactive (1) ###
    
    Twenty Twenty-One: version: 1.2, author: the WordPress team, Auto-updates disabled
    
    ### wp-plugins-active (9) ###
    
    Akismet Anti-Spam: version: 4.1.9, author: Automattic, Auto-updates disabled
    Contact Form 7: version: 5.4, author: Takayuki Miyoshi, Auto-updates disabled
    Jetpack by WordPress.com: version: 9.5, author: Automattic, Auto-updates disabled
    Post Types Order: version: 1.9.5.5, author: Nsp Code, Auto-updates disabled
    Really Simple SSL: version: 4.0.13, author: Really Simple Plugins, Auto-updates disabled
    Regenerate Thumbnails: version: 3.1.5, author: Alex Mills (Viper007Bond), Auto-updates disabled
    UpdraftPlus - Backup/Restore: version: 1.16.50, author: UpdraftPlus.Com, DavidAnderson, Auto-updates disabled
    WP Super Cache: version: 1.7.2, author: Automattic, Auto-updates disabled
    Yoast Duplicate Post: version: 4.1.2, author: Enrico Battocchi & Team Yoast, Auto-updates disabled
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Not available
    imagemagick_version: Not available
    file_uploads: File uploads is turned off
    post_max_size: 20M
    upload_max_filesize: 20M
    max_effective_size: 20 MB
    max_file_uploads: 20
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: 9.26
    
    ### wp-server ###
    
    server_architecture: Linux 5.4.25 x86_64
    httpd_software: Apache/2
    php_version: 7.3.2 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 120
    memory_limit: 256M
    max_input_time: 60
    upload_max_filesize: 20M
    php_post_max_size: 20M
    curl_version: 7.47.0 OpenSSL/1.0.2g
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.6.49-89.0-log
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: 7cc7cc96e675f6d72e5cf0f267f48e167c2abb23 $
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /hermes/bosnacweb01/bosnacweb01bd/b1593/apo.drosenthal/web/wp-content
    WP_PLUGIN_DIR: /hermes/bosnacweb01/bosnacweb01bd/b1593/apo.drosenthal/web/wp-content/plugins
    WP_MEMORY_LIMIT: 256M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: true
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    ### jetpack ###
    
    site_id: 151077978
    ssl_cert: No
    time_diff: undefined
    version_option: 9.5:1616697262
    old_version: 9.4:1612541932
    public: Public
    master_user: #3 rcharbon
    current_user: #3 rcharbon
    tokens_set: Blog User
    blog_token: vLikr5naU$VYCjJktuyCNv8mx&SB&OBx
    user_token: hE6lwgcw5ZzZPfV%tNjSAo1Had8IG&43
    version: 9.5
    jp_plugin_dir: /hermes/bosnacweb01/bosnacweb01bd/b1593/apo.drosenthal/web/wp-content/plugins/jetpack/
    plan: free
    protect_header: {"trusted_header":"REMOTE_ADDR","segments":1,"reverse":false}
    full_sync: {"started":"Sat, 27 Mar 2021 13:52:24 +0000","finished":"Sat, 27 Mar 2021 13:52:39 +0000","progress":{"options":{"finished":true},"functions":{"finished":true},"constants":{"finished":true},"users":{"total":"1","sent":1,"finished":true,"last_sent":"3"},"network_options":{"finished":true}},"config":{"options":true,"functions":true,"constants":true,"users":[3],"network_options":true}}
    sync_size: undefined
    sync_lag: 0 seconds
    full_sync_size: undefined
    full_sync_lag: 0 seconds
    idc_urls: {"home":"https:\/\/www.gemsofwisdomconsulting.com","siteurl":"https:\/\/www.gemsofwisdomconsulting.com\/web","WP_HOME":"","WP_SITEURL":""}
    idc_error_option: false
    idc_optin: true
    cxn_tests: {"9":{"name":"test__wpcom_connection_test","label":false,"short_description":"Gems of Wisdom Consulting Inc. | Dr. Sharon T. Freeman is not connected.: 200","long_description":"<p>A healthy connection ensures Jetpack essential services are provided to your WordPress site, such as Stats and Site Security.<\/p><p><span class=\"dashicons fail\"><span class=\"screen-reader-text\">Error<\/span><\/span> Gems of Wisdom Consulting Inc. | Dr. Sharon T. Freeman is not connected.: 200<\/p><p><strong>We recommend reconnecting Jetpack.<\/strong><\/p>","severity":"critical","action":"https:\/\/www.gemsofwisdomconsulting.com\/web\/wp-admin\/admin.php?page=jetpack#\/reconnect","action_label":"Reconnect Jetpack now","show_in_site_health":true,"pass":false,"group":["default"],"type":"direct"}}
    
    

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 27 total)
  • Eu estava desolada.
    Descobri que se desativasse o XML-RCP, poderia dar certo sem perder grandes funções.
    Dá pra fazer manualmente ou usar um plugin que só desabilita o XML-RCP, mais não impende seu funcionamento.
    Com esse plugin o problema foi resolvido.

    Plugin Support Karen Attfield

    (@wpkaren)

    Hi @rcharbonxx

    Apologies for the delay in responding here, we are dealing with a backlog of requests at the moment.

    The issue does actually appear to be Jetpack’s connection to the xmlrpc file on your site.

    While the correct response is visible here as you noticed – https://www.gemsofwisdomconsulting.com/web/xmlrpc.php – Jetpack can’t access it:

    https://www.gemsofwisdomconsulting.com/web/xmlrpc.php?for=jetpack

    If you are using any security plugins, please try connecting with those temporarily deactivated. If you don’t have any, or if that didn’t work, I would suggest contacting your hosting provider and asking them to unblock your site’s xmlrpc as they may have some security measures in place preventing specific levels of access.

    It may also be easier for them to whitelist the Jetpack IP address range as described here:

    https://jetpack.com/support/hosting-faq/#jetpack-whitelist

    Do let us know if you still notice a Jetpack connection issue or see any alerts / error messages after this and we’ll be happy to troubleshoot further as needed.

    Thread Starter rcharbonxx

    (@rcharbonxx)

    @wpkaren:
    What response should I get when I click on the amended link?

    Shouldn’t the Troubleshooting FAQ be amended with the new info?

    Thanks,
    Ray

    Plugin Contributor Stef

    (@erania-pinnera)

    Hi there @rcharbonxx,

    Thanks a lot for the follow-up and apologies again for the delay – the backlog Karen mentioned is still here, so we answer in the order received.

    I did some additional tests and I’m afraid to report that also your site is experiencing the problem mentioned in this thread.

    In fact, while your site is publicly accessible, we cannot access your site’s XML-RPC file for Jetpack:

    https://www.gemsofwisdomconsulting.com/web/xmlrpc.php

    The 406 Not acceptable error indicates that something is still off with your servers and the way they connect with Jetpack.

    We’re aware of a recent conflict we’ve been seeing between mod_security and Jetpack on sites that are hosted with EIG hosts. We are working directly with the hosts to get to the bottom of the problem/ We hope to circle back soon to let you know when that issue has been resolved so we can determine if that is enough to get everything back up and working or if we’ll need to take other steps as well.

    I’d recommend reporting this to your host to report that your site is experiencing this issue.

    Sorry I can’t be more helpful at this stage on this.`

    Plugin Contributor Stef

    (@erania-pinnera)

    Hey @vanessacv,

    Could you please start your own thread, as per the Forum Welcome?
    https://wordpress.org/support/plugin/jetpack#new-post
     
    Thank you!

    Thread Starter rcharbonxx

    (@rcharbonxx)

    @erania-pinnera
    I asked a simple question (What response should I get when I click on the amended link?). An answer, other than the boilerplate copied to everyone in this situation, would be appreciated.

    Plugin Contributor Stef

    (@erania-pinnera)

    @rcharbonxx,

    If you mean how the xmlrpc page should look like, here’s an example:

    https://jetpack.com/xmlrpc.php

    Hope that helps!

    Thread Starter rcharbonxx

    (@rcharbonxx)

    @erania-pinnera
    No, I meant what should I see with the “?for=jetpack” appended?

    Please tell me what I

      should

    see, don’t just provide a link.

    Thread Starter rcharbonxx

    (@rcharbonxx)

    When I tried to upgrade to PHP 7.4 from 7.32, I got a critical error every time I tried to go to the Site Health page. Debug told me it was a problem with Jetpack, so I deleted it and the PHP upgrade was successful.

    I reinstalled Jetpack, and now I can’t activate it at all. When I click on “Set up Jetpack”, I get “The Jetpack server was unable to communicate with your site https://www.gemsofwisdomconsulting.com/web [HTTP 409].”

    https://www.gemsofwisdomconsulting.com/web/xmlrpc.php?for=jetpack returns a 406:
    “Not Acceptable
    An appropriate representation of the requested resource /web/xmlrpc.php could not be found on this server.”

    So yes, please let me know when you’ve resolved the issue.

    Plugin Contributor Dan

    (@drawmyface)

    Hi @rcharbonxx

    You should see the same message for both /xmlrpc.php and /xmlrpc.php?for=jetpack

    The 409 error you’re seeing now actually sounds like a known issue we’re experiencing with sites hosted with iPage. Is your site hosted with iPage by any chance?

    If so, we’re currently working with them to resolve the issue and we’ll let you know as soon as we have a resolution.

    Thread Starter rcharbonxx

    (@rcharbonxx)

    @drawmyface
    No, the site is not hosted by iPage.

    Plugin Contributor Dan

    (@drawmyface)

    Ok, thanks for confirming. In that case, I’d suggest contacting your hosting provider and letting them know about the 409 error on https://www.gemsofwisdomconsulting.com/web/xmlrpc.php?for=jetpack

    They should be able to adjust their security rules to ensure that our requests don’t get blocked.

    Thread Starter rcharbonxx

    (@rcharbonxx)

    @drawmyface @erania-pinnera @wpkaren
    Well, I’m certainly getting the level of support I’m paying for. It would be nice if Jetpack had one person provide a consistent contact and follow through on a support issue. And it’s always good practice to read carefully and provide accurate replies.

    The successful “?for=jetpack” link apparently returns some XML, as seen here:
    https://jetpack.com/xmlrpc.php?for=jetpack
    Can someone who knows what they’re talking about confirm this?

    And as I noted, I get a 406 when clicking on https://www.gemsofwisdomconsulting.com/web/xmlrpc.php?for=jetpack
    The 409 appears when I try to activate the reinstalled Jetpack.

    Plugin Contributor Dan

    (@drawmyface)

    The successful “?for=jetpack” link apparently returns some XML, as seen here:
    https://jetpack.com/xmlrpc.php?for=jetpack
    Can someone who knows what they’re talking about confirm this?

    No, this was actually a bad example, as jetpack.com is not actually a Jetpack site, it’s a WordPress.com site, so that’s the expected response there.

    For a Jetpack site like yours, /xmlrpc.php?for=jetpack should show the same as /xmlrpc.php – i.e: XML-RPC server accepts POST requests only.

    And as I noted, I get a 406 when clicking on https://www.gemsofwisdomconsulting.com/web/xmlrpc.php?for=jetpack
    The 409 appears when I try to activate the reinstalled Jetpack.

    Apologies for confusing those two error codes. However, they are very likely due to the same underlying issue, and the advice remains to pass the error on to your hosting provider so that they can ensure our requests to xmlrpc.php do not get blocked.

    Thread Starter rcharbonxx

    (@rcharbonxx)

    Host contacted, waiting for a resolution….

Viewing 15 replies - 1 through 15 (of 27 total)
  • You must be logged in to reply to this topic.