Jetpack by WordPress.com
[resolved] Jetpack Connected by Not Posting to Facebook (6 posts)

  1. jathompson06
    Posted 2 years ago #

    I recently lost the ability to publish new blog posts to Facebook. I had no issues until the update and have already walked through the steps of disconnect and reconnecting the plug-in but to no avail.

    Unable to find additional info in forums or support on how to otherwise fix the issue. All other networks, including Twitter, are publishing as normal, but not Facebook.

    Anyone able to help?


  2. Jeremy Herve
    Jetpack Mechanic
    Plugin Author

    Posted 2 years ago #

    Could you post your site URL here, so I can have a look?

    If you want it to remain private, you can also contact us via this contact form:

  3. wjackman
    Posted 2 years ago #

    I have had the same problem with posting to Facebook, and the same lack of improvement after disconnect/reconnect. I also tried deactivating/reactivating Jetpack. The problem began as soon as I updated to WordPress 3.8.

    I have also noticed that the "Publicize" widget is also not placing sharing buttons on my blog either, though I've tried to get that to work also.

    My blog site is http://www.limulussystems.com/blog/ if that helps solve the problem.

  4. WPyogi
    Forum Moderator
    Posted 2 years ago #

    @wjackman - you need to start your own thread on this forum - they don't help more than one person in the same thread as it's too confusing.

    Start a new one here:


  5. jathompson06
    Posted 2 years ago #

    @Jeremy - here's the link


  6. Jeremy Herve
    Jetpack Mechanic
    Plugin Author

    Posted 2 years ago #

    I had a look at your site, and you seem to be using 2 different plugins (or a plugin and a function in your theme) to add Open Graph meta tags to your site.

    Unfortunately, duplicate Open Graph tags create errors on Facebook's end, and cause Publicized posts to be rejected:

    Could you try to deactivate one of the Open Graph plugins, until errors disappear from Facebook's Debugger? Once you've done so Publicize should start working again.

    I hope this helps.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Jetpack by WordPress.com
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic