Support » Plugin: Jetpack by WordPress.com » JetPack connected but it is not!

  • Resolved acekin

    (@acekin)



    This site has been connected to JetPack for a long time. Recently, when I logged in to WordPress.com a brown banner on the site reported that The site cannot be accessed and asked if I wanted to disconnect. That said, I could see the site stats on the site and wordpress.com, I could even sporadically manage the plugins like activating even adding one. But within seconds I get the same “The site cannot be connected” banner on the site title on the left. Since then:
    1. On the site, I have disabled all the plugins and the behavior did not change
    2. It was using an older StudioPress theme, I changed it with a recent one
    3. I disconnected from WordPress.com with some difficulty, kept getting Json errors, ended up deleting the plugin folder via FTP and reinstalling it from the dashboard
    4. As of now, I can still see the site stats and the site seems to be connected on the dashboard but on WordPress.com it gives the mixed message of showing stats but saying cannot reach the site

    This is an archive site as I am retired. I am troubleshooting it for future benefit and learning and will appreciate your help.

    Thanks,

    Cemal

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 18 total)
  • Wes Candela

    (@voicesfilmcom)

    Same issue here
    Self hosted WordPress site
    http://voicesfilm.com

    I have jetpack installed

    IT will not connect with WordPress.com with out giving me errors
    Jetpack has issues communicating with WordPress.com it reports
    And WordPress.com will not load my posts, media, pages, anything anymore.

    Is there anyway to figure out and fix issue ?

    lamday

    (@lamdayap)

    HI @acekin – It does look like the connection isn’t working: https://jetpack.com/support/debug/?url=https%3A%2F%2Fwww.cemalekin.com%2Fsyllabus%2F

    I would like to grab more info from your about your site by using our debug, however the some of the information is sensitive. Would you mind following the below and then sending us the contents of the debug to our email:

    1. Go to the Jetpack page in your dashboard.
    2. Click on the Debug link appearing at the bottom of the page.
    3. Click the link that says “click here to contact Jetpack support.”
    4. Fill in the description box and your name and email address.
    5. Click the “Contact Support” button to send us the debug results privately.

    Thanks!

    lamday

    (@lamdayap)

    Hi @voicesfilmcom – Your issue appears to be different to the the OPs, can you please try to first reinstall the Jetpack plugin? This will clear out some old Jetpack options which may be stopping your site from connecting.

    If you’re still running into issues could you please start your own thread, as per the Forum Welcome?
    https://wordpress.org/support/plugin/jetpack#new-post

    Thank you!

    acekin

    (@acekin)

    @lamdayap, I did what you asked for the following day and added a link to this thread as well.

    Cemal

    acekin

    (@acekin)

    I was on the site and JetPack seems to be functioning fine! I am not sure if you had to do anything on the back end or it needed to “age” for a few days! I can activate and deactivate various JP modules on the site and can manage the plugins on WordPress.com.

    I would like to know for my future reference what made it work again.

    NOPE! I am adding this note within the edit time window and the link seems to be broken again, it works but it does not! Like before!

    Thanks,

    Cemal

    • This reply was modified 12 months ago by  acekin.
    Plugin Contributor Richard Archambault

    (@richardmtl)

    Hi Cemal! Did you get a reply to the ticket you sent in? Maybe one of my colleagues did something for your site and has yet to reply to you?

    acekin

    (@acekin)

    No, nobody replied and the site still does not work as I added to the end of the above post. The problem continues and I have not heard from team JetPack!

    Cemal

    Plugin Contributor Richard Archambault

    (@richardmtl)

    Oh I missed that last part, sorry!

    I looked in our ticketing system, and I’m not finding anything from you, unfortunately. 🙁

    Can you try following Lamda’s instructions again? Let me know when you’ve done so and I’ll look again, and if I still can’t find anything, we’ll try something else.

    acekin

    (@acekin)

    Done it again! After I click to submit I end up seeing :

    https://jetpack.com/contact-support/

    page. I suppose that is what’s expected. Please let me know if you received it or not. If necessary, I can copy the advanced debug screen and send it to an email address.

    Cemal

    Plugin Contributor Richard Archambault

    (@richardmtl)

    I’m still not seeing it in our system. 🙁 Can you send it to support@jetpack.com please, and let me know when you’ve done that?

    acekin

    (@acekin)

    Have just sent it.

    Cemal

    Plugin Contributor Richard Archambault

    (@richardmtl)

    I got it, thanks! At least it made it through! 🙂 We’ll get to it shortly.

    Although we have exchanged quite a few emails on private channels, I thought I would ask this question on the forum:

    Should a site respond to an xmlrpc.php request at the site root or WordPress install folder, or both?

    Could this have anything to do with some of my sites connecting and others not? I really would like to get to the bottom of this problem, very close to throwing the towel!

    Cemal

    • This reply was modified 11 months, 3 weeks ago by  acekin.
    • This reply was modified 11 months, 3 weeks ago by  acekin. Reason: typo
    Plugin Contributor Richard Archambault

    (@richardmtl)

    Hi Cemal,

    Should a site respond to an xmlrpc.php request at the site root or WordPress install folder, or both?

    The xmlrpc.php will always be in the installation folder, and that’s where we’ll look for it if your site is reporting the site_url value correctly. I haven’t followed the email discussion, though. If you’d like my input on it, can you tell me the ticket number, please?

    In the e-mail correspondence we have had the subject line has been:

    [Jetpack] /support/topic/jetpack-connected-but-it-is-not/

    No ticket number per se.

    There is one possibly related issue that Jeremy noted to be fixed, the “View site” on WordPress.com dashboard tries to get to the install folder rather than the site_url. That was one of the reasons I brought this question up.

    Thank you,

    Cemal

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘JetPack connected but it is not!’ is closed to new replies.