Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » Jetpack conflict with QTranslateX plugin

  • Resolved miquelpontes

    (@miquelpontesgmailcom)


    Hi, I’m running a wildlife observations website called OPK (http://opistobranquis.info/) that has full contents translated into 3 languages (Catalan, Spanish and English) by using the QTranslateX plugin.

    QTranslateX plugin is configured to use “Prepath” mode, that is, it puts /en/ in front of URL for the English pages, puts /es/ in front of the URL for the Spanish pages and so on, so anyone can access our homepage in English here (http://opistobranquis.info/en/) or the Spanish one here (http://opistobranquis.info/es/), but in fact we only have one homepage, with the 3 languages “inside”.

    Since the last update of Jetpack we’re spuriously receiving the following message in the Admin mode:

    Jetpack Safe Mode
    
    Jetpack has been placed into Safe mode because we noticed this is an exact copy of opistobranquis.info/es.
    
    Please confirm Safe Mode or fix the Jetpack connection. Select one of the options below or learn more about Safe Mode.
    
    Is this website a temporary duplicate of opistobranquis.info/es for the purposes of testing, staging or development? If so, we recommend keeping it in Safe Mode.
    Confirm Safe Mode
    
    If this is a separate and new website, or the new home of opistobranquis.info/es, we recommend turning Safe Mode off, and re-establishing your connection to WordPress.com.
    Fix Jetpack's Connection

    Our situation is none of the above. Website behaviour is just normal (possibly thanks to Jetpack Safe Mode) but I suspect functionality is somewhat limited, and I expect problems in the future if not solved.

    Is there a way to solve the problem? Thanks for your time !

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    I’m afraid that’s a known issue. We’re working on a fix and hope to include it in the next major Jetpack release. You can monitor our progress here:
    https://github.com/Automattic/jetpack/pull/5852

    Until this is fixed, I would recommend that you disable that notice with one of the following options:

    • Either add define( 'JETPACK_SYNC_IDC_OPTIN' , false ); in your site’s wp-config.php file.
    • Either add add_filter( 'jetpack_sync_idc_optin', '__return_false' ); in a functionality plugin like this one.

    Sorry for the trouble!

    Thread Starter miquelpontes

    (@miquelpontesgmailcom)

    Thank you very much Jeremy, I used the first option to avoid the notice displaying and it seems to work just fine.

    I’ll keep an eye on this. Thank you for your incredible work.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Jetpack conflict with QTranslateX plugin’ is closed to new replies.