WordPress.org

Forums

Decode
[resolved] Jetpack Comments with Decode crashes browser on iOS devices (17 posts)

  1. isaacrthorne
    Member
    Posted 1 year ago #

    Hello Scott.

    First, my apologies if this issue has been reported before. I could not find it in the existing support requests.

    I have both the Decode theme and the Jetpack plugin operating on http://www.isaacthorne.com. When I enable Jetpack Comments, the entire site functions as it should on a desktop browser. On an iOS device (regardless of whether I use Safari or Chrome for iOS), posts that have the Jetpack Comments form on them crash the browser. To see the problem, view the following page in Safari or Chrome on an iOS 7 device:
    http://www.isaacthorne.com/dislike

    I know that there are other responsive themes have had this issue:
    http://support.themeblvd.com/forums/topic/swagger-site-crashing-in-ios7-browsers/

    I can work around the issue by using Jetpack's built-in theme for mobile devices. However, I love the Decode theme and would like to continue using it for all devices.

    Thank you for any advice.

    James

  2. Scott Smith
    Member
    Theme Author

    Posted 1 year ago #

    I don't know what is causing this issue. Jetpack seems to be positively riddled with bugs like this. I'll investigate but I don't have an ETA on a fix or diagnosis.

  3. Sam Steiner
    Member
    Posted 1 year ago #

    I had this problem with the theme Akita from Themeblvd. Had to deactivate Jetpack. The problem didn't occur every single time (and I couldn't replicate the problem on Android Chrome).

  4. Scott Smith
    Member
    Theme Author

    Posted 1 year ago #

    I'm not sure if there is anything I can do at the moment. I really think this is a Jetpack issue because Decode does everything the proper WordPress way. If there is anything I can do to improve it, I will, but I'm marking this as resolved for now.

  5. isaacrthorne
    Member
    Posted 1 year ago #

    Thank you for trying. I noticed that someone has posted about a similar problem over on the Jetpack plugin's reviews page. I added to the discussion there. Hopefully the Jetpack developers will be able to solve it. Here is a link to that thread if you'd like to follow it:

    http://wordpress.org/support/topic/crashes-ios-browsers?replies=3#post-5571800

  6. Hi! Thanks for the info. It does appear to be some sort of conflict between Jetpack and Decode, but I don't know what. I will likely open a Github issue for it; I'll let you know when I've done that, so we can try to track down what the cause is.

  7. Here's the link to the bug report on Github:

    https://github.com/Automattic/jetpack/issues/540

  8. Scott Smith
    Member
    Theme Author

    Posted 1 year ago #

    I subscribed to the report. Thanks for posting it!

  9. isaacrthorne
    Member
    Posted 1 year ago #

    I have made some progress on this issue. In Jetpack's comments.php file, I commented out the following markup before the comments iframe:

    <div id="commentform" class="comment-form">

    I also commented out the following markup just after the iframe:

    </div>

    The page loaded fine in Chrome on iOS 7 and Safari on iOS 7 after making this change. To further test, I uncommented the above two lines of markup. The crash reappeared.

    Next, I modified the Decode theme's /style.css file. I changed all instances of the .comment-form class to .comment-florm, excluding any .comment-form-xxxx classes, which I left as-is. After refreshing caches, the page again worked with Jetpack comments enabled and the Decode theme in Chrome and Safari on iOS 7.

    I suspect that there is some sort of CSS conflict between Jetpack and the comment-form class that the Decode theme's stylesheet is using. I note that there are several uses of -webkit in the Decode comment-form classes. Perhaps one of those is the issue.

    At some point, I will comment out the -webkits one-by-one and see if I can, by process of elimination, determine where the problem lies.

    I have cross-posted this on the Jetpack support issue in case it helps the developers or other users of both Decode and Jetpack.

  10. isaacrthorne
    Member
    Posted 1 year ago #

    I have located the CSS properties that are causing this issue. In the Decode theme's style.css file, the comment-form class contains the following two properties at the beginning of the class:

    display:-webkit-box;
    display:-webkit-flex;

    Commenting out these two properties from the comment-form class fixes the problem. If either of these properties are present in the comment-form class AND Jetpack Comments are enabled, the crash occurs.

    This narrows down the problem considerably, although it still does not pinpoint the specific conflict between Decode and Jetpack Comments.

  11. Thanks for firguing that out, Isaac! To me this makes it sound like a Webkit bug (Webkit is the rendering engine behind Safari and Chrome). I was unable to find a specific related bug report, but I suspect that there's nothing that we'll be able to do.

  12. CaroleB
    Member
    Posted 8 months ago #

    I know this is an old thread, but I'm hoping you'll still read it, Scott. I've just built a site using Decode theme (which I love!), but can NOT get a comment box to display on posts. I've deactivated Jetpack comments, but that didn't help. This is the 1st site I've built & I know very little coding so if your instructions are going to include some coding, please be very specific about where to include it.

    Thanks!
    Carole
    Site is http://www.thecaroleshow.com

  13. Scott Smith
    Member
    Theme Author

    Posted 8 months ago #

    I think this is a separate issue not related to the previous ones, but have you made sure the Show comments option in Discussion Options in the customize menu is checked?

  14. CaroleB
    Member
    Posted 8 months ago #

    Hi Scott,
    Thanks for your quick response. I feel kinda dumb right now. Yes, I'd checked the Show/allow comments in the customize menu & the Discussion page. I wasn't seeing an Allow commenting check box option on the individual post pages and couldn't figure out what was going on (or why that option wasn't available on the post pages). I just clicked on Quick Edit on the post page and realized that the Allow Comments & pings check boxes are housed there. I guess I'll have to do that for every post or is there be a way to display checkbox in the post page itself?

    Thanks again,
    Carole

  15. Scott Smith
    Member
    Theme Author

    Posted 8 months ago #

    I think this help link can help you with this better than I can here. http://en.support.wordpress.com/enable-disable-comments/

  16. CaroleB
    Member
    Posted 8 months ago #

    Bingo! Thanks Scott! You rock...and so does Decode!! :)

    Appreciate your help!

  17. Scott Smith
    Member
    Theme Author

    Posted 8 months ago #

    No problem! have a great day!

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic