WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Jetpack Comments 404

[Resolved] Jetpack Comments 404

  • Hi BPS,

    When running Jetpack comments, the BPS htaccess file results in comment submitters getting a 404 error rather than comment submission.

    Going back to the default htaccess file fixes the issue, but, of course, also makes BPS significantly less effective.

    I tried commenting out some of the specific comment-related lines of the BPS root htacess file, but the 404s persisted until I completed disabled the root protection.

    Any ideas on how to fix this without throwing the baby out with the bathwater?

    http://wordpress.org/extend/plugins/bulletproof-security/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author AITpro

    @aitpro

    Is Jetpack Comments a feature in the Jetpack by WordPress.com plugin or is it a separate plugin? Thanks.

    Plugin Author AITpro

    @aitpro

    Ok i figured out that Jetpack Comments is a feature of Jetpack. I installed Jetpack and yep i see an error. Will figure out the cause and solution shortly.

    Plugin Author AITpro

    @aitpro

    I first just happened to test Jetpack Comments on a GWIOD site – Giving WordPress Its Own Directory – site that has the WordPress 2011 Theme installed and that is where i was seeing an error. When i put the GWIOD test site in Default Mode Jetpack Comments no longer was displaying an error, but something really strange was happening since it was a GWIOD site so i then decided to test Jetpack Comments on a standard WordPress site and no error occurred at all with all BulletProof Modes activated???

    I am not sure why the errors occurred on the GWIOD and this may be some other odd different problem, but no errors are occurring at all on a standard WordPress site and Jetpack Comments is working fine.

    So backtracking a bit here. 404 errors typically indicate you have a permalink problem of some sort.
    Have you activated Both BulletProof Modes? Root and wp-admin BulletProof Modes?
    Are you doing anything unusual with your Custom Permalink Structure?
    What is your Custom Permalink Structure?

    Thanks for the quick reply and sorry I wasn’t clearer.

    I found this issue on a production site, so I haven’t been able to narrow it down beyond what I posted originally. But, to provide more information:

    • I’m also using the Subscriptions module in Jetpack which adds some functionality to the contact form.
    • The site is not GWIOD, but there are other sites in directories in the same domain (none of which are running BPS).
    • Permalinks are just %postname%. There’s a custom post type that uses the core rewrites for CPTs (just added in the args of register_post_type(), but that’s it.
    • Both BPS modes were activated prior to running into this problem.

    I’ll try to isolate the issue further today if I can, but I hope this information is useful.

    Plugin Author AITpro

    @aitpro

    Yep if you could provide URL links with BPS in Default Mode when everything is working correctly and then the 404 URL and error message that would be very helpful. Thanks.

    Interesting. I just reactivated the Bulletproof mode and now commenting works. No other changes beyond having to redeploy the W3TC htaccess. I wonder if it was somehow related to W3TC.

    The site is mrwweb.com and you can even see a list of the plugins I use (http://mrwweb.com/useful-wordpress-plugins/).

    I’ll try and see if I can set-off the issue again, and report back if I do, but for now it seems resolved…weird.

    Plugin Author AITpro

    @aitpro

    Yep ok then you are seeing what I see too that BPS does not block Jetpack Comments in general, but yeah it is a bit wierd and you may have just nailed the issue. It is actually very likely that this is some kind of cache issue.

    That is what appears to be going on with the problem on the GWIOD site since a GWIOD site actually has 3 .htaccess files – a website root folder .htaccess and also a subfolder .htaccess file and the wp-admin .htaccess file. When i created a standard Default .htaccess file in the GWIOD root of the site and a secure .htaccess file in the subfolder (actual subfolder where WordPress is installed) then Jetpack Comments worked fine without any errors. That testing site is also using W3TC.

    Plugin Author AITpro

    @aitpro

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] Jetpack Comments 404’ is closed to new replies.