Support » Plugins and Hacks » [Resolved] Jetpack Commenting Stopped Working?

[Resolved] Jetpack Commenting Stopped Working?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Jeremy Herve


    Jetpack Mechanic

    I see you have now deactivated Jetpack on your site.

    Do you have any other active Comment or Anti Spam plugins on your site? Some plugins are indeed known to cause conflicts with Jetpack Comments:

    This is a problem all over at the moment.
    When I’m logged in to wordpress.com with my jetpack I used to be able to comment directly. But now there are many blogs, both at wordpress.com and stand alone wordpress.org blogs that don’t recognized me.
    This started after the last update for Jetpack.

    And for the blogs I run there are no other active comment or antispam other than askimet.

    Plugin Author Jeremy Herve


    Jetpack Mechanic

    If you experience similar issues on WordPress.com sites and on different Jetpack sites, the problem might not be linked to Jetpack.

    Could you please try clearing out your cache and cookies, and see if this helps?

    Could you also let me know what happens when you try to leave a comment? Do you receive an error message?

    We are many different users that experience this problem. Different browsers, and a lot of different pages
    Both at wordpress.com and wordpress.org blogs.
    Clearing cache and cookies was my first try, and then different browsers, but that doesn’t solved this.

    Mostly the comment just disapper from the screen, no “your comment awaiting moderation” alert, it just disapper, but the blog-owner can retrive the comment from the spam-filter.

    Maybe you can see the problem from my blog-page
    the page is in norwegian
    But that can’t do anything, this happens on danish and german sites too

    Plugin Author Jeremy Herve


    Jetpack Mechanic

    the blog-owner can retrive the comment from the spam-filter.

    Thanks for that extra detail. If your comment appears in the Spam filter, it means it was successfully posted.

    If all your comments are considered as Spam, by mistake I would recommend that you contact Akismet about it:

    Okey, I’ll try to do that
    Thank you so far, and if I find a solution I will post it here to 😉

    I actually just had someone inform me this morning that they posted a comment to a post of mine overnight and it didn’t appear. According to them, they’d signed in with their WordPress account, typed a comment, hit post, and… nothing. It’s definitely not posted, not in moderation, and not in spam.


    Oh, and now I can tell you why, sort of. Upon hitting post, the Jetpack comments iframe refreshes to… a page that’s a 404 error.

    Once again, it’s because a plugin for some reason is not correctly calling *WordPress URL* and is calling *Site URL* instead.

    Hence it goes to


    which doesn’t work, because it should be wordpress/wp-comments-post.php?for=jetpack

    ETA that if I disable Jetpack comments, native WordPress commenting functions fine. So, it’s something about Jetpack comments being active.

    Plugin Author Jeremy Herve


    Jetpack Mechanic

    @theonetruebix I tried to leave a comment on your blog a few minutes ago, and it worked. I have also tested leaving comments on a test blog of mine, using a different WordPress URL and Site URL, and it seems to work properly.

    Do you have any other comment plugins active on your site?

    Yeah, sorry, since I wasn’t sure it was the same issue, I started a new thread


    where we went through the issue.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Resolved] Jetpack Commenting Stopped Working?’ is closed to new replies.