Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » Jetpack comment section is broken

  • Resolved Senri Miura

    (@senribb)


    When I turn on comments in Jetpack’s discussion settings, the two checkboxes in the comment field (the following words) will not be displayed as shown in the attached image.

    https://www.senris.com/debug/Jetpack-Comment.jpg

    □ Notify me by email when new comments are added.
    □ Receive new posts by email

    Conflicts with the theme programs and plugins may be a factor, but it’s hard to figure out the cause.
    Or is it due to some server preferences (permission settings, etc.)?
    Previously, when I enabled the site accelerator in Jetpack’s performance settings, I had a problem that all the images were not displayed.
    On the other server I run (non-SSL), the site accelerator and Jetpack comments work fine in the same theme and similar plugin environment.

    For reference, the environment of this server is shown below.

    <Server>
    Server structure Linux 4.4.0-208-generic x86_64
    Web server Apache

    <PHP>
    PHP version 7.4.16 (supports 64-bit values)
    PHP SAPI cgi-fcgi

    <DB>
    Extension mysqli
    Server version 5.7.33-log
    Current version mysqlnd 7.4.16

    <Jetpack>
    Jetpack SSL Verfication Bypass No

    The theme program “comments.php” has the following description.

    <? php comment_form ();?>

    Currently, the plugins in use are as follows, but even if you disable the plugins individually, the comment section will be broken, so I feel that the plugin conflict is not the cause. ..

    Advanced Ads
    Advanced Editor Tools (formerly TinyMCE Advanced)
    Akismet Anti-Spam
    Auto Featured Image (Auto Post Thumbnail)
    Auto Limit Posts Reloaded
    BackWPup
    Broken Link Checker
    Classic Editor
    Code Syntax Block
    Compact Audio Player
    Contact Form 7
    Content Copy Protection & Prevent Image Save
    Contextual Related Posts
    Cool Tag Cloud
    Display Posts
    Easy FancyBox
    Google Website Translator
    Google XML Sitemaps
    Gwolle Guestbook
    Highlighting Code Block
    hpb dashboard
    hpb seo plugin for WordPress
    Jetpack
    Markup (JSON-LD) structured in schema.org
    MP3-jPlayer
    NewStatPress
    Optimize Database after Deleting Revisions
    PuSHPress
    Pz-Link Card
    Really Simple CAPTCHA
    reCaptcha by BestWebSoft
    Site Kit by Google
    Social Media and Share Icons (Ultimate Social Media)
    Styles For WP Pagenavi Addon
    Theme Authenticity Checker (TAC)
    To Top
    Transposh Translation Filter
    WordPress Popular Posts
    WP Multibyte Patch
    WP Sitemap Page
    WP-Optimize
    WP-PageNavi
    Business day calendar

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Thread Starter Senri Miura

    (@senribb)

    Apparently, the following Jetpack malfunctions have been reported by others on the core server (https://www.coreserver.jp/).
    By the way, when I set the share button of Jetpack, the comment field disappeared.

    <Bug 1>
    All images disappear when Jetpack site accelerator is enabled. (CDN is disabled)

    <Bug 2>
    When I enable comments on Jetpack’s SNS account, the comment field is broken.

    <Bug 3>
    If you enable comments on Jetpack’s SNS account after setting the Jetpack share button on Jetpack, the comment field will not be displayed.

    Thread Starter Senri Miura

    (@senribb)

    P.S.

    The comment field is not displayed in <Bug 3>, but if you set the share button display to OFF, it will be in the same state as <Bug 2>.

    Thread Starter Senri Miura

    (@senribb)

    Today, I’ve received the following answer (removing the connection restriction to IP addresses that send and receive from Automattic) from the support of the CoreServer, but unfortunately, the problem of Jetpack has not been fixed yet.

    from CoreServer
    —- from here
    As a result of confirmation by the department in charge of our company, some IP addresses were rejected on our server side within the range of the IP address of “192.0.64.0/18” that we contacted, and connection restrictions were enforced. ..
    The above restrictions have been lifted by the department in charge.
    However, we have a security mechanism that automatically rejects the connection source IP address that causes a high load on the server.

    Therefore, we may refuse the connection from the target IP address again, but for security reasons, we cannot stop the implementation of the above restrictions.
    Thank you for your understanding.
    —- to this point

    I’ve provided the following list of IP addresses used by Automattic, but is there anything else?

    # Allow Automattic (Jetpack)

    allow from 66.135.48.128/25
    allow from 66.155.8.0/22
    allow from 66.155.38.0/24
    allow from 69.174.248.128/25
    allow from 72.233.119.192/26
    allow from 76.74.248.128/25
    allow from 76.74.254.0/25
    allow from 76.74.255.0/25
    allow from 185.64.140.0/22
    allow from 192.0.64.0/18
    allow from 198.181.116.0/22
    allow from 192.0.64.0/255.0.64.0
    allow from 207.198.101.0/25
    allow from 207.198.112.0/23
    allow from 209.15.21.0/24
    allow from 216.151.209.64/26

    Plugin Support MadHatter

    (@madhattersez)

    Hello, there.

    It definitely sounds like the host is limiting and blocking our process based on what they consider to be high use – The Jetpack plugin may make several requests to a site, but the load is generally very low.

    The only IPs we have to whitelist are the ranges found in our hosting FAQ:

    https://jetpack.com/support/hosting-faq/

    However, if they have security stopping processes after a certain amount, even through whitelisted IPs, the solution may be to increase sever resources or find a host that doesn’t have these limitations. We have a list of recommendations for hosts that work well with Jetpack here:

    https://jetpack.com/hosting/

    Please let us know if you have any other questions.

    Thread Starter Senri Miura

    (@senribb)

    Hello, MadHatter

    Thank you for your polite commentary.
    When I checked with core server support yesterday, I got the following answer.

    ‘As a result of confirmation by the department in charge of our company, some IP addresses were rejected on our server side within the range of the IP address of “192.0.64.0/18” that we contacted, and connection restrictions were enforced.

    The above restrictions have been lifted by the department in charge.’

    For the time being, after removing the IP address restrictions, I checked the operation of Jetpack, but unfortunately the situation did not improve.

    Perhaps the cause is that the core server security process considers the source IP address to be overloaded and still limits it.
    This is in line with the view that, as MadHatter points out, “although you’re using a whitelisted IP, there’s a security outage process after a certain amount of time.”

    I’ve already contacted core server support for this issue, but I think it’s probably difficult to fix the core server security system right away.
    So far, the basic functions of Jetpack are working, so I will continue to use it in the current state.
    Unfortunately, I will give up using Jetpack’s comment function.

    Thank you very much for this time.

    Plugin Support Michelle Paese

    (@deathlynotes)

    Hey there,

    Let us know if you have any other questions or if the hosting contact you back with new solution.

    My best regards,

    Michelle C.

    Thread Starter Senri Miura

    (@senribb)

    Hello, Michelle Paese

    thank you so much.
    If the hosting company contacts me again, I’ll let you know in this thread.
    Thank you for your continued support.

    Thread Starter Senri Miura

    (@senribb)

    Hi there!

    Yesterday, I received the following contact from the hosting company CoreServer as follows.

    The response we have taken this time is to lift all restrictions by IP address, such as restrictions on the connection source IP address of behavior that is suspected of brute force attack on WordPress.

    So I’ve checked the operation of Jetpack.
    As a result, I confirmed that the following problems have been resolved on CoreServer.

    1. When I turn on / off the Jetpack extension module, a “Status 400” error occurs.
    2. Site Accelerator (CDN) does not work

    However, the phenomenon that Jetpack’s comment section was broken was not improved.
    Therefore, when I checked Jetpack’s “Known Issues” as shown below, it turned out that “Google Captcha (reCAPTCHA) by BestWebSoft” corresponds to this website.

    https://jetpack.com/support/getting-started-with-jetpack/known-issues/

    Antispam Bee, Spam Free WordPress, Bad Behavior, WP‑SpamShield, CommentLuv, Anti‑spam, Google Captcha (reCAPTCHA) by BestWebSoft
    These plugins are currently not compatible with the Jetpack Comments module.

    For the time being, if Jetpack’s comment module does not support Google Captcha (reCAPTCHA), I will not use Jetpack comments, so I will close this topic once.
    I’d like to thank all the people who cooperated in the survey.
    Thank you very much.

    Best Regards,
    Senri Miura

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.