WordPress.org

Support

Support » Plugins and Hacks » JetPack & CiviCRM conflict

JetPack & CiviCRM conflict

Viewing 11 replies - 1 through 11 (of 11 total)
  • I rolled back to Jetpack 2.0.2 and this resolved the problems I was having on two separate sites hosted by two different hosts. Also, judging from the deluge of support posts following the 2.0.4 update, there are serious problems with this particular update.

    This issue is persisting with the current release of Jetpack, 2.1.1 Would be nice to get some response from the JetPack developer about this.

    Plugin Author Jeremy Herve

    @jeherve

    Could you try to disable the Sharing and Publicize modules, and let me know if that solves the issue?

    You can find out how to disable a Jetpack module here:
    http://jetpack.me/support/#turn-off-jetpack-modules

    Ok, disabling both modules fixes the problem. Activating either one of the modules by itself, or both at the same time causes the problem.
    This seems to be the same observation many others have been seeing with regards to the conflict between JetPack since version 2.0.3, with other plugins.

    Plugin Author Jeremy Herve

    @jeherve

    Could you add this small plugin to your site? It should solve the issue:
    http://i.wpne.ws/M7Le

    There are indeed a few plugins currently conflicting with Jetpack. We try to look at all these conflicts and find out if we can solve the issue by ourselves, or if the fix has to be made in the other plugin.

    Could you send me a link to this CiviCRM plugin, so I can have a look?

    CiviCRM is more than just a plugin. Here is the main site for CiviCRM http://civicrm.org/

    You can also visit the WordPress-CiviCRM integration demo where you can go into the admin menu here: http://wordpress.demo.civicrm.org/

    The small plugin you asked me to install solved the conflict I was experiencing. I am now able to activate both sharing and publicize without losing my CiviCRM front-end content.

    Will I have to now keep this small plugin on my site indefinitely, or only until the next JetPack update?

    Plugin Author Jeremy Herve

    @jeherve

    Is that the CiviCRM plugin you use on your site?
    http://civicrm.org/extensions/wordpress-civimember-role-sync-plugin

    The plugin I gave you earlier will always work, but we would need to have a look at the CiviCRM plugin to understand how we can fix the issue, or if it can only be fixed by CiviCRM plugin authors.

    Thanks!

    No, that is just an extension for CiviCRM. YOu can download CiviCRM from sourceforge.

    I have notified the developers at CiviCRM as well and perhaps you talking directly with them may help: http://forum.civicrm.org/index.php/topic,27294.msg116645.html#msg116645.

    Plugin Author Jeremy Herve

    @jeherve

    In the other forum thread, you mention that you use shortcodes to load CiviCRM profiles.

    Are you by chance using get_the_excerpt or get_the_content or the_excerpt or the_content actions to create these shortcodes?

    CiviCRM comes with built-in shortcodes for loading CiviCRM content on the WordPress front-end. I do not know what actions are used to create these shortcodes.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘JetPack & CiviCRM conflict’ is closed to new replies.