Jetpack by WordPress.com
[resolved] Jetpack causing blank screen conflicts with other plugins (25 posts)

  1. charles_i
    Posted 3 years ago #

    I'm having all kinds of problems with conflicts with other plugins. As soon as I activate any of these with Jetpack I get a blank Plugins screen, I have to uninstall the plugin and Jetpack as well (which takes quite awhile) each time.

    All In One SEO
    Ultimate SEO
    Wordpress SEO
    Google Analytics

    I installed the Jetpack 1.9.2 release from Oct. 30th two days - it didn't make any difference.



  2. Primitive
    Posted 3 years ago #

    Jetpack doesn't conflict with either WordPress SEO or the Google Analytics plugin as far as I've noticed - I have them both running on a number of sites on a number of platforms.

    I can't comment on the others, but is there a reason you're using so many SEO plugins? Don't they all do much the same thing?

  3. charles_i
    Posted 3 years ago #

    I should have clarified, This problem occurs when any one the above plugins is installed - not all of them. Any idea if anything else could be causing this?

  4. Primitive
    Posted 3 years ago #

    It could be any number of things conflicting to be honest.

    What theme are you using?

  5. kraftyua
    Posted 3 years ago #

    The same thing has happened to me. I updated to the latest version of jetpack and my site went blank.

    I am using the Karama theme. I had to disable jetpack in order to get my site back up.

  6. Primitive
    Posted 3 years ago #

    What other plugins do you have running?
    What is your server setup? What's the PHP memory limit?

  7. kraftyua
    Posted 3 years ago #

    I had wpcu3er and WordPress Importer running, however I disabled both then reactivated jetpack and my site went back down.

    I use hostgator for my server. No idea what the PHP memory limit is, I don't see that information on my account.

  8. j_simon
    Posted 3 years ago #

    Ok, while I wrote this, I also resolved it, so I write it anyway, maybe it helps someone:

    [The short version: activation seems to use more than 32MB of memory for PHP for me, which was over the default of what PHP is allowed to use. Change it, and it works. Long version below:]

    I already tried to disable all plugins and disable the theme, did not work.

    I use:
    Wordpress 3.4.2
    Jetpack 1.9.2 <- or better: I want to use that
    Askimet 2.5.6
    CodeColorer 0.9.9
    Smart Youtube PRO 4.1.7
    Grey Opaque 1.8.5

    as I said, I already changed the theme (I did not remove it, just switched to the other) and disabled all modules. As soon as I try to aktivate jetback in the plugins area, the screen goes blank with that url:

    Now after looking into my error.log (tail -f /var/log/apache2/error.log) file I found the following:
    "PHP Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 32 bytes) in /srv/www/li305-99.members.linode.com/public_html/wordpress/wp-includes/pomo/translations.php on line 256, referer: http://blog.jsimon.at/wp-admin/update.php?action=install-plugin&plugin=jetpack&_wpnonce=dfa2f834b6"

    So, older servers with ubuntu have a default of 16MB, newer of 32MB, and jetback seems to overrun that now.

    Usually setting the memory_limit variable to something higher should work:
    f.e. in:
    sudo vi /etc/php5/apache2/php.ini

    Hope that helped someone ;)
    Cheers, Jörg

  9. Primitive
    Posted 3 years ago #

    Thanks j_simon.

    I was thinking that the memory limit might be the problem.
    A lot of CPanel based hosts let you up the limit in your own PHP.ini file, but others will just do it for you if you ask in support.

    It definitely sounds like that is the issue though!

  10. kraftyua
    Posted 3 years ago #

    Thanks. Doesn't look like I have access to change the memory limit, I'll ask support to do it for me.

  11. j_simon
    Posted 3 years ago #

    hope it helps! good luck with it ^_^
    Hm, the support should also be able to look up if memory is the problem.

    They should see a memory problem in their log for a url like YOURBLOGNAME/wp-admin/update.php?action=install-plugin&plugin=jetpack&_wpnonce=dfa2f834b6

    and if it is not that, maybe they see another issue there....

  12. kraftyua
    Posted 3 years ago #

    Working with support now, memory is not the issue. Still getting a blank screen when I activate the plugin.

  13. Primitive
    Posted 3 years ago #

    What does it say in your error_log?

  14. kraftyua
    Posted 3 years ago #

    I can't seem to find the correct error log. There is an error log icon on my control panel, but there is nothing listed in that log.
    When I look at the logs folder through my file manager, there is nothing there either.

    Any idea how I might able to find the correct error log?

  15. j_simon
    Posted 3 years ago #

    according to this link 1, the error log icon should be the right one
    [1] http://support.hostgator.com/articles/specialized-help/technical/apache-htaccess/can-i-access-my-apache-log-files

    however, according to this one [2] it seems that this is not allways working. Since you have no root access, I guess you have to ask the support again, to check for errors... (maybe send them that link ;) )
    [2] http://www.flynsarmy.com/2011/10/location-of-error-logs-in-a-cpanel-install/

    cheers, joerg

  16. kraftyua
    Posted 3 years ago #

    I will check with support again.

    In order to get my site back up after activating jetpack, I have to go into PHPmyAdmin and switch the theme from Karma to twentyten. That brings my site back up so I can access my wordpress admin panel. I then go deactivate jetpack and then activate Karma.

    Based on that, it would seem to me that the issue is jetpack and Karma, since jetpack still works with the twentyten theme.

  17. Primitive
    Posted 3 years ago #

    If the problem is with Karma, then it may be worthwhile to get in touch with the developer(s) of that theme and ask them if anyone else is reporting your issues...

  18. kraftyua
    Posted 3 years ago #

    The Karma people are blaming the problem on JetPack. They had me disable the contact forms in the JetPack options, which worked. I now have JetPack and Karma running at the same time. However, I am of course missing some of the functionality of JetPack due to that change.

  19. charles_i
    Posted 3 years ago #

    Im using the Responsive Theme and our company uses Rackspace for hosting so I can't imagine that there is any PHP 35MB limit on our server.

    I also posted the problem here because a search brought me to the same problem last week (and interestingly Jetpack immediately issued an upgrade that "solved" the problem).

    Let me know what you figure out. I'd really like to use Jetpack but at the moment it's impossible.

  20. charles_i
    Posted 3 years ago #

    j_simon was correct. I contacted Rackspace and sent them your error log info. Their response was:

    You are correct in your assumption, I am seeing similar php memory errors in your error_log: I have added a vhost.conf file for the blog subdomain to raise the memory limit to 64 MB.

    FYI for anyone else who has this issue.

    Thanks j_simon

  21. cjsmith
    Posted 3 years ago #

    I had the same problem as kraftyua with Karma and Jetpack. Disabling the contact form worked for me as well. What would we do without sites like this?

  22. Primitive
    Posted 3 years ago #

    Does your error_log say anything?

    At a guess, because Karma has its own form builder, something in that is named the same as something in the Jetpack form builder and causing the conflict.

    It really sounds like something for the Karma developers to consider to be honest as Jetpack is by far the more widely used even if Karma had a form builder first (which I have no idea if it did).

  23. dcorp
    Posted 3 years ago #

    I was shocked about seeing that my earnings are dramatically dropped and for around 24 hours i did not notice that my adsense ads were disabled on one of my sites which i updated jetpack to the latest version. (as i am using many sites for adsense, my income was not 0, so i thought there was adsense issue than my own possible problem)

    To keep long story short: Jetpack has conflict with Quick Adsense plugin and because of this, my loss is around 100 usd so far, i am glad i noticed it and disabled jetpack, my quick adsense plugin works fine now and ads are back.

    Wish i could be aware of this situation earlier...

    Does anyone else have the same issue?

    Is there a fix for this?

    Does Jetpack know about this issue?

    Please help me get it fixed or advice me other ad injection plugin so i can use jetpack + my adsense ads.


  24. charles_i
    Posted 3 years ago #

    I don't know when this memory requirement changed because I just started using jetpack. Did you check with your service provider? Make sure the memory limit in your vhost.conf file is 64 MB.

    Also, I see another update - 2.0 - was released 5 days ago.

    Hope that helps. It worked for me.

  25. Richard Munter
    Posted 3 years ago #

    For users of Karma theme + Jetpack - here are the instructions from Karma developers to fix the issue:


    I was concerned about losing Karma settings etc so tested switching themes on a test site. Didn't have any problems switching back to Karma.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Jetpack by WordPress.com
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic