Support » Plugin: Jetpack by » Jetpack causing blank screen conflicts with other plugins

  • Resolved charles_i


    I’m having all kinds of problems with conflicts with other plugins. As soon as I activate any of these with Jetpack I get a blank Plugins screen, I have to uninstall the plugin and Jetpack as well (which takes quite awhile) each time.

    All In One SEO
    Ultimate SEO
    Wordpress SEO
    Google Analytics

    I installed the Jetpack 1.9.2 release from Oct. 30th two days – it didn’t make any difference.


Viewing 15 replies - 1 through 15 (of 24 total)
  • Jetpack doesn’t conflict with either WordPress SEO or the Google Analytics plugin as far as I’ve noticed – I have them both running on a number of sites on a number of platforms.

    I can’t comment on the others, but is there a reason you’re using so many SEO plugins? Don’t they all do much the same thing?

    I should have clarified, This problem occurs when any one the above plugins is installed – not all of them. Any idea if anything else could be causing this?

    It could be any number of things conflicting to be honest.

    What theme are you using?

    The same thing has happened to me. I updated to the latest version of jetpack and my site went blank.

    I am using the Karama theme. I had to disable jetpack in order to get my site back up.

    What other plugins do you have running?
    What is your server setup? What’s the PHP memory limit?

    I had wpcu3er and WordPress Importer running, however I disabled both then reactivated jetpack and my site went back down.

    I use hostgator for my server. No idea what the PHP memory limit is, I don’t see that information on my account.

    Ok, while I wrote this, I also resolved it, so I write it anyway, maybe it helps someone:

    [The short version: activation seems to use more than 32MB of memory for PHP for me, which was over the default of what PHP is allowed to use. Change it, and it works. Long version below:]

    I already tried to disable all plugins and disable the theme, did not work.

    I use:
    Wordpress 3.4.2
    Jetpack 1.9.2 <- or better: I want to use that
    Askimet 2.5.6
    CodeColorer 0.9.9
    Smart Youtube PRO 4.1.7
    Grey Opaque 1.8.5

    as I said, I already changed the theme (I did not remove it, just switched to the other) and disabled all modules. As soon as I try to aktivate jetback in the plugins area, the screen goes blank with that url:

    Now after looking into my error.log (tail -f /var/log/apache2/error.log) file I found the following:
    “PHP Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 32 bytes) in /srv/www/ on line 256, referer:

    So, older servers with ubuntu have a default of 16MB, newer of 32MB, and jetback seems to overrun that now.

    Usually setting the memory_limit variable to something higher should work:
    f.e. in:
    sudo vi /etc/php5/apache2/php.ini

    Hope that helped someone ๐Ÿ˜‰
    Cheers, Jรถrg

    Thanks j_simon.

    I was thinking that the memory limit might be the problem.
    A lot of CPanel based hosts let you up the limit in your own PHP.ini file, but others will just do it for you if you ask in support.

    It definitely sounds like that is the issue though!

    Thanks. Doesn’t look like I have access to change the memory limit, I’ll ask support to do it for me.

    hope it helps! good luck with it ^_^
    Hm, the support should also be able to look up if memory is the problem.

    They should see a memory problem in their log for a url like YOURBLOGNAME/wp-admin/update.php?action=install-plugin&plugin=jetpack&_wpnonce=dfa2f834b6

    and if it is not that, maybe they see another issue there….

    Working with support now, memory is not the issue. Still getting a blank screen when I activate the plugin.

    What does it say in your error_log?

    I can’t seem to find the correct error log. There is an error log icon on my control panel, but there is nothing listed in that log.
    When I look at the logs folder through my file manager, there is nothing there either.

    Any idea how I might able to find the correct error log?

    according to this link 1, the error log icon should be the right one

    however, according to this one [2] it seems that this is not allways working. Since you have no root access, I guess you have to ask the support again, to check for errors… (maybe send them that link ๐Ÿ˜‰ )

    cheers, joerg

    I will check with support again.

    In order to get my site back up after activating jetpack, I have to go into PHPmyAdmin and switch the theme from Karma to twentyten. That brings my site back up so I can access my wordpress admin panel. I then go deactivate jetpack and then activate Karma.

    Based on that, it would seem to me that the issue is jetpack and Karma, since jetpack still works with the twentyten theme.

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘Jetpack causing blank screen conflicts with other plugins’ is closed to new replies.