Support » Plugin: Jetpack by WordPress.com » Jetpack Carousel not working

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Contributor Tim Moore

    (@tmoorewp)

    It doesn’t look like Jetpack is connected to WordPress.com. Have you done that?

    check again now, tried something else but now it’s as it was during my firs post, and still not working

    Plugin Contributor Tim Moore

    (@tmoorewp)

    Are you using WordPress’s [gallery] shortcode and inserting galleries in the manner described here:

    http://en.support.wordpress.com/images/gallery/#adding-a-gallery

    Yes I have, right now it’s [gallery columns="4"]

    I tried both “Image File” and “Attachment Page”

    Plugin Contributor Tim Moore

    (@tmoorewp)

    What happens if you change your theme to Twenty Eleven? Does Carousel start working?

    Yes, it does…

    there must be some issues with wp-foundation…duh!

    The WP-Foundation theme remove default gallery shortcode in library/shortcodes.php :

    // remove the standard shortcode
    remove_shortcode('gallery', 'gallery_shortcode');
    add_shortcode('gallery', 'gallery_shortcode_tbs');

    To re-enable the default gallery, try to put this in your child theme, maybe in init action :

    // remove the wp-foudation shortcode
    remove_shortcode('gallery', 'gallery_shortcode_tbs');
    add_shortcode('gallery', 'gallery_shortcode');

    It worked for me.

    Thanks Cyril, that works!
    For others remember you need to add this function after theme setup or the parent will over ride.

    function child_theme_setup() {
       remove_shortcode('gallery', 'gallery_shortcode_tbs');
       add_shortcode('gallery', 'gallery_shortcode');
    
    }
    add_action( 'after_setup_theme', 'child_theme_setup' );

    Hi there!

    I seem to have the same problem, but I don’t really understand where to put which code.

    You can put the code in your functions.php file of you theme.
    I would not edit the code in your theme editor in WordPress back-end rather edit it in notepad++ or the like because if your functions.php file has an error in it the site will break.
    Basically what you are doing is over riding the parent themes functionality in the child theme, in this case you are removing their custom gallery functionality.
    If you need help with development try odesk.com or elance.com you can get help at a good price.

    Thanks for the quick response!
    I copied it to functions.php, but it still doesn’t work :-/

    What theme are you using?
    Have you disabled all other plugins besides Jetpack to see if its a plugin conflict?

    Yes, I tested it without plugins.
    I use the Theme Portafolio

    Home

    Ask the theme author he should be able to help you.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Jetpack Carousel not working’ is closed to new replies.