Support » Plugin: Jetpack by » Jetpack Carousel not loading on the-bootstrap theme

  • Resolved conualfy



    I am using a customized version of the-bootstrap theme and I am trying to activate the Jetpack Carousel.
    This theme has some kind of carousel for gallery type posts, but I do not have any post like this. Anyways, I have activated the small plugin (Disable Hybrid’s Cleaner Gallery) to fix a problem with some galleries (have no idea if the-bootstrap uses that one).

    Option in Admin – Settings – Media is missing, too.

    The carousel tiles nice in other themes, but not on the-bootstrap unfortunately. Do you know if there is any way to force it or fix this?

    This is a link to one of my pages to see it does not load the Jetpack scripts:

    Thanks a lot,

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Jeremy Herve


    Jetpack Mechanic

    I had a look at your site, and the Carousel module doesn’t seem to be activated at the moment.

    Could you go to the Jetpack menu in your dashboard, and make sure that the Carousel module is active there?


    Yes, I am quite sure it is activated, here is the screenshot:

    You can trust me I did not change anything since yesterday. 🙂 So it is activated, but the way it includes the scripts has some interaction with something else at some point and it does not include the script (my guess, don’t know it for sure).

    PS: if you need it, I can allow you to have temporary access to my WP (or I can also send you my theme code).

    Plugin Author Jeremy Herve


    Jetpack Mechanic

    Yes, I am quite sure it is activated, here is the screenshot:

    My bad. It seems we were talking about 2 different modules: in your first post, you mentioned you were having trouble with the Carousel module. This module is not active on your site, and is a bit different from the Tiled Galleries.

    I downloaded the-bootstrap, and it seems it includes a function that modifies the behaviour of the core galleries. Since Tiled Galleries are built on top of core galleries, they cannot be added to a modified version of these galleries.

    Could you try to remove this function from your customized theme? The function name is the_bootstrap_post_gallery


    Cool, it worked, thanks a lot! Yes, I was thinking just like they are one single plugin, sorry for the confusion created, but in the end a good thing came out of it 🙂

    BTW, great support!

    I had to temporary activate some other theme and then I got the desired interaction.

    Now I only have another bug in Jetpack Carousel: using left/right keyboard keys it jumps 2 images 🙂 I made a screen recording and uploaded it here:

    The left-right problem is caused by an interaction with Lightbox Plus ColorBox plugin. Disabling Lightbox plus fixed it.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Jetpack Carousel not loading on the-bootstrap theme’ is closed to new replies.