Support » Plugin: Jetpack by WordPress.com » Jetpack Carousel Functionality in New WordPress Editor

  • Resolved mrjarbenne

    (@mrjarbenne)


    I have the Gutenberg plugin active on my site and noticed that Galleries I create using the core Gallery block don’t trigger the Jetpack Carousel functionality. Is there a setting I’m missing, or is this just on the roadmap, but support for this function hasn’t been extended to the new editor yet? Thanks for any info you can provide.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic πŸš€

    Could you try to update to Jetpack 6.8, that was released a few hours ago? The latest version of Jetpack adds Carousel support for the Gallery block.

    Let me know how it goes.

    Hi, I just updated to Jetpack 6.8 and have been experimenting with galleries using the Gutenberg plugin. The carousel function works in a Gutenberg post now, so thanks for that! I did notice that unlike the classic editor (or the classic block in the Gutenberg editor) I can’t select a gallery type (Tiled Mosaic, Square Tiles, Circles, or Tiled Columns). Is that something you will be adding in the future, or is it no longer available with the Gutenberg editor? Thanks!

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic πŸš€

    did notice that unlike the classic editor (or the classic block in the Gutenberg editor) I can’t select a gallery type (Tiled Mosaic, Square Tiles, Circles, or Tiled Columns). Is that something you will be adding in the future, or is it no longer available with the Gutenberg editor?

    That’s something we are working on right now. You can expect Tiled Galleries to be available in the block editor in the next release!

    Great, glad to hear it, thank you very much!

    Hi Jeremy,

    I had the same issue as the OP and updated to the latest version of JetPack 6.8

    The Carousel is now working but no matter what image I click on, it takes me to the first in the gallery. I cleared caches and even created a new page/gallery to be sure.

    Thanks

    I haven’t been able to test this yet. I had to regress back to 6.7 because 6.8 is creating a 500 error in the editor on a Custom Post Type on my Multisite install (not WooCommerce, but not one of the packaged Jetpack CPTs either). I’m watching this ticket with interest: https://github.com/Automattic/jetpack/issues/10727

    • This reply was modified 4 months, 3 weeks ago by  mrjarbenne.

    If I set the gallery images so they link to Attachment Page, then the correct image opens. But then the Carousel fix no longer works… πŸ™

    This was the fix, correct?
    https://github.com/Automattic/jetpack/pull/10646

    • This reply was modified 4 months, 3 weeks ago by  ecotechie.
    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic πŸš€

    The Carousel is now working but no matter what image I click on, it takes me to the first in the gallery. I cleared caches and even created a new page/gallery to be sure.

    Could you post a link to one of your galleries so I can take a closer look? Could you also let me know how you created that gallery in the editor?

    This was the fix, correct?
    https://github.com/Automattic/jetpack/pull/10646

    That is correct.

    Here is the link, I created this one a while back through the block editor.

    I also created others as tests with the newest versions of Gutenberg and Jetpack with the same results.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic πŸš€

    Oh, I see what you mean now, thank you! I was able to reproduce. We’ll get that fixed.

    You can follow our progress on this here:
    https://github.com/Automattic/jetpack/issues/10747

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.