The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

Jetpack by WordPress.com
[resolved] Jetpack breaks Leaflet Maps Marker plugin (8 posts)

  1. RobertHarm
    Posted 3 years ago #

    If you use Jetpack 2.0.4 together with my plugin Leaflet Maps Marker (v3.2.4 - http://downloads.wordpress.org/plugin/leaflet-maps-marker.3.2.4.zip), my maps get broken after the first connect to the wordpress account within Jetpack.

    I dont know what exactly happens within Jetpack, just as I look into the html source afterwards, I see the output of my global $lmmjs_out variable duplicated or sometimes even more often available. If I disconnect from WordPress account, output is normal again.

    I will implement a workaround for 3.2.5 but hope that someone from Automatic can take a look into this and see whats going on here. I´d be glad to help of course.
    best regards,



  2. RobertHarm
    Posted 3 years ago #

    unfortunately still no response from you - the error exists even with the latest update of Jetpack - please take a look into this issue - I´d be glad to help if you have any questions!

  3. Christopher Finke
    Design Engineer at Automattic
    Plugin Contributor

    Posted 3 years ago #

    Hi Robert, I'm confirming that I can reproduce the problem with Leaflet Maps Marker 3.2.4 and the latest Jetpack, and that it goes away when the Publicize module is disabled. I'll work on a fix.

  4. RobertHarm
    Posted 3 years ago #


  5. RobertHarm
    Posted 3 years ago #

    unfortunately, this bug is still not fixed with the latest version - any news when a fix will be available?

  6. Jeremy Herve
    Jetpack Mechanic
    Plugin Author

    Posted 3 years ago #


    The problem seems to be linked with the way your plugin handles shortcodes.

    A similar problem was reported in the NextGen plugin:

    You can find details about it in this WP-Hackers thread:

    Could you try to update your plugin based on Otto's recommendations?

  7. RobertHarm
    Posted 3 years ago #

    Hi Jeremy,

    thanks for taking a look into this issue. I studied the posts you linked to and tried to fix it.
    Unfortunately with no success :-/

    In leaflet-maps-marker.php within the function lmm_frontend_enqueue_stylesheets()
    I use

    global $wp_query, $wp_version;
    $posts = $wp_query->posts;

    which from my understanding according to Otto should be the reason for this bug. I also talked to Ian Dunn who reported this problem and also thought that his case seems to be different.

    But even if I completely remove this code/css check the js output still gets duplicated. So as there
    is no other code/function within my plugin which uses $posts I wonder if this really is the
    reason for this bug.

    Any help would be really appreciated!


  8. RobertHarm
    Posted 3 years ago #

    bug got fixed with latest Jetpack release v2.2

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Jetpack by WordPress.com
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic