Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » Jetpack Blocks missing

  • Resolved cantraig

    (@cantraig)


    I recently had trouble with a jetpack form ‘newsletter subscription’ where the form was unsubscribing guests instead of subscribing them.
    I decided to remove the block and try and re install it. I’ve now got no Jetpack blocks at all.
    If i go to a page that already has a jetpack block from before then it tells me
    – Your site does not include support for the ‘jetpack block name’, you can leave the block intact, convert to a html custom or remove it entirely.

    any ideas what’s going on?
    i have disabled and removed jetpack and re added it with no success.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Contributor Stef

    (@erania-pinnera)

    Hi @cantraig,

    Thanks for reporting this:

    I recently had trouble with a jetpack form ‘newsletter subscription’ where the form was unsubscribing guests instead of subscribing them.

    I tried to replicate this on my test site with no success. Is it possible that there was another plugin that was conflicting with this block?

    When you re-added Jetpack, did the block behave again the way you reported? If so, can you try temporarily to deactivate all your plugins and check if the problem gets fixes that way? If it works, then reactivate each plugin one-by-one to find out which one is causing problems.

    It’d also useful if you can share your site URL with us; if you want it to remain private, you can also contact us via this contact form:
    Contact Support.

    Thread Starter cantraig

    (@cantraig)

    Hi @erania-pinnera The problem i now have is that i have no jetpack blocks available at all.
    So when i removed the block i could not re add it.
    Throughout the entire site not just the one page. i have lost access to all blocks associated to Jetpack.
    On any page where i already had Jetpack blocks active, i have a message to say i can remove the block entirely but i can not edit, add or do anything relating to any jetpack block.

    i have two websites. both identical (just different brands). the problem only with one Cantraig.co.uk

    • This reply was modified 4 months, 1 week ago by cantraig.
    Plugin Contributor Jen H.

    (@jenhooks)

    Thanks for the followup, @cantraig.

    I see Stef recommended you temporarily toggle off other plugins to see if there’s something else that’s conflicting with Jetpack and preventing blocks from functioning as expected. Did you do that and find anything noteworthy?

    Do you have any pending updates in the Dashboard > Updates section of your WP Admin? If so, please update anything you see there.

    Do you know how to check your browser’s console for errors? If not, this page in the WordPress Codex has guidance for how to do so in different web browsers:

    Using Your Browser to Diagnose JavaScript Errors

    Please attempt to work with blocks, then check the page for errors, and let us know what you find. You can use a service like http://snipboard.io/ to share a screenshot with us. Or, you can copy and paste any error you see in a reply back to us here.

    Looking forward to hearing back from you!

    Thread Starter cantraig

    (@cantraig)

    Hello, sorry for the delayed response.
    So i went through and checked through your steps and nothing has worked.
    Here is a screen shot of the error message
    https://snipboard.io/LuesAJ.jpg

    I no longer have access to any Jetpack blocks at all, in fact the blocks available to me are now very limited.

    Plugin Contributor Jen H.

    (@jenhooks)

    Hey @cantraig,

    Please go to your Jetpack Settings and make sure you have the Contact Form enabled. It looks like it is currently disabled. You might also want to enable Extra Sidebar Widgets. You can manage all Jetpack features from one page here.

    Does this help?

    Plugin Support Animesh Gaurav

    (@bizanimesh)

    Hi @cantraig

    It has been more than one week since we have heard from you, so I’m marking this topic as resolved. But If you have any further questions or need some more help, you’re welcome to reply here or open another thread.

    Thanks!

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.